summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2024-10-10 20:41:25 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2024-10-10 20:55:18 +0200
commit3d11da60e79c1d1c07b75ac038b432d9c537c2e9 (patch)
tree1db7f399c99d0106637e24d76a7627f02f2a8fb0 /kde-apps/dolphin-plugins-dropbox
parentmedia-sound/krecorder: 24.08.2 version bump (diff)
downloadgentoo-3d11da60e79c1d1c07b75ac038b432d9c537c2e9.tar.gz
gentoo-3d11da60e79c1d1c07b75ac038b432d9c537c2e9.tar.bz2
gentoo-3d11da60e79c1d1c07b75ac038b432d9c537c2e9.zip
kde-apps/dolphin-plugins-dropbox: 24.08.2 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-apps/dolphin-plugins-dropbox')
-rw-r--r--kde-apps/dolphin-plugins-dropbox/Manifest1
-rw-r--r--kde-apps/dolphin-plugins-dropbox/dolphin-plugins-dropbox-24.08.2.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/kde-apps/dolphin-plugins-dropbox/Manifest b/kde-apps/dolphin-plugins-dropbox/Manifest
index 28934a2a7807..8df4dc4a131d 100644
--- a/kde-apps/dolphin-plugins-dropbox/Manifest
+++ b/kde-apps/dolphin-plugins-dropbox/Manifest
@@ -1,2 +1,3 @@
DIST dolphin-plugins-24.05.2.tar.xz 305512 BLAKE2B 4f5a2b8e7e7131d55610622669398c537f5ef2a0f69bdcce431d28efd1784e31bd57fccabe93d380d38b7cfbbedb0f7ef79deb6de297deba57420373767c9a38 SHA512 7e8df3f14f0db6114a85e3077a515ea598f436d52ce6d199ead97119604455e06cc8585281cd2aa49068134505bce8bcce461976fad791d5729d278344a30c56
DIST dolphin-plugins-24.08.1.tar.xz 317532 BLAKE2B 1f8bbcbcf79ca80e0744cbf5a1ecc4507d1e222c6ef179e01aac62361625d550702d014e28bb409d87cafad5bd57ae5d25bbc289177685681e84aa4261ac4b17 SHA512 d123197d4669611f0d12ad128967686d11b865865472028e60916e85bc4f0a5159e023a2784cba04e069ea5dbd9fd0801617b73e4033cffe1f6d815895aac59c
+DIST dolphin-plugins-24.08.2.tar.xz 317744 BLAKE2B 5ea4755bee6d5ec3a3dbb30e1afe290818bdb57e14421fbb9a907f8f791e6001eef8cf134ec3d9415ca43824153bf55096f8f3e1ee2434a58795da979957a2db SHA512 c89a7a6d9f1a2d567522e126e25b52290205f96166ceb9b95c8aa0fbcf28424891ed1e60a1cdd4b158fd4ed48bb3b7a6bcdb6c79fe712b1cbdeb13c0c275a1f5
diff --git a/kde-apps/dolphin-plugins-dropbox/dolphin-plugins-dropbox-24.08.2.ebuild b/kde-apps/dolphin-plugins-dropbox/dolphin-plugins-dropbox-24.08.2.ebuild
new file mode 100644
index 000000000000..b33625039bc4
--- /dev/null
+++ b/kde-apps/dolphin-plugins-dropbox/dolphin-plugins-dropbox-24.08.2.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+KDE_ORG_NAME="dolphin-plugins"
+MY_PLUGIN_NAME="dropbox"
+PVCUT=$(ver_cut 1-3)
+KFMIN=6.5.0
+QTMIN=6.7.2
+inherit ecm gear.kde.org
+
+DESCRIPTION="Dolphin plugin for Dropbox service integration"
+HOMEPAGE="https://apps.kde.org/dolphin_plugins/"
+
+LICENSE="GPL-2" # TODO: CHECK
+SLOT="6"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ >=dev-qt/qtbase-${QTMIN}:6[gui,network,widgets]
+ >=kde-apps/dolphin-${PVCUT}:6
+ >=kde-frameworks/kcoreaddons-${KFMIN}:6
+ >=kde-frameworks/ki18n-${KFMIN}:6
+ >=kde-frameworks/kio-${KFMIN}:6
+ >=kde-frameworks/ktextwidgets-${KFMIN}:6
+ >=kde-frameworks/kxmlgui-${KFMIN}:6
+"
+RDEPEND="${DEPEND}
+ >=kde-apps/dolphin-plugins-common-${PV}
+ net-misc/dropbox-cli
+"
+
+src_prepare() {
+ ecm_src_prepare
+ ecm_punt_po_install
+ # qtconcurrent only required by git
+ ecm_punt_qt_module Concurrent
+ # solid, qtdbus only required by mountiso
+ ecm_punt_qt_module DBus
+ ecm_punt_kf_module Solid
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_${MY_PLUGIN_NAME}=ON
+ -DBUILD_bazaar=OFF
+ -DBUILD_git=OFF
+ -DBUILD_hg=OFF
+ -DBUILD_makefileactions=OFF
+ -DBUILD_mountiso=OFF
+ -DBUILD_svn=OFF
+ )
+ ecm_src_configure
+}