summaryrefslogtreecommitdiff
path: root/gui-wm
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-03-25 15:53:23 +0000
committerSam James <sam@gentoo.org>2021-03-25 15:56:38 +0000
commit893ef30a570d5d1e202e6b9e007eda4bec663b67 (patch)
treeb088ecca0203eb4eeee8b81a4b3d8ff83c9119d5 /gui-wm
parentdev-lang/php: Include upstream patch on 8.0 slot for pdo_firebird (diff)
downloadgentoo-893ef30a570d5d1e202e6b9e007eda4bec663b67.tar.gz
gentoo-893ef30a570d5d1e202e6b9e007eda4bec663b67.tar.bz2
gentoo-893ef30a570d5d1e202e6b9e007eda4bec663b67.zip
gui-wm/hikari: use emake instead of (b)make directly
PMS guarantees [0] that 'emake' respects ${MAKE}, so let's use that to ensure that e.g. ${MAKEFLAGS} from the user is respected. [0] https://dev.gentoo.org/~ulm/pms/head/pms.html#x1-12800012.3.8 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'gui-wm')
-rw-r--r--gui-wm/hikari/hikari-2.2.2-r1.ebuild19
1 files changed, 12 insertions, 7 deletions
diff --git a/gui-wm/hikari/hikari-2.2.2-r1.ebuild b/gui-wm/hikari/hikari-2.2.2-r1.ebuild
index a9bbaec4c529..249a1164a1ed 100644
--- a/gui-wm/hikari/hikari-2.2.2-r1.ebuild
+++ b/gui-wm/hikari/hikari-2.2.2-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 2019-2020 Gentoo Authors
+# Copyright 2019-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit multiprocessing toolchain-funcs
+inherit toolchain-funcs
DESCRIPTION="Wayland compositor inspired by CWM"
HOMEPAGE="https://hikari.acmelabs.space/"
@@ -45,7 +45,8 @@ pkg_setup() {
}
src_compile() {
- ${MAKE} -j$(makeopts_jobs) VERSION="{PV}" \
+ emake \
+ VERSION="{PV}" \
CC="$(tc-getCC)" \
CFLAGS_EXTRA="${CFLAGS}" \
LDFLAGS_EXTRA="${LDFLAGS}" \
@@ -55,12 +56,16 @@ src_compile() {
$(usex screencopy -DWITH_SCREENCOPY "") \
$(usex virtual-io -DWITH_VIRTUAL_INPUT "") \
$(usex X -DWITH_XWAYLAND "") \
- all || die
+ all
}
src_install() {
- ${MAKE} DESTDIR="${D}" PREFIX=/usr ETC_PREFIX=/ \
- $(usex suid "" -DWITHOUT_SUID) \
- install || die
+ emake \
+ DESTDIR="${D}" \
+ PREFIX=/usr \
+ ETC_PREFIX=/ \
+ $(usex suid "" -DWITHOUT_SUID) \
+ install
+
doman share/man/man1/hikari.1
}