summaryrefslogtreecommitdiff
path: root/gui-wm
diff options
context:
space:
mode:
authorJulien Roy <julien@jroy.ca>2024-11-16 22:33:41 -0500
committerYixun Lan <dlan@gentoo.org>2024-11-17 09:58:53 +0000
commit1daff822d1a2211fac6e8356eb498e8fadae89d3 (patch)
tree974b5f66d240db9a9b1d0b4190484feb8bcaa59b /gui-wm
parentgui-libs/hyprutils: add 0.2.6 (diff)
downloadgentoo-1daff822d1a2211fac6e8356eb498e8fadae89d3.tar.gz
gentoo-1daff822d1a2211fac6e8356eb498e8fadae89d3.tar.bz2
gentoo-1daff822d1a2211fac6e8356eb498e8fadae89d3.zip
gui-wm/hyprland: add 0.45.0
Signed-off-by: Julien Roy <julien@jroy.ca> Signed-off-by: Yixun Lan <dlan@gentoo.org>
Diffstat (limited to 'gui-wm')
-rw-r--r--gui-wm/hyprland/Manifest1
-rw-r--r--gui-wm/hyprland/hyprland-0.45.0.ebuild100
2 files changed, 101 insertions, 0 deletions
diff --git a/gui-wm/hyprland/Manifest b/gui-wm/hyprland/Manifest
index 846a3f0f43d2..e48206281d0a 100644
--- a/gui-wm/hyprland/Manifest
+++ b/gui-wm/hyprland/Manifest
@@ -1,3 +1,4 @@
DIST hyprland-0.42.0.gh.tar.gz 54225438 BLAKE2B a947289c5568408d71383034a290f114b974f442ed1f56ac3ec30e49519ee886ac83e1f2611577a7240a555480a59bc01defb79b2aca2122ef0d81ea007f5486 SHA512 839916957abc867ad9a3a32b6f74830055060b99c4c1de314f71a85f8d55ef051c5adb7c79dd7a7e10f81d1130aa032458bb65ce2454198a79faa719021f66af
DIST hyprland-0.43.0.gh.tar.gz 54388932 BLAKE2B 610afadde6e56cb576d96c1d704327534d3ab50e69b091e9b44e9f901dbdfcd38f8a3c6a40f7fd3e843e5dda884ea1e93a24e085446861104019be9489a0a666 SHA512 521adcfb9ef55d5ad45192566856c20619942e8229f41400d2534531458dd3e54673b9dd3a0c3360280ccaaf35f5ac48393553a8549f147b701aa26522cec37b
DIST hyprland-0.44.1.gh.tar.gz 54398098 BLAKE2B ab5b52fa27591ad1f6db524663a85c2eb3f1137c8a55d6eaad9a41837fe057d6a92a75fb3bec930693a10311e3b82488ff94af86f4c2d58557879bffea02426f SHA512 2ffa16a180ec9f9e6b20481b0724e24524a499f7a224f72598426a6630c675632f2447a2f7dfd4609e8da9a86dda7919e40002a91dc917af2541e639fb4d542d
+DIST hyprland-0.45.0.gh.tar.gz 54409358 BLAKE2B 9744b525d2128d3723e42267620fa0b2e593eea13c564c3f2e38264dda97eacc422d44dc3c86b79deadbc785ba6f121148206ca47fb7f30b07722c2ef448199e SHA512 06b0d3eee9831e2f1dfa5e93c12cea82d3bcfa80685cfacac8f076a4467848c77b5bb06d8c389046588c1cc2340a2405c22b09794fec37bae4a9e3697a0875a2
diff --git a/gui-wm/hyprland/hyprland-0.45.0.ebuild b/gui-wm/hyprland/hyprland-0.45.0.ebuild
new file mode 100644
index 000000000000..cab0caee888f
--- /dev/null
+++ b/gui-wm/hyprland/hyprland-0.45.0.ebuild
@@ -0,0 +1,100 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson toolchain-funcs
+
+DESCRIPTION="A dynamic tiling Wayland compositor that doesn't sacrifice on its looks"
+HOMEPAGE="https://github.com/hyprwm/Hyprland"
+
+if [[ "${PV}" = *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/hyprwm/${PN^}.git"
+else
+ SRC_URI="https://github.com/hyprwm/${PN^}/releases/download/v${PV}/source-v${PV}.tar.gz -> ${P}.gh.tar.gz"
+ S="${WORKDIR}/${PN}-source"
+
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="X legacy-renderer systemd"
+
+# hyprpm (hyprland plugin manager) requires the dependencies at runtime
+# so that it can clone, compile and install plugins.
+HYPRPM_RDEPEND="
+ app-alternatives/ninja
+ >=dev-build/cmake-3.30
+ dev-build/meson
+ dev-vcs/git
+ virtual/pkgconfig
+"
+RDEPEND="
+ ${HYPRPM_RDEPEND}
+ dev-cpp/tomlplusplus
+ dev-libs/glib:2
+ dev-libs/libinput
+ >=dev-libs/udis86-1.7.2
+ >=dev-libs/wayland-1.22.90
+ >=gui-libs/aquamarine-0.4.2
+ >=gui-libs/hyprcursor-0.1.9
+ media-libs/libglvnd
+ x11-libs/cairo
+ x11-libs/libdrm
+ x11-libs/libxkbcommon
+ x11-libs/pango
+ x11-libs/pixman
+ x11-libs/libXcursor
+ X? (
+ x11-libs/libxcb:0=
+ x11-base/xwayland
+ x11-libs/xcb-util-errors
+ x11-libs/xcb-util-wm
+ )
+"
+DEPEND="
+ ${RDEPEND}
+ >=dev-libs/hyprland-protocols-0.4
+ >=dev-libs/hyprlang-0.3.2
+ >=dev-libs/wayland-protocols-1.36
+ >=gui-libs/hyprutils-0.2.3
+"
+BDEPEND="
+ || ( >=sys-devel/gcc-14:* >=sys-devel/clang-18:* )
+ app-misc/jq
+ dev-build/cmake
+ >=dev-util/hyprwayland-scanner-0.3.10
+ virtual/pkgconfig
+"
+
+pkg_setup() {
+ [[ ${MERGE_TYPE} == binary ]] && return
+
+ if tc-is-gcc && ver_test $(gcc-version) -lt 14 ; then
+ eerror "Hyprland requires >=sys-devel/gcc-14 to build"
+ eerror "Please upgrade GCC: emerge -v1 sys-devel/gcc"
+ die "GCC version is too old to compile Hyprland!"
+ elif tc-is-clang && ver_test $(clang-version) -lt 18 ; then
+ eerror "Hyprland requires >=sys-devel/clang-18 to build"
+ eerror "Please upgrade Clang: emerge -v1 sys-devel/clang"
+ die "Clang version is too old to compile Hyprland!"
+ fi
+}
+
+src_prepare() {
+ # skip version.h
+ sed -i -e "s|scripts/generateVersion.sh|echo|g" meson.build || die
+ default
+}
+
+src_configure() {
+ local emesonargs=(
+ $(meson_feature legacy-renderer legacy_renderer)
+ $(meson_feature systemd)
+ $(meson_feature X xwayland)
+ )
+
+ meson_src_configure
+}