summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <mmk@levelnine.at>2022-07-08 20:53:01 +0200
committerMatthew Thode <prometheanfire@gentoo.org>2022-07-23 15:41:46 -0500
commitb0dd926b35256908500ab0d48681695c8f90fcf5 (patch)
tree09a07540205f1853b091997185e41c24526b7239 /gui-wm/sway/sway-9999.ebuild
parentmail-client/claws-mail: fix build with USE=-gnutls (diff)
downloadgentoo-b0dd926b35256908500ab0d48681695c8f90fcf5.tar.gz
gentoo-b0dd926b35256908500ab0d48681695c8f90fcf5.tar.bz2
gentoo-b0dd926b35256908500ab0d48681695c8f90fcf5.zip
gui-wm/sway: EAPI bump, minor improvements
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Michael Mair-Keimberger <mmk@levelnine.at> Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'gui-wm/sway/sway-9999.ebuild')
-rw-r--r--gui-wm/sway/sway-9999.ebuild32
1 files changed, 21 insertions, 11 deletions
diff --git a/gui-wm/sway/sway-9999.ebuild b/gui-wm/sway/sway-9999.ebuild
index 3c0073c3c363..8b8ee2335dc1 100644
--- a/gui-wm/sway/sway-9999.ebuild
+++ b/gui-wm/sway/sway-9999.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-inherit meson
+inherit meson optfeature
DESCRIPTION="i3-compatible Wayland window manager"
HOMEPAGE="https://swaywm.org"
@@ -20,7 +20,7 @@ fi
LICENSE="MIT"
SLOT="0"
-IUSE="grimshot +man +swaybar +swaybg +swayidle +swaylock +swaymsg +swaynag tray wallpapers X"
+IUSE="grimshot +man +swaybar +swaynag tray wallpapers X"
DEPEND="
>=dev-libs/json-c-0.13:0=
@@ -34,23 +34,20 @@ DEPEND="
x11-libs/pixman
media-libs/mesa[gles2,libglvnd(+)]
swaybar? ( x11-libs/gdk-pixbuf:2 )
- swaybg? ( gui-apps/swaybg )
- swayidle? ( gui-apps/swayidle )
- swaylock? ( gui-apps/swaylock )
tray? ( || (
sys-apps/systemd
sys-auth/elogind
sys-libs/basu
) )
- wallpapers? ( x11-libs/gdk-pixbuf:2[jpeg] )
+ wallpapers? ( gui-apps/swaybg[gdk-pixbuf(+)] )
X? ( x11-libs/libxcb:0= )
"
if [[ ${PV} == 9999 ]]; then
- DEPEND+="~gui-libs/wlroots-9999:=[X=]"
+ DEPEND+="~gui-libs/wlroots-9999:=[X?]"
else
DEPEND+="
- >=gui-libs/wlroots-0.16:=[X=]
- <gui-libs/wlroots-0.17:=[X=]
+ >=gui-libs/wlroots-0.16:=[X?]
+ <gui-libs/wlroots-0.17:=[X?]
"
fi
RDEPEND="
@@ -74,7 +71,7 @@ if [[ ${PV} == 9999 ]]; then
else
BDEPEND+="man? ( >=app-text/scdoc-1.9.3 )"
fi
-REQUIRED_USE="grimshot? ( swaymsg )"
+REQUIRED_USE="tray? ( swaybar )"
src_configure() {
local emesonargs=(
@@ -101,3 +98,16 @@ src_install() {
dobin contrib/grimshot
fi
}
+
+pkg_postinst() {
+ optfeature_header "There are several packages that may be useful with sway:"
+ optfeature "wallpaper utility" gui-apps/swaybg
+ optfeature "idle management utility" gui-apps/swayidle
+ optfeature "simple screen locker" gui-apps/swaylock
+ optfeature "lightweight notification daemon" gui-apps/mako
+ echo
+ einfo "For a list of additional addons and tools usable with sway please"
+ einfo "visit the offical wiki at:"
+ einfo "https://github.com/swaywm/sway/wiki/Useful-add-ons-for-sway"
+ einfo "Please note that some of them might not (yet) available on gentoo"
+}