summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Fore <csfore@posteo.net>2024-10-15 15:49:04 -0400
committerArthur Zamarin <arthurzam@gentoo.org>2024-10-17 19:13:43 +0300
commit6789d55b3e527e10adb0572681dd2ba80973873a (patch)
treeab84974891741c4f00a0fca0dfc511e39f14c09e /gui-libs
parentnet-fs/samba: add 4.19.9 (diff)
downloadgentoo-6789d55b3e527e10adb0572681dd2ba80973873a.tar.gz
gentoo-6789d55b3e527e10adb0572681dd2ba80973873a.tar.bz2
gentoo-6789d55b3e527e10adb0572681dd2ba80973873a.zip
gui-libs/neatvnc: add 0.8.1, security bump
- Tests pass Bug: https://bugs.gentoo.org/937140 Signed-off-by: Christopher Fore <csfore@posteo.net> Closes: https://github.com/gentoo/gentoo/pull/39005 Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'gui-libs')
-rw-r--r--gui-libs/neatvnc/Manifest1
-rw-r--r--gui-libs/neatvnc/neatvnc-0.8.1.ebuild86
2 files changed, 87 insertions, 0 deletions
diff --git a/gui-libs/neatvnc/Manifest b/gui-libs/neatvnc/Manifest
index a9370b3619d2..0eb808121e06 100644
--- a/gui-libs/neatvnc/Manifest
+++ b/gui-libs/neatvnc/Manifest
@@ -1 +1,2 @@
DIST neatvnc-0.8.0.tar.gz 661726 BLAKE2B 075831ad8f2a4e209b316b848ac2f5b2dbcd0ecf36e2ecc2b264be255ca0250d9a61ae5df1c522c310459cc2a536958cb01567ee640fca52db3966329d89cd09 SHA512 bd5bfbcec88711a64eb45c12cad208d594f24e3812d98ccb9eb3a3f8a933df3040fcb21e4bdf0df3ea44332096b6f0bca6dcb8f4be15d42541ab98b2295d4091
+DIST neatvnc-0.8.1.tar.gz 661911 BLAKE2B 7d17e14cef3af1de509387581ea632ef967a9a669f26b85adb7e0f3e725fbe15125faf85bf71e75f926cf3b1508eafe600fc4d2b937e34c738dae9427459fb05 SHA512 4c5701765ba78e8fbfff71054988760b5a705946798e709d6905e63ac457f4c2da72aa0866e3cb3832b9aff0722199c1fb52869373677310ba22620413ed6b03
diff --git a/gui-libs/neatvnc/neatvnc-0.8.1.ebuild b/gui-libs/neatvnc/neatvnc-0.8.1.ebuild
new file mode 100644
index 000000000000..d92fdca31640
--- /dev/null
+++ b/gui-libs/neatvnc/neatvnc-0.8.1.ebuild
@@ -0,0 +1,86 @@
+# Copyright 2020-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+DESCRIPTION="Liberally licensed VNC server library with a clean interface"
+HOMEPAGE="https://github.com/any1/neatvnc/"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/any1/neatvnc.git"
+else
+ SRC_URI="https://github.com/any1/neatvnc/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+fi
+
+LICENSE="ISC"
+SLOT="0"
+IUSE="examples gbm h264 jpeg ssl test tracing websockets"
+REQUIRED_USE="h264? ( gbm )"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ =dev-libs/aml-0.3*
+ sys-libs/zlib
+ x11-libs/pixman
+ examples? (
+ media-libs/libpng:=
+ )
+ gbm? ( media-libs/mesa )
+ h264? (
+ media-video/ffmpeg:=
+ x11-libs/libdrm
+ )
+ jpeg? ( media-libs/libjpeg-turbo:= )
+ ssl? ( net-libs/gnutls:= )
+ tracing? ( dev-debug/systemtap )
+ websockets? (
+ dev-libs/gmp:=
+ dev-libs/nettle:=[gmp]
+ )
+"
+DEPEND="
+ ${RDEPEND}
+ x11-libs/libdrm
+"
+BDEPEND="
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ "${FILESDIR}/neatvnc-0.8.0-fix-tracing-undeclared-variable.patch"
+)
+
+src_prepare() {
+ default
+
+ # useful soname
+ sed -i -e "s/'0.0.0'/meson.project_version()/" meson.build || die
+}
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use examples)
+ $(meson_use test tests)
+ $(meson_feature jpeg)
+ $(meson_feature ssl tls)
+ $(meson_feature websockets nettle)
+ $(meson_use tracing systemtap)
+ $(meson_feature gbm)
+ $(meson_feature h264)
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ einstalldocs
+
+ if use examples; then
+ newbin "${BUILD_DIR}"/examples/draw neatvnc-example-draw
+ newbin "${BUILD_DIR}"/examples/png-server neatvnc-example-png-server
+ fi
+}