summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn M. Harris Jr. <johnmh@johnmh.me>2024-10-26 12:04:28 -0700
committerJames Le Cuirot <chewi@gentoo.org>2024-10-29 21:43:05 +0000
commit0e22093d461361dae529845fc0f260644a37347a (patch)
tree6954856db53e65b1080b6e4d46a4572862a70439 /gui-libs/gtk-layer-shell
parentdev-cpp/sdbus-c++: add 2.0.0 (diff)
downloadgentoo-0e22093d461361dae529845fc0f260644a37347a.tar.gz
gentoo-0e22093d461361dae529845fc0f260644a37347a.tar.bz2
gentoo-0e22093d461361dae529845fc0f260644a37347a.zip
gui-libs/gtk-layer-shell: add 0.9.0
Signed-off-by: John M. Harris Jr. <johnmh@johnmh.me> Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'gui-libs/gtk-layer-shell')
-rw-r--r--gui-libs/gtk-layer-shell/Manifest1
-rw-r--r--gui-libs/gtk-layer-shell/gtk-layer-shell-0.9.0.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/gui-libs/gtk-layer-shell/Manifest b/gui-libs/gtk-layer-shell/Manifest
index 21064712c5a4..d3f445cf7199 100644
--- a/gui-libs/gtk-layer-shell/Manifest
+++ b/gui-libs/gtk-layer-shell/Manifest
@@ -1 +1,2 @@
DIST gtk-layer-shell-0.8.2.tar.gz 137693 BLAKE2B 8c36e37fe0e675bfa9f3bfb6c4013ac7b137d27615cb29bd750c4cbbff36754986d0608cb97e427972e9108b048b6bca5611e89c01275aabec05c0b1fc9b7e62 SHA512 e3b56612dab2527d5242b8305362c88100de3eac76cee32ce51791cbc77df38a5052143bf4bf5781a90fa62e026a758ef9d10dc5b4292b0b334983842fad632c
+DIST gtk-layer-shell-0.9.0.tar.gz 141591 BLAKE2B 154e4b269978cb0b7d9e03637f951b54fafd30c17de826b4c6b5cbfb612594631590145d8a0988c5abd64c12d7b5483810dec19d2ef721f8b6f97aed94edfa14 SHA512 38179dd83a0828740ca8e2cc27fe3708f61107e88246644745da6c300da03ce04b17dd7117087946a68401a43176a599bdb98ed50936602d2b2540449c0e9066
diff --git a/gui-libs/gtk-layer-shell/gtk-layer-shell-0.9.0.ebuild b/gui-libs/gtk-layer-shell/gtk-layer-shell-0.9.0.ebuild
new file mode 100644
index 000000000000..96f32e755741
--- /dev/null
+++ b/gui-libs/gtk-layer-shell/gtk-layer-shell-0.9.0.ebuild
@@ -0,0 +1,57 @@
+# Copyright 2020-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+VALA_USE_DEPEND="vapigen"
+inherit vala meson python-any-r1
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/wmww/${PN}"
+else
+ SRC_URI="https://github.com/wmww/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86"
+fi
+
+DESCRIPTION="Library to create desktop components for Wayland using the Layer Shell protocol"
+HOMEPAGE="https://github.com/wmww/gtk-layer-shell"
+
+LICENSE="MIT-with-advertising LGPL-3+"
+SLOT="0"
+IUSE="examples gtk-doc introspection test vala"
+RESTRICT="!test? ( test )"
+
+REQUIRED_USE="vala? ( introspection )"
+
+DEPEND="
+ >=x11-libs/gtk+-3.24.39:3[introspection?,wayland]
+ >=dev-libs/wayland-1.10.0
+ >=dev-libs/wayland-protocols-1.16
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ dev-util/wayland-scanner
+ virtual/pkgconfig
+ x11-base/xorg-proto
+ gtk-doc? ( dev-util/gtk-doc )
+ test? ( ${PYTHON_DEPS} )
+ vala? ( $(vala_depend) )
+"
+
+src_prepare() {
+ default
+ use vala && vala_setup
+}
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use examples)
+ $(meson_use gtk-doc docs)
+ $(meson_use test tests)
+ $(meson_use introspection)
+ $(meson_use vala vapi)
+ )
+ meson_src_configure
+}