summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2024-09-03 22:12:34 -0400
committerIonen Wolkens <ionen@gentoo.org>2024-09-03 22:45:48 -0400
commitfb9efe919463d7d6233e409fd5b6d8249fd6dc2e (patch)
tree5f63a242501c21adb25896eb6d01eacf29645039 /gui-libs/eglexternalplatform/eglexternalplatform-1.2.ebuild
parentnet-im/telegram-desktop: Bump to 5.4.1 (diff)
downloadgentoo-fb9efe919463d7d6233e409fd5b6d8249fd6dc2e.tar.gz
gentoo-fb9efe919463d7d6233e409fd5b6d8249fd6dc2e.tar.bz2
gentoo-fb9efe919463d7d6233e409fd5b6d8249fd6dc2e.zip
gui-libs/eglexternalplatform: add 1.2
The new meson.build changes the header install location to /usr/include rather than /usr/include/EGL but should be harmless given the old .pc file was adding -I/usr/include/EGL and egl-gbm/wayland are not using EGL/ in #include statements. Currently unclear if this version is safe to use with <nvidia-560, I believe it only adds access to a new function and it shouldn't matter if it is not used (yet). Did give it a quick try but may have been insufficient to expose issues. Upstream commit message: With version 1.2 (supported starting in 560 series drivers), platform libraries can safely call into the driver during unloadEGLExternalPlatform. Prior to that, the driver would have torn down the internal EGLDisplays by that point. Ultimately 560 is due to replace 550 as the stable driver, and old versions bare 470 (w/o USE=wayland anyway) are due for eventual removal. So *eventual* usage may be a non-issue. If need to check for driver version on this package, may need a subslot to force rebuilds when driver version changes, hopefully can avoid. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'gui-libs/eglexternalplatform/eglexternalplatform-1.2.ebuild')
-rw-r--r--gui-libs/eglexternalplatform/eglexternalplatform-1.2.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/gui-libs/eglexternalplatform/eglexternalplatform-1.2.ebuild b/gui-libs/eglexternalplatform/eglexternalplatform-1.2.ebuild
new file mode 100644
index 000000000000..ed2b3aba9691
--- /dev/null
+++ b/gui-libs/eglexternalplatform/eglexternalplatform-1.2.ebuild
@@ -0,0 +1,24 @@
+# Copyright 2021-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+DESCRIPTION="EGL External Platform interface"
+HOMEPAGE="https://github.com/NVIDIA/eglexternalplatform/"
+SRC_URI="
+ https://github.com/NVIDIA/eglexternalplatform/archive/${PV}.tar.gz
+ -> ${P}.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+
+src_install() {
+ meson_src_install
+
+ # header-only and we need it found for both 32bit and 64bit
+ mv -- "${ED}"/usr/{$(get_libdir),share}/pkgconfig || die
+}