summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonas Toth <gentoo@jonas-toth.eu>2022-05-29 10:24:15 +0200
committerJoonas Niilola <juippis@gentoo.org>2022-06-18 11:47:24 +0300
commitd1c3e36b24e32c53deb6992632819b3a210e0dc7 (patch)
tree3679408869520a9261b2977be8349b9356b5434e /gui-apps
parentmedia-video/yle-dl: stabilize 20220610 for ALLARCHES (diff)
downloadgentoo-d1c3e36b24e32c53deb6992632819b3a210e0dc7.tar.gz
gentoo-d1c3e36b24e32c53deb6992632819b3a210e0dc7.tar.bz2
gentoo-d1c3e36b24e32c53deb6992632819b3a210e0dc7.zip
gui-apps/waybar: version bump 0.9.13
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Jonas Toth <gentoo@jonas-toth.eu> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'gui-apps')
-rw-r--r--gui-apps/waybar/Manifest1
-rw-r--r--gui-apps/waybar/waybar-0.9.13.ebuild71
2 files changed, 72 insertions, 0 deletions
diff --git a/gui-apps/waybar/Manifest b/gui-apps/waybar/Manifest
index 520f4ccab862..753f8ada2d0b 100644
--- a/gui-apps/waybar/Manifest
+++ b/gui-apps/waybar/Manifest
@@ -1,3 +1,4 @@
DIST waybar-0.9.12.tar.gz 183392 BLAKE2B 697a2fce74af8337dfbfc8d8823cf4f2acfda6a0dd009cea03ec2b79358a80db0935418436a51e375be2f702e2d53f9f3403ab01cb1e91e246c7e4cc01effdf5 SHA512 c035140ca0d47ae2cbc0313e25dc206c116b5b6f7a4e6192c7d40a9bd0ef18b8bfafdc8aeea2a85d670dccceda1e3942b6b3e3a451f51a6e68d25edf0ccb1b05
+DIST waybar-0.9.13.tar.gz 198160 BLAKE2B 222863b1048d2833be393875cad947647eccde3fcae335c48d4606843b3b9445717c18955351c56779196afaf9a5333ae7f718ea590521a79359372450d494a9 SHA512 d0a87044bcccdd16b1bbb20de750804c06335f11e638d37b5b80b72233e513378ba521f5c9d2c121a78a206877487628a6562cb080dd43eadae27e52d4cf6349
DIST waybar-0.9.8.tar.gz 158869 BLAKE2B d5496986e3985747881cb8693b40d92e5c038a0ee55bf32e156efb67f02c46810cc80767635bd83837609b33855feced4f4f476deecbc47dfd43ef82700a87a2 SHA512 5c65b04cf0ae2e4cdff2b58c6b733a10a8b8d8acbb8f4f4519a0542be759fb6e84e46c323e4b8611ed25bda8bd322ee7a09cb697ed378e120841ce324021b104
DIST waybar-0.9.9.tar.gz 181603 BLAKE2B ac0430fef2cc3be3a63ae2e27d6982cdea67ee800db8e9acda2bd8025114c8f065a87a164a787d2c82a00b81012fe2fad91e8adb1b51241bc722355b100fed86 SHA512 c219c55014726d9201031ef4448505de516507a74d840a3f733b1719ae0100d1e882580da8b1490158fff2c3003cf915e04bcdf8a55b757bdb845e29bf705ecd
diff --git a/gui-apps/waybar/waybar-0.9.13.ebuild b/gui-apps/waybar/waybar-0.9.13.ebuild
new file mode 100644
index 000000000000..fa2bf998afdc
--- /dev/null
+++ b/gui-apps/waybar/waybar-0.9.13.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+DESCRIPTION="Highly customizable Wayland bar for Sway and Wlroots based compositors"
+HOMEPAGE="https://github.com/Alexays/Waybar"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/Alexays/${PN^}.git"
+else
+ SRC_URI="https://github.com/Alexays/${PN^}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+S="${WORKDIR}/${PN^}-${PV}"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="mpd network +popups pulseaudio sndio tray +udev wifi"
+
+BDEPEND="
+ >=app-text/scdoc-1.9.2
+ dev-util/gdbus-codegen
+ virtual/pkgconfig
+"
+DEPEND="
+ dev-cpp/cairomm:0
+ dev-cpp/glibmm:2
+ dev-cpp/gtkmm:3.0
+ dev-libs/glib:2
+ dev-libs/jsoncpp:=
+ dev-libs/libinput:=
+ dev-libs/libsigc++:2
+ >=dev-libs/libfmt-7.0.0:=
+ >=dev-libs/spdlog-1.8.5:=
+ dev-libs/date:=
+ dev-libs/wayland
+ dev-libs/wayland-protocols
+ gui-libs/wlroots:=
+ x11-libs/gtk+:3[wayland]
+ x11-libs/libxkbcommon
+ mpd? ( media-libs/libmpdclient )
+ network? ( dev-libs/libnl:3 )
+ popups? ( gui-libs/gtk-layer-shell )
+ pulseaudio? ( media-sound/pulseaudio )
+ sndio? ( media-sound/sndio:= )
+ tray? (
+ dev-libs/libdbusmenu[gtk3]
+ dev-libs/libappindicator
+ )
+ udev? ( virtual/libudev:= )
+ wifi? ( || ( sys-apps/util-linux net-wireless/rfkill ) )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local emesonargs=(
+ $(meson_feature mpd)
+ $(meson_feature network libnl)
+ $(meson_feature popups gtk-layer-shell)
+ $(meson_feature pulseaudio)
+ $(meson_feature sndio)
+ $(meson_feature tray dbusmenu-gtk)
+ $(meson_feature udev libudev)
+ $(meson_feature wifi rfkill)
+ )
+ meson_src_configure
+}