summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorViorel Munteanu <ceamac@gentoo.org>2024-08-24 19:36:52 +0300
committerViorel Munteanu <ceamac@gentoo.org>2024-08-24 20:06:23 +0300
commit70d0f793e5b5351f048f99f78f7414a28cc8cd08 (patch)
treeab40992f9c9daafb296e2099882e83ed3a174fe0 /gui-apps
parentgui-wm/wayfire: add 0.9.0 (diff)
downloadgentoo-70d0f793e5b5351f048f99f78f7414a28cc8cd08.tar.gz
gentoo-70d0f793e5b5351f048f99f78f7414a28cc8cd08.tar.bz2
gentoo-70d0f793e5b5351f048f99f78f7414a28cc8cd08.zip
gui-apps/wf-shell: add 0.9.0
Signed-off-by: Viorel Munteanu <ceamac@gentoo.org>
Diffstat (limited to 'gui-apps')
-rw-r--r--gui-apps/wf-shell/Manifest1
-rw-r--r--gui-apps/wf-shell/wf-shell-0.9.0.ebuild60
2 files changed, 61 insertions, 0 deletions
diff --git a/gui-apps/wf-shell/Manifest b/gui-apps/wf-shell/Manifest
index f3a2a29bed5a..0509691cac8b 100644
--- a/gui-apps/wf-shell/Manifest
+++ b/gui-apps/wf-shell/Manifest
@@ -1,2 +1,3 @@
DIST wf-shell-0.8.0.tar.xz 9100508 BLAKE2B 0867f9968fca25d183fb912e01afc55ae6c9e3a0645eb63b2622ed53bb5d6538827a8e1bb6c68be4885f0c1513e76f0fd8f580402885bfa49dcbc7a0b8b02b49 SHA512 cdaebb4aabcfcb4a4d2ef0f7845348892e5731cc44417861b958d3f067f19b6bab002845d7663ef50f57e462664ff1ca0cdab74257109211db8fa20a47ef53ae
DIST wf-shell-0.8.1.tar.xz 9161772 BLAKE2B d778b2ed214dbb1b072400a85021d3ef4e590bc707417cf2de486c9211fdf3d1fa1c14d786363bc7dd4daeeb39406d6aa2e2c3c0b607cb9b6c87151d330a3983 SHA512 b0d283dee712ed01bdabb373f8144e6c231aa68669be8851e6603678972d9f2bdcadda773df49510c902f8e8845fdb767f9da65356640fe37843dd92d0c240f2
+DIST wf-shell-0.9.0.tar.xz 9167256 BLAKE2B ea68e110381fa76590f193e6d9035e2ce1ce1a998a4c476785912d5666f42f9976b89ef78511b6d17e36f3dfb7022ed460b8b29a379445c5d41392ec7bb3ad3f SHA512 dceb0234302ceb51ac23576752d65cf122755bd044bc98e4ca92e0b8e6715063cdebdf35e82e5dc033effc288228622886e1a0e25b4bd788f6d32f8b189c1cfe
diff --git a/gui-apps/wf-shell/wf-shell-0.9.0.ebuild b/gui-apps/wf-shell/wf-shell-0.9.0.ebuild
new file mode 100644
index 000000000000..1be6243f8563
--- /dev/null
+++ b/gui-apps/wf-shell/wf-shell-0.9.0.ebuild
@@ -0,0 +1,60 @@
+# Copyright 2019-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson xdg
+
+DESCRIPTION="Compiz like 3D wayland compositor"
+HOMEPAGE="https://github.com/WayfireWM/wf-shell"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/WayfireWM/wf-shell.git"
+ SLOT="0/0.10"
+else
+ SRC_URI="https://github.com/WayfireWM/wf-shell/releases/download/v${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm64"
+ SLOT="0/$(ver_cut 1-2)"
+fi
+
+LICENSE="MIT"
+IUSE="+pulseaudio"
+
+# no tests
+RESTRICT="test"
+
+DEPEND="
+ dev-cpp/glibmm:2
+ dev-cpp/gtkmm:3.0[wayland]
+ dev-libs/glib:2
+ dev-libs/gobject-introspection
+ dev-libs/libsigc++:2
+ dev-libs/libdbusmenu[gtk3]
+ >=gui-libs/gtk-layer-shell-0.6
+ dev-libs/wayland
+ >=gui-libs/wf-config-0.7.0:=
+ gui-wm/wayfire
+ x11-libs/cairo
+ x11-libs/gtk+:3
+ pulseaudio? (
+ media-libs/alsa-lib
+ media-libs/libpulse
+ )
+"
+RDEPEND="${DEPEND}
+ gui-apps/wayland-logout
+"
+BDEPEND="
+ dev-libs/wayland-protocols
+ dev-util/wayland-scanner
+ virtual/pkgconfig
+"
+
+src_configure () {
+ local emesonargs=(
+ "$(meson_feature pulseaudio pulse)"
+ -Dwayland-logout=false
+ )
+ meson_src_configure
+}