summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2024-10-17 19:18:31 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2024-10-17 19:18:31 +0300
commit50cabd9cd78e72864843a549111ff705682ce712 (patch)
treed8f618b45264b398de0b540c71c0ab6a3911d51b /gui-apps
parentgui-apps/swaylock: add 1.8.0 (diff)
downloadgentoo-50cabd9cd78e72864843a549111ff705682ce712.tar.gz
gentoo-50cabd9cd78e72864843a549111ff705682ce712.tar.bz2
gentoo-50cabd9cd78e72864843a549111ff705682ce712.zip
gui-apps/swaylock: sync live ebuild
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'gui-apps')
-rw-r--r--gui-apps/swaylock/swaylock-9999.ebuild20
1 files changed, 9 insertions, 11 deletions
diff --git a/gui-apps/swaylock/swaylock-9999.ebuild b/gui-apps/swaylock/swaylock-9999.ebuild
index 6351d0bbc4a6..bb547be7e617 100644
--- a/gui-apps/swaylock/swaylock-9999.ebuild
+++ b/gui-apps/swaylock/swaylock-9999.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit fcaps meson
@@ -38,19 +38,17 @@ BDEPEND="
src_configure() {
local emesonargs=(
- -Dman-pages=$(usex man enabled disabled)
- -Dpam=$(usex pam enabled disabled)
- -Dgdk-pixbuf=$(usex gdk-pixbuf enabled disabled)
- "-Dfish-completions=true"
- "-Dzsh-completions=true"
- "-Dbash-completions=true"
+ $(meson_feature man man-pages)
+ $(meson_feature pam)
+ $(meson_feature gdk-pixbuf)
+ -Dfish-completions=true
+ -Dzsh-completions=true
+ -Dbash-completions=true
)
meson_src_configure
}
pkg_postinst() {
- if ! use pam; then
- fcaps cap_sys_admin usr/bin/swaylock
- fi
+ use !pam && fcaps cap_sys_admin usr/bin/swaylock
}