summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillermo Joandet <gjoandet@gmail.com>2024-04-21 18:54:27 -0300
committerPacho Ramos <pacho@gentoo.org>2024-07-16 10:40:29 +0200
commitadf952ed2397677d14e92baf88345189a1db961e (patch)
treebc88b6219162ddb56f07445a59d5a2d5b0264181 /gnome-extra
parentgnome-extra/gnome-weather: update HOMEPAGE (diff)
downloadgentoo-adf952ed2397677d14e92baf88345189a1db961e.tar.gz
gentoo-adf952ed2397677d14e92baf88345189a1db961e.tar.bz2
gentoo-adf952ed2397677d14e92baf88345189a1db961e.zip
gnome-extra/gnome-user-docs: Bump to 46.1
Signed-off-by: Guillermo Joandet <gjoandet@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/36846 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/gnome-user-docs/Manifest1
-rw-r--r--gnome-extra/gnome-user-docs/gnome-user-docs-46.1.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/gnome-extra/gnome-user-docs/Manifest b/gnome-extra/gnome-user-docs/Manifest
index cba8e1719c42..096ace26d023 100644
--- a/gnome-extra/gnome-user-docs/Manifest
+++ b/gnome-extra/gnome-user-docs/Manifest
@@ -1 +1,2 @@
DIST gnome-user-docs-45.5.tar.xz 13176820 BLAKE2B 3f19f8cfe4205707fab12ca5f43efbf4c2b477259237895339dc20a3c2b6994866ff95f89b37c78d9d4fc46857da7dc674195f1f092556ffffdafdfad76960e1 SHA512 b2452fb8093679a2b43ba3a4ce8efa8006c34329522849ab08a6a3f555d5afb6240d4beda9c29a382ccc8cfb246f155de2db6db8b161d4ef88fd4347c2a3634c
+DIST gnome-user-docs-46.1.tar.xz 13232972 BLAKE2B a4c33b2939c674b76f239cd7c94d412e8874d9e672ee35c118d5d4c818bc88c8a024e2424e567528ce823e23ac013d54c7859e5a76765b8ae17abe64c8fe149c SHA512 2520714e46e93ae834a6f1b1ca910f61a56b7b9361af2b16883fe78db441b7fbd616e359b99cbcf300576501cf9c6500578c8fc1040261f02349cdd67c2ceabb
diff --git a/gnome-extra/gnome-user-docs/gnome-user-docs-46.1.ebuild b/gnome-extra/gnome-user-docs/gnome-user-docs-46.1.ebuild
new file mode 100644
index 000000000000..4ed26bcbdbf2
--- /dev/null
+++ b/gnome-extra/gnome-user-docs/gnome-user-docs-46.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit gnome2
+
+DESCRIPTION="GNOME end user documentation"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/gnome-user-docs"
+
+LICENSE="CC-BY-3.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="test"
+
+BDEPEND="test? ( dev-libs/libxml2 )"
+# eautoreconf requires:
+# app-text/yelp-tools
+# rebuilding translations requires:
+# app-text/yelp-tools
+# dev-util/gettext
+
+# This ebuild does not install any binaries
+RESTRICT="binchecks strip
+ !test? ( test )"
+
+src_configure() {
+ # itstool is only needed for rebuilding translations
+ # xmllint is only needed for tests
+ gnome2_src_configure \
+ $(usex test "" XMLLINT=$(type -P true)) \
+ ITSTOOL=$(type -P true)
+}
+
+src_compile() {
+ # Do not compile; "make all" with unset LINGUAS rebuilds all translations,
+ # which can take > 2 hours on a Core i7.
+ return
+}