summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillermo Joandet <gjoandet@gmail.com>2024-03-21 20:44:06 -0300
committerPacho Ramos <pacho@gentoo.org>2024-07-16 10:40:29 +0200
commit42ff0122987c22e0ddee3220fda3eb83efd57668 (patch)
tree5da3379a3b6f55978be0a23bef49fd3b2fc4d658 /gnome-extra
parentmedia-gfx/gnome-font-viewer: Bump to 46.0 (diff)
downloadgentoo-42ff0122987c22e0ddee3220fda3eb83efd57668.tar.gz
gentoo-42ff0122987c22e0ddee3220fda3eb83efd57668.tar.bz2
gentoo-42ff0122987c22e0ddee3220fda3eb83efd57668.zip
gnome-extra/gnome-weather: Bump to 46.0
Signed-off-by: Guillermo Joandet <gjoandet@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/36847 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/gnome-weather/Manifest1
-rw-r--r--gnome-extra/gnome-weather/gnome-weather-46.0.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/gnome-extra/gnome-weather/Manifest b/gnome-extra/gnome-weather/Manifest
index ab1e053515a4..e7ed0b16bab0 100644
--- a/gnome-extra/gnome-weather/Manifest
+++ b/gnome-extra/gnome-weather/Manifest
@@ -1 +1,2 @@
DIST gnome-weather-45.0.tar.xz 238520 BLAKE2B c1d11e63a01f59f07dab3b59e7b885970fdfefc74179c21afcce097ab7454e07754726f4676b1c9a49415d6a2312a73c4dbf4c0b378aaab741ccaa4146ab59b9 SHA512 decc1d917a9b0dcd4b9feb49c9dce0096f0f22b8da193bb3e913a92687b06f2cee9f7e029653b1af101d6ab682b49f89be37b864804e0f42ea0e249fc77a027c
+DIST gnome-weather-46.0.tar.xz 239644 BLAKE2B 4acf901dbb7ee0240aa371797823c5d2eadfbc869b273e9bf0da45b311b71ea4977c6d0809f7067d79d80326d75c3c0184a463201c6f319573764277480ee23d SHA512 b180b231359e7b1cfa593b9a536d77520d6183aa752a8900bb27a290bc5f6f9676da132897e51e2810baca57196c9328a8cbbbb172068f52409076e39ba87a8b
diff --git a/gnome-extra/gnome-weather/gnome-weather-46.0.ebuild b/gnome-extra/gnome-weather/gnome-weather-46.0.ebuild
new file mode 100644
index 000000000000..24d3dc352604
--- /dev/null
+++ b/gnome-extra/gnome-weather/gnome-weather-46.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org gnome2-utils meson xdg
+
+DESCRIPTION="A weather application for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Design/Apps/Weather"
+
+LICENSE="GPL-2+ LGPL-2+ MIT CC-BY-3.0 CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~loong ~ppc64 ~riscv ~x86"
+
+DEPEND="
+ >=dev-libs/glib-2.32:2
+ >=dev-libs/gobject-introspection-1.56:=
+ >=gui-libs/gtk-4.5:4
+ >=dev-libs/gjs-1.71.0
+ >=app-misc/geoclue-2.3.1:2.0
+ >=gui-libs/libadwaita-1.4_alpha:1=
+ >=dev-libs/libgweather-3.90.0:4=
+"
+RDEPEND="${DEPEND}
+ gnome-base/gsettings-desktop-schemas
+"
+# libxml2 required for glib-compile-resources
+BDEPEND="
+ dev-libs/appstream-glib
+ dev-libs/libxml2:2
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+# Tests have a lot of issues, starting with reliance on a system installation,
+# accessing the network and other intermittent failures with network-sandbox disabled
+# https://gitlab.gnome.org/GNOME/gnome-weather/issues/67 (and rest not filed)
+# test dep: $(python_gen_any_dep 'dev-util/dogtail[${PYTHON_USEDEP}]')
+# With 3.34, this is now behind a dogtail option we can pass (and have data validation)
+
+src_configure() {
+ meson_src_configure -Dprofile=default -Ddogtail=false
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}