summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2020-07-13 17:30:15 -0700
committerMatt Turner <mattst88@gentoo.org>2020-07-13 17:45:13 -0700
commit928dc0a64076e21a063a916d23c5ba14de0d5fb4 (patch)
tree6f8f0dd29f5574ca7768bdb6d0681c545ae3af24 /gnome-extra/libgsf
parentdev-cpp/mm-common: Version bump to 1.0.1 (diff)
downloadgentoo-928dc0a64076e21a063a916d23c5ba14de0d5fb4.tar.gz
gentoo-928dc0a64076e21a063a916d23c5ba14de0d5fb4.tar.bz2
gentoo-928dc0a64076e21a063a916d23c5ba14de0d5fb4.zip
gnome-extra/libgsf: Version bump to 1.14.47
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'gnome-extra/libgsf')
-rw-r--r--gnome-extra/libgsf/Manifest1
-rw-r--r--gnome-extra/libgsf/libgsf-1.14.47.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/gnome-extra/libgsf/Manifest b/gnome-extra/libgsf/Manifest
index fb2fcf88f577..0f763b9c01e4 100644
--- a/gnome-extra/libgsf/Manifest
+++ b/gnome-extra/libgsf/Manifest
@@ -1 +1,2 @@
DIST libgsf-1.14.46.tar.xz 689360 BLAKE2B d5d66e96dc74fa68111781ce9bcbfaed2b8a99f9d2bcb16e32a650e103716633b5def7c93f133538449a3b6d9299e4709ba29bc6a520d5c7fe144bcbf78d3ae1 SHA512 130331f63d48455cc2ce60756e2ac703f8a7f5fa8f1243d9d9321fb87e01bf1d616d085d100a3e5d1cf34fb851ffb77bc642aff6c674ace167b9aa117f4fb1b0
+DIST libgsf-1.14.47.tar.xz 691448 BLAKE2B 7be095fef159ff7a52f2cf4d83b59b5bb591e0d4fb1d69d88bc6f2eba4286337af2a2c46ac7d6603d5a68b9b6f03d41f647d34b0bee5e61244696c5ba02be569 SHA512 143d48eb02be8202b9eb97e29e5909061a0e1a562b86e4bb4b2eac3fb0a42b139ead131ed1ffa4dfe304b65527089777823122223a74ebbc9df94c17d013f97b
diff --git a/gnome-extra/libgsf/libgsf-1.14.47.ebuild b/gnome-extra/libgsf/libgsf-1.14.47.ebuild
new file mode 100644
index 000000000000..0fd31f6c5c76
--- /dev/null
+++ b/gnome-extra/libgsf/libgsf-1.14.47.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit gnome2
+
+DESCRIPTION="The GNOME Structured File Library"
+HOMEPAGE="https://developer.gnome.org/gsf/"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0/114" # libgsf-1.so version
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="bzip2 gtk +introspection"
+
+RDEPEND="
+ >=dev-libs/glib-2.36:2
+ >=dev-libs/libxml2-2.4.16:2
+ sys-libs/zlib
+ bzip2? ( app-arch/bzip2 )
+ gtk? (
+ x11-libs/gdk-pixbuf:2
+ virtual/imagemagick-tools
+ )
+ introspection? ( >=dev-libs/gobject-introspection-1:= )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.12
+ dev-libs/gobject-introspection-common
+ >=sys-devel/gettext-0.19.6
+ virtual/pkgconfig
+"
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-static \
+ $(use_with bzip2 bz2) \
+ $(use_enable introspection) \
+ $(use_with gtk gdk-pixbuf)
+}