summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /gnome-extra/gnome-system-monitor
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'gnome-extra/gnome-system-monitor')
-rw-r--r--gnome-extra/gnome-system-monitor/Manifest2
-rw-r--r--gnome-extra/gnome-system-monitor/gnome-system-monitor-3.14.1.ebuild44
-rw-r--r--gnome-extra/gnome-system-monitor/gnome-system-monitor-3.16.0.ebuild44
-rw-r--r--gnome-extra/gnome-system-monitor/metadata.xml9
4 files changed, 99 insertions, 0 deletions
diff --git a/gnome-extra/gnome-system-monitor/Manifest b/gnome-extra/gnome-system-monitor/Manifest
new file mode 100644
index 000000000000..7a3b96bf520e
--- /dev/null
+++ b/gnome-extra/gnome-system-monitor/Manifest
@@ -0,0 +1,2 @@
+DIST gnome-system-monitor-3.14.1.tar.xz 852712 SHA256 948be34a5c3e91acd4a1af0c7711020dd76d274aac547d5836910f2fde09a5e6 SHA512 09f21f0a7fc3fdf0fc83e37a8429b2868fb8f55f39c3713db565b1d46035fa31907bcd21154636df26e192f2f455207b18f02a91ed59d48af0685f90bb2f23fd WHIRLPOOL 5503e42979785bbb0c9beef99f2d1234be0476b2271b9984fc83a48a9f98946c9a504ebf3e87007c7558cbd8bb91c9e58ca93183beedcbdf01f902b5b9cfafa8
+DIST gnome-system-monitor-3.16.0.tar.xz 856044 SHA256 00936e8b5d29fc01cd6daf6c119242877d81b2dcca33fb0ee9ce4adec8675391 SHA512 22722150478c6d449908b16bfe4683e29151023e8f47407ea76ed09d4612ffee74c190f22e89153b1e21ad990b9fca6e3c42295dee16e16685a08e9349a6a68c WHIRLPOOL 21b96c33c1ea38b58f1fb5a1c8b18147e5c6ff60effe41cfa50b2410b60a378be23d4223ba9d8c83e7ca3e86ca5474a70ede065e27b57eb88f62d162e5c01453
diff --git a/gnome-extra/gnome-system-monitor/gnome-system-monitor-3.14.1.ebuild b/gnome-extra/gnome-system-monitor/gnome-system-monitor-3.14.1.ebuild
new file mode 100644
index 000000000000..1bc052c0fa39
--- /dev/null
+++ b/gnome-extra/gnome-system-monitor/gnome-system-monitor-3.14.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+
+inherit gnome2
+
+DESCRIPTION="The Gnome System Monitor"
+HOMEPAGE="https://help.gnome.org/users/gnome-system-monitor/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="systemd +X"
+KEYWORDS="~alpha amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc x86 ~x86-fbsd"
+
+RDEPEND="
+ >=dev-libs/glib-2.37.3:2
+ >=gnome-base/libgtop-2.28.2:2=
+ >=x11-libs/gtk+-3.12:3[X(+)]
+ >=dev-cpp/gtkmm-3.3.18:3.0
+ >=dev-cpp/glibmm-2.34:2
+ >=dev-libs/libxml2-2.0:2
+ >=gnome-base/librsvg-2.35:2
+
+ systemd? ( >=sys-apps/systemd-38:0= )
+ X? ( >=x11-libs/libwnck-2.91.0:3 )
+"
+#eautoreconf requires gnome-base/gnome-common
+DEPEND="${RDEPEND}
+ >=app-text/gnome-doc-utils-0.20
+ >=dev-util/intltool-0.41.0
+ virtual/pkgconfig
+
+ systemd? ( !=sys-apps/systemd-43* )
+"
+
+src_configure() {
+ gnome2_src_configure \
+ $(use_enable systemd) \
+ $(use_enable X wnck) \
+ ITSTOOL=$(type -P true)
+}
diff --git a/gnome-extra/gnome-system-monitor/gnome-system-monitor-3.16.0.ebuild b/gnome-extra/gnome-system-monitor/gnome-system-monitor-3.16.0.ebuild
new file mode 100644
index 000000000000..943cc960ed73
--- /dev/null
+++ b/gnome-extra/gnome-system-monitor/gnome-system-monitor-3.16.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+
+inherit gnome2
+
+DESCRIPTION="The Gnome System Monitor"
+HOMEPAGE="https://help.gnome.org/users/gnome-system-monitor/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="systemd +X"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+
+RDEPEND="
+ >=dev-libs/glib-2.37.3:2
+ >=gnome-base/libgtop-2.28.2:2=
+ >=x11-libs/gtk+-3.12:3[X(+)]
+ >=dev-cpp/gtkmm-3.3.18:3.0
+ >=dev-cpp/glibmm-2.34:2
+ >=dev-libs/libxml2-2.0:2
+ >=gnome-base/librsvg-2.35:2
+
+ systemd? ( >=sys-apps/systemd-38:0= )
+ X? ( >=x11-libs/libwnck-2.91.0:3 )
+"
+#eautoreconf requires gnome-base/gnome-common
+DEPEND="${RDEPEND}
+ >=app-text/gnome-doc-utils-0.20
+ >=dev-util/intltool-0.41.0
+ virtual/pkgconfig
+
+ systemd? ( !=sys-apps/systemd-43* )
+"
+
+src_configure() {
+ gnome2_src_configure \
+ $(use_enable systemd) \
+ $(use_enable X wnck) \
+ ITSTOOL=$(type -P true)
+}
diff --git a/gnome-extra/gnome-system-monitor/metadata.xml b/gnome-extra/gnome-system-monitor/metadata.xml
new file mode 100644
index 000000000000..4ad8daa8fd7f
--- /dev/null
+++ b/gnome-extra/gnome-system-monitor/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>gnome</herd>
+<use>
+ <flag name="systemd">Display <pkg>sys-apps/systemd</pkg> metadata, e.g.
+ unit names, for running processes</flag>
+</use>
+</pkgmetadata>