summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-04-22 17:59:08 -0700
committerMatt Turner <mattst88@gentoo.org>2022-04-22 21:59:57 -0700
commita5437bff84d922afe3f60a8ce1fd408a67c16d83 (patch)
treee8d9fccde21794531eb8fa4227fbe749313e9ede /gnome-base
parentgui-libs/libadwaita: Version bump to 1.1.1 (diff)
downloadgentoo-a5437bff84d922afe3f60a8ce1fd408a67c16d83.tar.gz
gentoo-a5437bff84d922afe3f60a8ce1fd408a67c16d83.tar.bz2
gentoo-a5437bff84d922afe3f60a8ce1fd408a67c16d83.zip
gnome-base/nautilus: Version bump to 42.1.1
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'gnome-base')
-rw-r--r--gnome-base/nautilus/Manifest1
-rw-r--r--gnome-base/nautilus/nautilus-42.1.1.ebuild114
2 files changed, 115 insertions, 0 deletions
diff --git a/gnome-base/nautilus/Manifest b/gnome-base/nautilus/Manifest
index 3a500bc4f4b3..9a39144045c8 100644
--- a/gnome-base/nautilus/Manifest
+++ b/gnome-base/nautilus/Manifest
@@ -1,2 +1,3 @@
DIST nautilus-41.2.tar.xz 3248212 BLAKE2B be4e4e8fc03751259a1a5d4d1eb726e3026d24376da3fa680c412598219bfb3ced52f9b809004913dffdb9bb1c176dede07288c440c100487b3a337d8eaab417 SHA512 adb14fa1cf37a4797f57ae5162bddcd5b012de270cf955051b69276bc266b1dbfd8027b835f627ae19a1252356b344b1c8a4b7ca79a22512f3138a2c13fd2f3e
DIST nautilus-42.0.tar.xz 3263108 BLAKE2B 0d06a72cc1ea1a227f6d92ee2841a2fdda9220ccb61bdb43cd5930a8f64393994a746e33a5451d460ca4c15810549c5d94f895ee861efa8ae46b98e25ed20f5f SHA512 c3b182f75f89a31ecb7b4f6b42dfb2f9792e195fdaf0e5f2b1a4dbe0f0d01071cf4ecb8408d6da476aa111ec891462e33c0d139d3423109bd5b4138ae822bd1e
+DIST nautilus-42.1.1.tar.xz 3259444 BLAKE2B 4737c44a6b30c61eeb850dce266f5ee1ed50dd5f2c7da868efb4b407e60a99b1ac0ea2c865a3e4710afabfa8c96c8d29f2dfaab3c56c5ef0236fa0c10a8c1864 SHA512 f8961c41fa2d5109e7011311f79caa1d3b9b71a3cf946a90d1a4dd03a4f0f7daac902e61bc01f6b86c2552255b9dbe0573474dcfe2ea08e0218a3c2bcbc58e48
diff --git a/gnome-base/nautilus/nautilus-42.1.1.ebuild b/gnome-base/nautilus/nautilus-42.1.1.ebuild
new file mode 100644
index 000000000000..c7dab39e1262
--- /dev/null
+++ b/gnome-base/nautilus/nautilus-42.1.1.ebuild
@@ -0,0 +1,114 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org gnome2-utils meson readme.gentoo-r1 virtualx xdg
+
+DESCRIPTION="Default file manager for the GNOME desktop"
+HOMEPAGE="https://wiki.gnome.org/Apps/Nautilus"
+
+LICENSE="GPL-3+ LGPL-2.1+"
+SLOT="0"
+IUSE="gnome +gstreamer gtk-doc +introspection +previewer selinux sendto"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+DEPEND="
+ >=dev-libs/glib-2.67.1:2
+ >=media-libs/gexiv2-0.14.0
+ gstreamer? ( media-libs/gstreamer:1.0
+ media-libs/gst-plugins-base:1.0 )
+ >=app-arch/gnome-autoar-0.4.0
+ >=gnome-base/gnome-desktop-3.0.0:3=
+ >=gnome-base/gsettings-desktop-schemas-42
+ >=x11-libs/gtk+-3.22.27:3[X,introspection?]
+ >=gui-libs/libhandy-1.5.0:1
+ >=x11-libs/pango-1.28.3
+ selinux? ( >=sys-libs/libselinux-2.0 )
+ >=app-misc/tracker-3.0:3=
+ x11-libs/libX11
+ >=dev-libs/libxml2-2.7.8:2
+ introspection? ( >=dev-libs/gobject-introspection-1.54:= )
+"
+RDEPEND="${DEPEND}
+ >=app-misc/tracker-miners-3.0:3=
+" # uses org.freedesktop.Tracker.Miner.Files gsettings schema from tracker-miners
+BDEPEND="
+ >=dev-util/gdbus-codegen-2.51.2
+ >=dev-util/meson-0.57.2
+ dev-util/glib-utils
+ gtk-doc? (
+ >=dev-util/gtk-doc-1.10
+ app-text/docbook-xml-dtd:4.1.2 )
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ x11-base/xorg-proto
+"
+PDEPEND="
+ gnome? ( x11-themes/adwaita-icon-theme )
+ previewer? ( >=gnome-extra/sushi-0.1.9 )
+ sendto? ( >=gnome-extra/nautilus-sendto-3.0.1 )
+ >=gnome-base/gvfs-1.14[gtk(+)]
+" # Need gvfs[gtk] for recent:/// support; always built (without USE=gtk) since gvfs-1.34
+
+PATCHES=(
+ "${FILESDIR}"/3.30.5-docs-build.patch # Always install pregenerated manpage, keeping docs option for gtk-doc
+ "${FILESDIR}"/42.0-optional-gstreamer.patch # Allow controlling audio-video-properties build
+)
+
+src_prepare() {
+ default
+ xdg_environment_reset
+
+ if use previewer; then
+ DOC_CONTENTS="nautilus uses gnome-extra/sushi to preview media files.
+ To activate the previewer, select a file and press space; to
+ close the previewer, press space again."
+ fi
+
+ # Disable test-nautilus-search-engine-tracker; bug #831170
+ sed -e '/^tracker_tests = /{n;N;N;d}' -i test/automated/displayless/meson.build || die
+}
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use gtk-doc docs)
+ -Dextensions=true # image file properties, sendto support; also required for -Dgstreamer=true
+ $(meson_use gstreamer) # gstreamer audio-video-properties extension
+ $(meson_use introspection)
+ -Dlibportal=false # As of 40.2, all libportal usages are flatpak-specific
+ -Dpackagekit=false
+ $(meson_use selinux)
+ -Dprofiling=false
+ -Dtests=$(usex test all none)
+ )
+ meson_src_configure
+}
+
+src_install() {
+ use previewer && readme.gentoo_create_doc
+ meson_src_install
+}
+
+src_test() {
+ gnome2_environment_reset # Avoid dconf that looks at XDG_DATA_DIRS, which can sandbox fail if flatpak is installed
+ # TODO: Tests require tracker testutils (e.g. tracker-sandbox), which may need some sorting out with tracker use flag deps
+ virtx meson_src_test
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+
+ if use previewer; then
+ readme.gentoo_print_elog
+ else
+ elog "To preview media files, emerge nautilus with USE=previewer"
+ fi
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}