summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAustin English <wizardedit@gentoo.org>2016-06-29 17:37:08 -0500
committerAustin English <wizardedit@gentoo.org>2016-06-29 17:54:17 -0500
commitce0efe07e55e9d2f09e0fa1c9f7f7bf5672d7c7d (patch)
tree26254f83a266525e5548cce76a8dbefc004bb9cc /games-util
parentsys-kernel/hardened-sources: remove older unstable versions (diff)
downloadgentoo-ce0efe07e55e9d2f09e0fa1c9f7f7bf5672d7c7d.tar.gz
gentoo-ce0efe07e55e9d2f09e0fa1c9f7f7bf5672d7c7d.tar.bz2
gentoo-ce0efe07e55e9d2f09e0fa1c9f7f7bf5672d7c7d.zip
games-util/mcrcon: remove depreacted games eclass
Also update to EAPI 6 Gentoo-Bug: https://bugs.gentoo.org/574082 Package-Manager: portage-2.2.28
Diffstat (limited to 'games-util')
-rw-r--r--games-util/mcrcon/mcrcon-0.0.5-r1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/games-util/mcrcon/mcrcon-0.0.5-r1.ebuild b/games-util/mcrcon/mcrcon-0.0.5-r1.ebuild
new file mode 100644
index 000000000000..224180e34463
--- /dev/null
+++ b/games-util/mcrcon/mcrcon-0.0.5-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="Remote connection client for Minecraft servers"
+HOMEPAGE="http://sourceforge.net/projects/mcrcon/"
+SRC_URI="mirror://sourceforge/${PN}/${P}-src.zip"
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+S="${WORKDIR}"
+
+src_compile() {
+ # Flags taken from COMPILING.txt.
+ $(tc-getCC) ${CFLAGS} ${LDFLAGS} -std=gnu11 -pedantic -Wall -Wextra -o "${PN}" "${PN}.c" || die
+}
+
+src_install() {
+ default
+ dobin "${PN}"
+}