summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2022-08-06 14:50:06 +0100
committerJames Le Cuirot <chewi@gentoo.org>2022-08-06 14:50:10 +0100
commitcf99a44f45292fe71d7f96af3e8abd9755a7f86d (patch)
treef2e9e93566894ba2b7ee0640d72fe631bf0d6794 /games-util/gamemode
parentapp-emulation/86Box: drop 3.7 (diff)
downloadgentoo-cf99a44f45292fe71d7f96af3e8abd9755a7f86d.tar.gz
gentoo-cf99a44f45292fe71d7f96af3e8abd9755a7f86d.tar.bz2
gentoo-cf99a44f45292fe71d7f96af3e8abd9755a7f86d.zip
games-util/gamemode: Bump to 1.7, don't install static lib, EAPI 8
Closes: https://bugs.gentoo.org/745096 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'games-util/gamemode')
-rw-r--r--games-util/gamemode/Manifest1
-rw-r--r--games-util/gamemode/files/gamemode-1.7-static-libs.patch29
-rw-r--r--games-util/gamemode/gamemode-1.7.ebuild125
-rw-r--r--games-util/gamemode/gamemode-9999.ebuild28
4 files changed, 169 insertions, 14 deletions
diff --git a/games-util/gamemode/Manifest b/games-util/gamemode/Manifest
index 82d722917814..a38ad2d24ca7 100644
--- a/games-util/gamemode/Manifest
+++ b/games-util/gamemode/Manifest
@@ -1 +1,2 @@
DIST gamemode-1.6.1.tar.xz 71224 BLAKE2B aafa3123a2c672197d28fafbc7331004b6e4c87808e831f5e0341fd9a690acda8305da114651391fe39e6702bac805cede9d696280d03d4cc3d03d6f4d782efd SHA512 99403a68675522d3b412424591ab7f0cef54968a699f8f68aa59a42a43df73db4bc8a84ee8f97b9f78f329ecd1ed2f3a50e3cb539458f23e7c5fbe28f7978e47
+DIST gamemode-1.7.tar.xz 73264 BLAKE2B 81957a1989cf49532b0d80fc9b96a75d8205e7f148125309f3cae601f6fe125e8d839d4b92bea418a229a6e2658eaa55db2b3bbdb5e7efb26d278e2b22ab8269 SHA512 1fc91367af37d18e0042831b377cafec122c603ab699ecc314b0ded11410aab1bd739712e7305e497796fda25bee88d34438d5f3751595bf579dcbeb7335d15b
diff --git a/games-util/gamemode/files/gamemode-1.7-static-libs.patch b/games-util/gamemode/files/gamemode-1.7-static-libs.patch
new file mode 100644
index 000000000000..89fd0ba3d70a
--- /dev/null
+++ b/games-util/gamemode/files/gamemode-1.7-static-libs.patch
@@ -0,0 +1,29 @@
+From d339709cc42fe0b78b881d760003845010f5a7c1 Mon Sep 17 00:00:00 2001
+From: James Le Cuirot <chewi@gentoo.org>
+Date: Sat, 6 Aug 2022 14:42:27 +0100
+Subject: [PATCH] Don't force installation of static libgamemodeauto
+
+Defining the library with `library` rather than `both_libraries` allows the user
+to choose which type they want to install using `-Ddefault_library`.
+
+Closes: https://github.com/FeralInteractive/gamemode/issues/287
+---
+ lib/meson.build | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/lib/meson.build b/lib/meson.build
+index e810509..7cdcf8a 100644
+--- a/lib/meson.build
++++ b/lib/meson.build
+@@ -25,7 +25,7 @@ gamemode_headers_includes = [
+ ]
+
+ # Small library to automatically use gamemode
+-libgamemodeauto = both_libraries(
++libgamemodeauto = library(
+ 'gamemodeauto',
+ sources: [
+ 'client_loader.c',
+--
+2.35.1
+
diff --git a/games-util/gamemode/gamemode-1.7.ebuild b/games-util/gamemode/gamemode-1.7.ebuild
new file mode 100644
index 000000000000..8e94f8d83a95
--- /dev/null
+++ b/games-util/gamemode/gamemode-1.7.ebuild
@@ -0,0 +1,125 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MULTILIB_COMPAT=( abi_x86_{32,64} )
+
+inherit meson-multilib systemd
+
+DESCRIPTION="Optimise Linux system performance on demand"
+HOMEPAGE="https://github.com/FeralInteractive/gamemode"
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/FeralInteractive/gamemode.git"
+ GAMEMODE_GIT_PTR="master"
+ inherit git-r3
+else
+ GAMEMODE_GIT_PTR="${PV}"
+ SRC_URI="https://github.com/FeralInteractive/gamemode/releases/download/${GAMEMODE_GIT_PTR}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="systemd elogind"
+
+REQUIRED_USE="^^ ( systemd elogind )"
+
+RDEPEND="
+ acct-group/gamemode
+ >=dev-libs/inih-53
+ sys-apps/dbus[${MULTILIB_USEDEP},systemd(+)=,elogind(-)=]
+ sys-auth/polkit
+ sys-libs/libcap
+"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.7-static-libs.patch
+)
+
+DOCS=(
+ CHANGELOG.md
+ LICENSE.txt
+ README.md
+ example/gamemode.ini
+)
+
+pkg_pretend() {
+ elog
+ elog "GameMode needs a kernel capable of SCHED_ISO to use its soft realtime"
+ elog "feature. Example of a kernel providing that is sys-kernel/pf-sources."
+ elog
+ elog "Support for soft realtime is completely optional. It may provide the"
+ elog "following benefits with systems having at least four CPU cores:"
+ elog
+ elog " * more CPU shares allocated exclusively to the game"
+ elog " * reduced input lag and reduced thread latency"
+ elog " * more consistent frame times resulting in less microstutters"
+ elog
+ elog "You probably won't benefit from soft realtime mode and thus don't need"
+ elog "SCHED_ISO if:"
+ elog
+ elog " * Your CPU has less than four cores because the game may experience"
+ elog " priority inversion with the graphics driver (thus heuristics"
+ elog " automatically disable SCHED_ISO usage then)"
+ elog " * Your game uses busy-loops to interface with the graphics driver"
+ elog " but you may still force SCHED_ISO per configuation file, YMMV,"
+ elog " it depends on the graphics driver implementation, i.e. usage of"
+ elog " __GL_THREADED_OPTIMIZATIONS or similar."
+ elog " * If your game causes more than 70% CPU usage across all cores,"
+ elog " SCHED_ISO automatically turns off and on depending on usage and"
+ elog " is processed with higher-than-normal priority then (renice)."
+ elog " This auto-switching may result in a lesser game experience."
+ elog
+ elog "For more info look at:"
+ elog "https://github.com/FeralInteractive/gamemode/blob/${GAMEMODE_GIT_PTR}/README.md"
+ elog
+}
+
+multilib_src_configure() {
+ local emesonargs=(
+ -Dwith-systemd-user-unit-dir="$(systemd_get_userunitdir)"
+ )
+ if multilib_is_native_abi; then
+ emesonargs+=(
+ -Dwith-sd-bus-provider=$(usex systemd systemd elogind)
+ )
+ else
+ emesonargs+=(
+ -Dwith-sd-bus-provider=no-daemon
+ -Dwith-pam-group=gamemode
+ -Dwith-examples=false
+ )
+ fi
+
+ meson_src_configure
+}
+
+pkg_postinst() {
+ elog
+ elog "GameMode has optional support for adjusting nice and ioprio of games"
+ elog "running with it. You may need to adjust your PAM limits to make use"
+ elog "of this. You need to be in the gamemode group for this to work."
+ elog
+ elog "Run the following command as root to add your user:"
+ elog "# gpasswd -a USER gamemode # with USER = your user name"
+ elog
+ elog "You can run the following command to test your settings:"
+ elog
+ elog "# gamemoded -t"
+ elog
+ elog "GameMode supports GPU optimizations. It defaults to OFF. Any"
+ elog "damage resulting from usage of this is your own responsibility."
+ elog
+ elog "systemd user sessions will automatically run the daemon on demand,"
+ elog "it does not need to be enabled explicitly. Games not supporting"
+ elog "GameMode natively can still make use of it, just add"
+ elog
+ elog "gamemoderun %command%"
+ elog
+ elog "to the start options of any steam game to enable optimizations"
+ elog "automatically as you start the game."
+ elog
+}
diff --git a/games-util/gamemode/gamemode-9999.ebuild b/games-util/gamemode/gamemode-9999.ebuild
index 1c2a2df1c374..9490fc1e7b56 100644
--- a/games-util/gamemode/gamemode-9999.ebuild
+++ b/games-util/gamemode/gamemode-9999.ebuild
@@ -1,7 +1,7 @@
-# Copyright 2021 Gentoo Authors
+# Copyright 2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
MULTILIB_COMPAT=( abi_x86_{32,64} )
@@ -35,6 +35,10 @@ RDEPEND="
"
DEPEND="${RDEPEND}"
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.7-static-libs.patch
+)
+
DOCS=(
CHANGELOG.md
LICENSE.txt
@@ -76,28 +80,24 @@ pkg_pretend() {
multilib_src_configure() {
local emesonargs=(
- -Dwith-sd-bus-provider=$(usex systemd "systemd" "elogind")
-Dwith-systemd-user-unit-dir="$(systemd_get_userunitdir)"
+ -Dwith-pam-limits-dir="${EPREFIX}"/etc/security/limits.d
)
- if ! multilib_is_native_abi; then
+ if multilib_is_native_abi; then
+ emesonargs+=(
+ -Dwith-sd-bus-provider=$(usex systemd systemd elogind)
+ )
+ else
emesonargs+=(
- -Dwith-examples=false
-Dwith-sd-bus-provider=no-daemon
+ -Dwith-pam-renicing=false
+ -Dwith-examples=false
)
fi
meson_src_configure
}
-multilib_src_install_all() {
- if multilib_is_native_abi; then
- insinto /etc/security/limits.d
- newins - 45-gamemode.conf <<-EOF
- @gamemode - nice -10
- EOF
- fi
-}
-
pkg_postinst() {
elog
elog "GameMode has optional support for adjusting nice and ioprio of games"