summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-04-19 05:20:41 +0100
committerSam James <sam@gentoo.org>2023-04-19 05:31:47 +0100
commitd2083bcde987b24ea09164d7fb71d46bdc77adb2 (patch)
treeca00f24ade77f67a74e698b8b66eb8711e98d55b /games-strategy
parentdev-python/iminuit: bump to 2.21.3 (diff)
downloadgentoo-d2083bcde987b24ea09164d7fb71d46bdc77adb2.tar.gz
gentoo-d2083bcde987b24ea09164d7fb71d46bdc77adb2.tar.bz2
gentoo-d2083bcde987b24ea09164d7fb71d46bdc77adb2.zip
games-strategy/colobot: fix build w/ gcc 13
Closes: https://bugs.gentoo.org/899034 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/colobot/colobot-0.2.0_alpha.ebuild4
-rw-r--r--games-strategy/colobot/files/colobot-0.2.0_alpha-gcc13.patch26
2 files changed, 29 insertions, 1 deletions
diff --git a/games-strategy/colobot/colobot-0.2.0_alpha.ebuild b/games-strategy/colobot/colobot-0.2.0_alpha.ebuild
index b49ad40a24db..ceef225ca257 100644
--- a/games-strategy/colobot/colobot-0.2.0_alpha.ebuild
+++ b/games-strategy/colobot/colobot-0.2.0_alpha.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -41,6 +41,8 @@ RDEPEND="${DEPEND}
PATCHES=(
# https://github.com/colobot/colobot/pull/1453
"${FILESDIR}"/colobot-0.1.12-sndfile-link.patch
+ # https://github.com/colobot/colobot/pull/1576
+ "${FILESDIR}"/colobot-0.2.0_alpha-gcc13.patch
)
src_prepare() {
diff --git a/games-strategy/colobot/files/colobot-0.2.0_alpha-gcc13.patch b/games-strategy/colobot/files/colobot-0.2.0_alpha-gcc13.patch
new file mode 100644
index 000000000000..f74dcb56db25
--- /dev/null
+++ b/games-strategy/colobot/files/colobot-0.2.0_alpha-gcc13.patch
@@ -0,0 +1,26 @@
+https://github.com/colobot/colobot/pull/1576
+
+From 96d32db288ccd5ab13afdb2a063ad9e03170c4ee Mon Sep 17 00:00:00 2001
+From: Sam James <sam@gentoo.org>
+Date: Wed, 19 Apr 2023 05:18:06 +0100
+Subject: [PATCH] Fix build with GCC 13
+
+GCC 13 (as usual for new compiler releases) shuffles around some internal includes so some
+are no longer transitively included.
+
+See https://gnu.org/software/gcc/gcc-13/porting_to.html.
+
+Bug: https://bugs.gentoo.org/899034
+--- a/src/CBot/CBotFileUtils.h
++++ b/src/CBot/CBotFileUtils.h
+@@ -19,6 +19,7 @@
+
+ #pragma once
+
++#include <cstdint>
+ #include <iostream>
+ #include <string>
+
+--
+2.40.0
+