summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <mmk@levelnine.at>2024-10-30 18:50:08 +0100
committerConrad Kostecki <conikost@gentoo.org>2024-11-02 13:05:38 +0100
commit555b97a76dfa6c2732cd2aeef867a42cce83ae7a (patch)
treee013386bdcbdf62e6d719d1ecbddb09902524239 /games-roguelike
parentsys-block/fio: remove unused patch (diff)
downloadgentoo-555b97a76dfa6c2732cd2aeef867a42cce83ae7a.tar.gz
gentoo-555b97a76dfa6c2732cd2aeef867a42cce83ae7a.tar.bz2
gentoo-555b97a76dfa6c2732cd2aeef867a42cce83ae7a.zip
games-roguelike/adom: EAPI8 bump
Signed-off-by: Michael Mair-Keimberger <mmk@levelnine.at> Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'games-roguelike')
-rw-r--r--games-roguelike/adom/adom-3.3.3-r2.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/games-roguelike/adom/adom-3.3.3-r2.ebuild b/games-roguelike/adom/adom-3.3.3-r2.ebuild
new file mode 100644
index 000000000000..76a508735df5
--- /dev/null
+++ b/games-roguelike/adom/adom-3.3.3-r2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_P="${PN}_linux_debian"
+
+DESCRIPTION="Ancient Domains Of Mystery rogue-like game"
+HOMEPAGE="https://www.adom.de/"
+SRC_URI="x86? ( https://www.adom.de/home/download/current/${MY_P}_32_${PV}.tar.gz -> ${P}_x86.tar.gz )
+ amd64? ( https://www.adom.de/home/download/current/${MY_P}_64_${PV}.tar.gz -> ${P}_amd64.tar.gz )"
+S="${WORKDIR}/adom"
+
+LICENSE="adom"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RESTRICT="strip" # The executable is pre-stripped
+
+QA_FLAGS_IGNORED="/opt/bin/adom"
+RDEPEND="sys-libs/ncurses-compat:5[abi_x86_32(-)]"
+
+DOCS=(
+ "docs/adomfaq.txt"
+ "docs/credits.txt"
+ "docs/manual.txt"
+ "docs/readme1st.txt"
+)
+
+src_install() {
+ exeinto /opt/bin
+ doexe adom
+ einstalldocs
+}