summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2021-09-28 15:32:05 -0400
committerIonen Wolkens <ionen@gentoo.org>2021-09-28 15:36:27 -0400
commitb7deab8b7bc7d1579ee883d855a1cbcd0627b787 (patch)
tree60cfcc7afddfafef2a279c44ec84089a6471732f /games-puzzle
parentdev-ruby/eventmachine: skip fewer tests, backport OpenSSL 1.1.1 fixes (diff)
downloadgentoo-b7deab8b7bc7d1579ee883d855a1cbcd0627b787.tar.gz
gentoo-b7deab8b7bc7d1579ee883d855a1cbcd0627b787.tar.bz2
gentoo-b7deab8b7bc7d1579ee883d855a1cbcd0627b787.zip
games-puzzle/fbg: EAPI6->8, fix runtime
Haven't tried with it, but this likely been broken since gcc-8 or so. Also added --without-x so it doesn't try to link with libXt that it does not actually use. Closes: https://bugs.gentoo.org/815259 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'games-puzzle')
-rw-r--r--games-puzzle/fbg/fbg-0.9-r3.ebuild (renamed from games-puzzle/fbg/fbg-0.9-r2.ebuild)36
-rw-r--r--games-puzzle/fbg/files/fbg-0.9-missing-return.patch8
2 files changed, 29 insertions, 15 deletions
diff --git a/games-puzzle/fbg/fbg-0.9-r2.ebuild b/games-puzzle/fbg/fbg-0.9-r3.ebuild
index b0c84fa8eeca..5da0c0508858 100644
--- a/games-puzzle/fbg/fbg-0.9-r2.ebuild
+++ b/games-puzzle/fbg/fbg-0.9-r3.ebuild
@@ -1,41 +1,47 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
+
inherit desktop
-DESCRIPTION="A Tetris clone written in OpenGL"
+DESCRIPTION="Tetris clone written in OpenGL"
HOMEPAGE="http://fbg.sourceforge.net/"
SRC_URI="mirror://sourceforge/fbg/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
-DEPEND="virtual/opengl
- virtual/glu
+RDEPEND="
dev-games/physfs
- media-libs/libsdl[opengl,video]
media-libs/libmikmod
- x11-libs/libXt"
-RDEPEND="${DEPEND}"
+ media-libs/libsdl[opengl,video]
+ virtual/glu
+ virtual/opengl"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-missing-return.patch
+)
src_prepare() {
default
- sed -i \
- -e "/FBGDATADIR=/s:\".*\":\"/usr/share/${PN}\":" \
+
+ sed -e "/FBGDATADIR=/s|=.*|=\"${EPREFIX}/usr/share/${PN}\"|" \
-e '/^datadir=/d' \
- configure || die
+ -i configure || die
}
src_configure() {
- econf --disable-fbglaunch
+ econf --disable-fbglaunch --without-x
}
src_install() {
default
+
newicon startfbg/icon.xpm ${PN}.xpm
- make_desktop_entry ${PN} "Falling Block Game" ${PN}
- rm -rf "${ED}/usr/doc"
+ make_desktop_entry ${PN} "Falling Block Game"
+
+ rm -r "${ED}"/usr/doc || die
}
diff --git a/games-puzzle/fbg/files/fbg-0.9-missing-return.patch b/games-puzzle/fbg/files/fbg-0.9-missing-return.patch
new file mode 100644
index 000000000000..86b0b551957f
--- /dev/null
+++ b/games-puzzle/fbg/files/fbg-0.9-missing-return.patch
@@ -0,0 +1,8 @@
+Lack of return leads to segmentation fault on startup.
+https://bugs.gentoo.org/815259
+--- a/src/glTGAImage.cc
++++ b/src/glTGAImage.cc
+@@ -180,2 +180,3 @@
+ glTexImage2D(GL_TEXTURE_2D, 0, type, getWidth(), getHeight(), 0, type, GL_UNSIGNED_BYTE, getImageData());
++ return true;
+ }