summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNils Freydank <holgersson@posteo.de>2017-11-17 21:39:33 +0100
committerDavid Seifert <soap@gentoo.org>2017-11-19 19:32:43 +0100
commitf32bcdeee1d31d80e0a62facb25a6839f7f60b51 (patch)
treeffffbe230f21216a4e7628a3069d985f1b49df12 /games-fps/urbanterror/files
parentgames-strategy/hedgewars: Pass font path to build system (diff)
downloadgentoo-f32bcdeee1d31d80e0a62facb25a6839f7f60b51.tar.gz
gentoo-f32bcdeee1d31d80e0a62facb25a6839f7f60b51.tar.bz2
gentoo-f32bcdeee1d31d80e0a62facb25a6839f7f60b51.zip
games-fps/urbanterror: Bump to 4.3.2_p20171105.
This bump adds support for skeetshoot mod. For more details, see: https://github.com/mickael9/ioq3/pull/13 and upstream commit 31e6b45a323f8ded92a1b4b78530ea0bc5382b85. According to the effort to reorganise X related calls[1], and as the icon isn't shipped anymore, only xdg_desktop_database_update is called. This bump also fixes a wrong compiler call (cc instead of correct gcc-call). [1] https://wiki.gentoo.org/wiki/Notes_on_ebuilds_with_GUI Package-Manager: Portage-2.3.14, Repoman-2.3.6 Closes: https://github.com/gentoo/gentoo/pull/6156
Diffstat (limited to 'games-fps/urbanterror/files')
-rw-r--r--games-fps/urbanterror/files/urbanterror-4.3-fix-build_system.patch73
1 files changed, 73 insertions, 0 deletions
diff --git a/games-fps/urbanterror/files/urbanterror-4.3-fix-build_system.patch b/games-fps/urbanterror/files/urbanterror-4.3-fix-build_system.patch
new file mode 100644
index 000000000000..b7a24a1b6e94
--- /dev/null
+++ b/games-fps/urbanterror/files/urbanterror-4.3-fix-build_system.patch
@@ -0,0 +1,73 @@
+Author: Nils Freydank <holgersson@posteo.de>
+Date: Fri Nov 17 20:30:00 2017 +0100
+
+Respect CFLAGS, CPPFLAGS etc. This patch is inspired
+by hasufell’s patch.
+
+--- a/Makefile 2017-03-31 11:08:58.419210817 +0200
++++ b/Makefile 2017-11-17 20:30:00.000000000 +0100
+@@ -223,7 +223,7 @@
+ ifndef USE_ALTGAMMA
+ # Clearskies - X11-based gamma for Linux
+ USE_ALTGAMMA=1
+-endif
++ endif
+
+ ifndef USE_SKEETMOD
+ USE_SKEETMOD=0
+@@ -306,34 +306,33 @@
+ CLIENT_EXTRA_FILES=
+
+ ifneq (,$(findstring "$(PLATFORM)", "linux" "gnu_kfreebsd" "kfreebsd-gnu" "gnu"))
+- BASE_CFLAGS = -Wall -fno-strict-aliasing -Wimplicit -Wstrict-prototypes \
+- -pipe -DUSE_ICON -DARCH_STRING=\\\"$(ARCH)\\\"
++ BASE_CFLAGS = -DUSE_ICON -DARCH_STRING=\\\"$(ARCH)\\\"
+ CLIENT_CFLAGS += $(SDL_CFLAGS)
+
+- OPTIMIZEVM = -O3
+- OPTIMIZE = $(OPTIMIZEVM) -ffast-math
++ OPTIMIZEVM =
++ OPTIMIZE = $(OPTIMIZEVM)
+
+ ifeq ($(ARCH),x86_64)
+- OPTIMIZEVM = -O3
+- OPTIMIZE = $(OPTIMIZEVM) -ffast-math
++ OPTIMIZEVM =
++ OPTIMIZE = $(OPTIMIZEVM)
+ HAVE_VM_COMPILED = true
+ else
+ ifeq ($(ARCH),x86)
+- OPTIMIZEVM = -O3 -march=i586
+- OPTIMIZE = $(OPTIMIZEVM) -ffast-math
++ OPTIMIZEVM =
++ OPTIMIZE = $(OPTIMIZEVM)
+ HAVE_VM_COMPILED=true
+ else
+ ifeq ($(ARCH),ppc)
+- BASE_CFLAGS += -maltivec
++ BASE_CFLAGS +=
+ HAVE_VM_COMPILED=true
+ endif
+ ifeq ($(ARCH),ppc64)
+- BASE_CFLAGS += -maltivec
++ BASE_CFLAGS +=
+ HAVE_VM_COMPILED=true
+ endif
+ ifeq ($(ARCH),sparc)
+- OPTIMIZE += -mtune=ultrasparc3 -mv8plus
+- OPTIMIZEVM += -mtune=ultrasparc3 -mv8plus
++ OPTIMIZE +=
++ OPTIMIZEVM +=
+ HAVE_VM_COMPILED=true
+ endif
+ ifeq ($(ARCH),armv7l)
+@@ -1124,7 +1123,7 @@
+
+ define DO_CC
+ $(echo_cmd) "CC $<"
+-$(Q)$(CC) $(NOTSHLIBCFLAGS) $(CFLAGS) $(CLIENT_CFLAGS) $(OPTIMIZE) -o $@ -c $<
++$(Q)$(CC) $(NOTSHLIBCFLAGS) $(CFLAGS) $(CPPFLAGS) $(CLIENT_CFLAGS) $(OPTIMIZE) -o $@ -c $<
+ endef
+
+ define DO_REF_CC
+