summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2015-12-21 17:57:13 -0500
committerMichael Sterrett <mr_bones_@gentoo.org>2015-12-21 17:57:13 -0500
commit0ee810ed8842319135f58a44e2d39b3b773b3a28 (patch)
treee5cab727b0faabd56db8c2b61cf966b151cc292b /games-fps/red-blue-quake2
parentmask games-fps/ut2004-ultraduel for removal (diff)
downloadgentoo-0ee810ed8842319135f58a44e2d39b3b773b3a28.tar.gz
gentoo-0ee810ed8842319135f58a44e2d39b3b773b3a28.tar.bz2
gentoo-0ee810ed8842319135f58a44e2d39b3b773b3a28.zip
Revert "mask games-fps/ut2004-ultraduel for removal"
This reverts commit cf00534e64f93c0992faf2584a970f1910afcc5a.
Diffstat (limited to 'games-fps/red-blue-quake2')
-rw-r--r--games-fps/red-blue-quake2/red-blue-quake2-0.1.ebuild26
1 files changed, 13 insertions, 13 deletions
diff --git a/games-fps/red-blue-quake2/red-blue-quake2-0.1.ebuild b/games-fps/red-blue-quake2/red-blue-quake2-0.1.ebuild
index 459116bea577..521b0eaa25e2 100644
--- a/games-fps/red-blue-quake2/red-blue-quake2-0.1.ebuild
+++ b/games-fps/red-blue-quake2/red-blue-quake2-0.1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
+EAPI=2
-EAPI=5
inherit eutils games
DESCRIPTION="red-blue Quake II ! play quake2 w/3d glasses !"
@@ -25,13 +25,11 @@ src_prepare() {
epatch "${FILESDIR}"/${PV}-gentoo.patch \
"${FILESDIR}/${P}"-gcc41.patch \
"${FILESDIR}/${P}"-ldflags.patch
- sed -i \
- -e "s:GENTOO_DIR:$(games_get_libdir)/${PN}:" \
- sys_linux.c || die
- sed -i \
- -e "s:/etc/quake2.conf:${GAMES_SYSCONFDIR}/${PN}.conf:" \
- sys_linux.c vid_so.c || die
- echo "$(games_get_libdir)"/${PN} > "${T}"/${PN}.conf || die
+ sed -i "s:GENTOO_DIR:$(games_get_libdir)/${PN}:" sys_linux.c \
+ || die "sed failed"
+ sed -i "s:/etc/quake2.conf:${GAMES_SYSCONFDIR}/${PN}.conf:" \
+ sys_linux.c vid_so.c \
+ || die "sed failed"
}
src_compile() {
@@ -39,20 +37,22 @@ src_compile() {
emake \
GENTOO_CFLAGS="${CFLAGS}" \
GENTOO_DATADIR="${GAMES_DATADIR}"/quake2/baseq2/ \
- build_release
+ build_release \
+ || die "emake failed"
}
src_install() {
cd release*
exeinto "$(games_get_libdir)"/${PN}
- doexe gamei386.so ref_softx.so
+ doexe gamei386.so ref_softx.so || die "doexe failed"
exeinto "$(games_get_libdir)"/${PN}/ctf
- doexe ctf/gamei386.so
- newgamesbin quake2 red-blue-quake2
+ doexe ctf/gamei386.so || die "doexe failed"
+ newgamesbin quake2 red-blue-quake2 || die "newgamesbin failed"
insinto "${GAMES_SYSCONFDIR}"
- doins "${T}"/${PN}.conf
+ echo "$(games_get_libdir)"/${PN} > ${PN}.conf
+ doins ${PN}.conf || die "doins failed"
prepgamesdirs
}