summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-09-05 04:02:11 +0100
committerSam James <sam@gentoo.org>2021-09-05 06:24:44 +0100
commitadea094719995c15eb6642c5cc7691899972ad80 (patch)
treed8a081513023e2fb3ca2b799018b94e047d07c07 /games-engines
parentnet-libs/libwebsockets: Remove old 4.2.0 (diff)
downloadgentoo-adea094719995c15eb6642c5cc7691899972ad80.tar.gz
gentoo-adea094719995c15eb6642c5cc7691899972ad80.tar.bz2
gentoo-adea094719995c15eb6642c5cc7691899972ad80.zip
games-engines/box2d: conditionally build tests
This is also a workaround for the glibc 2.34 build failure. Bug: https://bugs.gentoo.org/806342 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'games-engines')
-rw-r--r--games-engines/box2d/box2d-2.4.1.ebuild4
1 files changed, 3 insertions, 1 deletions
diff --git a/games-engines/box2d/box2d-2.4.1.ebuild b/games-engines/box2d/box2d-2.4.1.ebuild
index 9dfc4358d3dc..bbb16ef9e92c 100644
--- a/games-engines/box2d/box2d-2.4.1.ebuild
+++ b/games-engines/box2d/box2d-2.4.1.ebuild
@@ -12,13 +12,15 @@ SRC_URI="https://github.com/erincatto/Box2D/archive/v${PV}.tar.gz -> ${P}.tar.gz
LICENSE="ZLIB"
SLOT="0"
KEYWORDS="amd64 ~arm ~arm64 ~ppc64 x86"
-IUSE="doc"
+IUSE="doc test"
+RESTRICT="!test? ( test )"
BDEPEND="doc? ( app-doc/doxygen )"
src_configure() {
local mycmakeargs=(
-DBOX2D_BUILD_TESTBED=OFF # bundled libs, broken anyway right now
+ -DBOX2D_BUILD_UNIT_TESTS=$(usex test)
-DBOX2D_BUILD_DOCS=$(usex doc)
)
cmake_src_configure