summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2023-04-04 22:53:12 +0200
committerSebastian Pipping <sping@gentoo.org>2023-04-04 22:53:12 +0200
commitb9ebfbaef10f4740671c8bd90c6d2c929f8379bc (patch)
tree5c94ec46162bca7544328a47bc1bac9be87a9125 /games-board
parentapp-emacs/yaml: Stabilize 0.5.2 amd64, #903678 (diff)
downloadgentoo-b9ebfbaef10f4740671c8bd90c6d2c929f8379bc.tar.gz
gentoo-b9ebfbaef10f4740671c8bd90c6d2c929f8379bc.tar.bz2
gentoo-b9ebfbaef10f4740671c8bd90c6d2c929f8379bc.zip
games-board/pychess: 1.0.4
Signed-off-by: Sebastian Pipping <sping@gentoo.org>
Diffstat (limited to 'games-board')
-rw-r--r--games-board/pychess/Manifest1
-rw-r--r--games-board/pychess/pychess-1.0.4.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/games-board/pychess/Manifest b/games-board/pychess/Manifest
index c24e3476ca70..c56995fffa41 100644
--- a/games-board/pychess/Manifest
+++ b/games-board/pychess/Manifest
@@ -1,2 +1,3 @@
DIST pychess-1.0.3.tar.gz 14898032 BLAKE2B 0993bcf26d3284847815b37f570b7482c5359595f9649f9546ed090b6c090c3686d71478c9ecdaacde4bdf56f8f57da89623023d25809b46fe4e2800beeba91d SHA512 ca69555b1d952274fc4850f20bc66569e2f08120109908489c584231c754345b16fc1b1e9fa5b44a10582590145cf472604e5f5bd22522037666414418f5fda5
+DIST pychess-1.0.4.tar.gz 14553786 BLAKE2B 25855090d8d24f75ac519cc3f28f97c82229a72ca1e9c96bdb129271e487ff84b32fd644c953628c917bb2a1f5c71d3feaa18e10883cb207441ecf3c5119c64e SHA512 668fef78352f6aab9dabb3c061403dd7cad4db9b699d4f562820f0ae6732c337ba2aab789ad70c7e01eb3bd6f2602291afd43ddc25826f5f132b4e78b3dba4b4
DIST pychess-1.0.4a1.tar.gz 14553856 BLAKE2B d9d6d77993f4bb65330b9e07a043054261970a829bf278e9644f60876de243a6dfdbbe83dba065272bd26f0bbb046120db8498d77fb2a388b46c19cd03ef87d1 SHA512 240989ae118a5b267b0d71c8dfeea14a38c342801a33e20ebef6659d90f221c6b6debbcee2c4ebf726ad4e69b48991ed1d3eab78b78f4f0a3785e213de7e8318
diff --git a/games-board/pychess/pychess-1.0.4.ebuild b/games-board/pychess/pychess-1.0.4.ebuild
new file mode 100644
index 000000000000..05ae518edf13
--- /dev/null
+++ b/games-board/pychess/pychess-1.0.4.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_REQ_USE="sqlite"
+inherit distutils-r1 xdg
+
+DESCRIPTION="GTK chess client"
+HOMEPAGE="https://pychess.github.io/"
+SRC_URI="https://github.com/pychess/pychess/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gstreamer"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/pycairo[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP},cairo]
+ >=dev-python/sqlalchemy-2[${PYTHON_USEDEP},sqlite]
+ dev-python/websockets[${PYTHON_USEDEP}]
+ gstreamer? ( dev-python/gst-python:1.0[${PYTHON_USEDEP}] )')
+ gnome-base/librsvg:2[introspection]
+ x11-libs/gtk+:3[introspection]
+ x11-libs/gtksourceview:3.0[introspection]
+ x11-libs/pango[introspection]
+ x11-themes/adwaita-icon-theme"
+BDEPEND="${RDEPEND}" # setup.py fails if introspection deps not found
+
+src_install() {
+ distutils-r1_src_install
+
+ # https://github.com/pychess/pychess/pull/1825
+ gunzip -v "${ED}"/usr/share/man/man1/${PN}.1.gz || die
+}