summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-08-19 01:14:56 +0100
committerSam James <sam@gentoo.org>2021-08-19 01:38:59 +0100
commitcc5711b5d7361555490a74a439872e065e29a30a (patch)
tree8c344612bcfa5e052966d0a99a77427fd8236d36 /games-arcade
parentgames-arcade/openmortal: update EAPI 6 -> 7, add libsdl2[joystick] dep (diff)
downloadgentoo-cc5711b5d7361555490a74a439872e065e29a30a.tar.gz
gentoo-cc5711b5d7361555490a74a439872e065e29a30a.tar.bz2
gentoo-cc5711b5d7361555490a74a439872e065e29a30a.zip
games-arcade/kobodeluxe: add libsdl[joystick] dep
Closes: https://bugs.gentoo.org/743001 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'games-arcade')
-rw-r--r--games-arcade/kobodeluxe/kobodeluxe-0.5.1-r3.ebuild (renamed from games-arcade/kobodeluxe/kobodeluxe-0.5.1-r2.ebuild)11
1 files changed, 7 insertions, 4 deletions
diff --git a/games-arcade/kobodeluxe/kobodeluxe-0.5.1-r2.ebuild b/games-arcade/kobodeluxe/kobodeluxe-0.5.1-r3.ebuild
index b813ddc2a1b0..8f68045c4f6a 100644
--- a/games-arcade/kobodeluxe/kobodeluxe-0.5.1-r2.ebuild
+++ b/games-arcade/kobodeluxe/kobodeluxe-0.5.1-r3.ebuild
@@ -1,27 +1,27 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+
inherit desktop
MY_P="KoboDeluxe-${PV/_/}"
DESCRIPTION="An SDL port of xkobo, a addictive space shoot-em-up"
HOMEPAGE="http://www.olofson.net/kobodl/"
SRC_URI="http://www.olofson.net/kobodl/download/${MY_P}.tar.bz2"
+S="${WORKDIR}/${MY_P}"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~ppc64 ~x86"
IUSE="opengl"
-DEPEND="media-libs/libsdl
+DEPEND="media-libs/libsdl[joystick]
media-libs/sdl-image[png]
opengl? ( virtual/opengl )
"
RDEPEND="${DEPEND}"
-S="${WORKDIR}/${MY_P}"
-
PATCHES=(
"${FILESDIR}"/${P}-glibc29.patch
"${FILESDIR}"/${P}-glibc2.10.patch
@@ -36,11 +36,13 @@ src_unpack() {
src_prepare() {
default
+
# Fix paths
sed -i \
-e 's:\$(datadir)/kobo-deluxe:$(datadir)/kobodeluxe:' \
-e 's:\$(sharedstatedir)/kobo-deluxe/scores:$(localstatedir)/kobodeluxe:' \
configure || die "sed configure failed"
+
sed -i \
-e 's:kobo-deluxe:kobodeluxe:' \
data/gfx/Makefile.in \
@@ -53,6 +55,7 @@ src_configure() {
src_install() {
default
+
newicon icons/KDE/icons/32x32/kobodl.png ${PN}.png
make_desktop_entry kobodl "Kobo Deluxe"
keepdir /var/lib/${PN}