summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2015-12-18 04:36:01 -0500
committerMichael Sterrett <mr_bones_@gentoo.org>2015-12-18 04:36:01 -0500
commit517228da801915dd7e004d66fceeb010ba524599 (patch)
tree845de6ac346bf3fbf5d5de0d047852be758e178e /games-arcade
parentEAPI=5; minor tidying (diff)
downloadgentoo-517228da801915dd7e004d66fceeb010ba524599.tar.gz
gentoo-517228da801915dd7e004d66fceeb010ba524599.tar.bz2
gentoo-517228da801915dd7e004d66fceeb010ba524599.zip
EAPI=5; minor tidying
Package-Manager: portage-2.2.24
Diffstat (limited to 'games-arcade')
-rw-r--r--games-arcade/cdogs-sdl/cdogs-sdl-0.4-r1.ebuild15
1 files changed, 7 insertions, 8 deletions
diff --git a/games-arcade/cdogs-sdl/cdogs-sdl-0.4-r1.ebuild b/games-arcade/cdogs-sdl/cdogs-sdl-0.4-r1.ebuild
index ec3c7898a736..f0534386f851 100644
--- a/games-arcade/cdogs-sdl/cdogs-sdl-0.4-r1.ebuild
+++ b/games-arcade/cdogs-sdl/cdogs-sdl-0.4-r1.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=4
+EAPI=5
inherit eutils games
CDOGS_DATA="cdogs-data-2007-07-06"
@@ -11,31 +11,30 @@ HOMEPAGE="http://lumaki.com/code/cdogs"
SRC_URI="http://icculus.org/cdogs-sdl/files/src/${P}.tar.bz2
http://icculus.org/cdogs-sdl/files/data/${CDOGS_DATA}.tar.bz2"
-LICENSE="GPL-2"
+LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="amd64 x86"
IUSE=""
-DEPEND="media-libs/libsdl
+DEPEND="media-libs/libsdl[video]
media-libs/sdl-mixer"
+RDPEND=${DEPEND}
S=${WORKDIR}/${P}/src
src_unpack() {
unpack ${A}
- mv ${CDOGS_DATA} ${P}/data || die "Failed moving data around"
+ mv ${CDOGS_DATA} ${P}/data || die
}
src_prepare() {
sed -i \
-e "/^CF_OPT/d" \
-e "/^CC/d" \
- Makefile \
- || die "sed failed"
+ Makefile || die
sed -i \
-e "/\bopen(/s/)/, 0666)/" \
- files.c \
- || die "sed failed"
+ files.c || die
epatch "${FILESDIR}"/${P}-64bit.patch
}