summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron W. Swenson <titanofold@gentoo.org>2023-03-20 06:50:18 -0400
committerAaron W. Swenson <titanofold@gentoo.org>2023-03-20 06:50:18 -0400
commitf87e13ff2ad9583899ed04bc024c53eb297a9715 (patch)
tree54d1416d1e739f99c6f60f07b205bd72d9b39fe3 /dev-vcs
parentgames-puzzle/atomix: EAPI 8, drop empty ISUE, fix libgnome-games-support dep (diff)
downloadgentoo-f87e13ff2ad9583899ed04bc024c53eb297a9715.tar.gz
gentoo-f87e13ff2ad9583899ed04bc024c53eb297a9715.tar.bz2
gentoo-f87e13ff2ad9583899ed04bc024c53eb297a9715.zip
dev-vcs/fossil: add 2.21
Signed-off-by: Aaron W. Swenson <titanofold@gentoo.org>
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/fossil/Manifest1
-rw-r--r--dev-vcs/fossil/fossil-2.21.ebuild77
2 files changed, 78 insertions, 0 deletions
diff --git a/dev-vcs/fossil/Manifest b/dev-vcs/fossil/Manifest
index 7d91d7c41f02..9c719a6045e3 100644
--- a/dev-vcs/fossil/Manifest
+++ b/dev-vcs/fossil/Manifest
@@ -1 +1,2 @@
DIST fossil-src-2.19.tar.gz 6435868 BLAKE2B 414dd8b1630bb6a8bcc22f3528da60386663e7f31191e5134474e37211e55323af45947452a0f09e21964dd3cd94ca6cf6e34ecd74e0d3e4f0dce7a50146f0ff SHA512 fcd84df2d84c3a958bb19228de4320456382d3c925717c58bec42de86d96383a9208fb31ba6aaeccd9bc6bba949048d5c1ce3d2b3e8535951956ae18d9aa34e4
+DIST fossil-src-2.21.tar.gz 6703622 BLAKE2B fcc74ed5e3eec34f044624b128b8933b54d1cea99a212a1423e369fc469af4634f469f8c9c20af768c41edc9f1ec2592a074f87dadd5b9b90805906451268f0e SHA512 22534eb632f485de895b291a35325efe9bfd13ec0df84e94afe822593489ecdb2998352dcd501123d8d4c426a40bd4ff43190b50fb849392f886dd94bee42bf3
diff --git a/dev-vcs/fossil/fossil-2.21.ebuild b/dev-vcs/fossil/fossil-2.21.ebuild
new file mode 100644
index 000000000000..f7baf17994b4
--- /dev/null
+++ b/dev-vcs/fossil/fossil-2.21.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+MY_TAG="f9aa474081f0618c76f4c2f4d6f0277a3fd480aa185d7da0b8b61b00fad1aa78"
+
+DESCRIPTION="Simple, high-reliability, source control management, and more"
+HOMEPAGE="https://www.fossil-scm.org/home"
+SRC_URI="https://fossil-scm.org/home/tarball/${MY_TAG}/fossil-src-${PV}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~riscv ~x86"
+IUSE="debug fusefs json system-sqlite +ssl static tcl tcl-stubs
+ tcl-private-stubs th1-docs th1-hooks"
+
+# Please check sqlite minimum version on every release. This can be done with:
+# ./configure --print-minimum-sqlite-version
+RDEPEND="
+ sys-libs/zlib
+ || (
+ sys-libs/readline:0
+ dev-libs/libedit
+ )
+ system-sqlite? ( >=dev-db/sqlite-3.38.0:3 )
+ ssl? ( dev-libs/openssl:0= )
+ tcl? ( dev-lang/tcl:0= )
+"
+
+# Either tcl or jimtcl need to be present to build Fossil (Bug #675778)
+DEPEND="${RDEPEND}
+ !tcl? (
+ || (
+ dev-lang/tcl:*
+ dev-lang/jimtcl:*
+ )
+ )
+"
+
+# Tests can't be run from the build directory
+RESTRICT="test"
+
+PATCHES=(
+ # fossil-2.10-check-lib64-for-tcl.patch: Bug 690828
+ "${FILESDIR}"/fossil-2.10-check-lib64-for-tcl.patch
+)
+
+S="${WORKDIR}/fossil-src-${PV}"
+
+src_configure() {
+ # this is not an autotools situation so don't make it seem like one
+ # --with-tcl: works
+ # --without-tcl: dies
+ local myconf="--with-openssl=$(usex ssl auto none)"
+ use debug && myconf+=' --fossil-debug'
+ use json && myconf+=' --json'
+ use system-sqlite && myconf+=' --disable-internal-sqlite'
+ use static && myconf+=' --static'
+ use tcl && myconf+=' --with-tcl=1'
+ use fusefs || myconf+=' --disable-fusefs'
+
+ local u useflags
+ useflags=( tcl-stubs tcl-private-stubs th1-docs th1-hooks )
+ for u in ${useflags[@]} ; do
+ use ${u} && myconf+=" --with-${u}"
+ done
+
+ tc-export CC CXX
+ CC_FOR_BUILD=${CC} ./configure ${myconf} || die
+}
+
+src_install() {
+ dobin fossil
+}