summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-09-04 09:49:59 +0200
committerMaciej Barć <xgqt@gentoo.org>2024-09-04 10:09:37 +0200
commit702e0ffd68c0fc98ab5eec53d990d1eba041693f (patch)
tree73d0a1123caf9c76eeb0651f88c706aab6a0f6fc /dev-vcs
parentsys-fs/xfsdump: add 3.2.0, filter LTO (diff)
downloadgentoo-702e0ffd68c0fc98ab5eec53d990d1eba041693f.tar.gz
gentoo-702e0ffd68c0fc98ab5eec53d990d1eba041693f.tar.bz2
gentoo-702e0ffd68c0fc98ab5eec53d990d1eba041693f.zip
dev-vcs/pre-commit: drop old 3.7.0
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/pre-commit/Manifest1
-rw-r--r--dev-vcs/pre-commit/pre-commit-3.7.0.ebuild60
2 files changed, 0 insertions, 61 deletions
diff --git a/dev-vcs/pre-commit/Manifest b/dev-vcs/pre-commit/Manifest
index 547da45e272f..fc0190bbdaf9 100644
--- a/dev-vcs/pre-commit/Manifest
+++ b/dev-vcs/pre-commit/Manifest
@@ -1,3 +1,2 @@
-DIST pre-commit-3.7.0.gh.tar.gz 269999 BLAKE2B 9ca1b2279e1ed753a09c3da83f6de19fc9b36821ba6f642962b9be1da29894e3260c48a2cdb582eb5331543fa6c7e9065d799fde7ab4e84dd54032c2ff84e4a7 SHA512 2a238e74ce2f080914e4403b7ce7b8dbd2a257a736d8292e2ec299c8015d3c4611e51f4be1a95ff2bd29db4888f6997e335346931567e943a8b5d78be7c14725
DIST pre-commit-3.7.1.gh.tar.gz 270138 BLAKE2B da21e8c05b722985273554bd455d2ea0c113206eb4924c826532b5135805eca143441a237e516fad1275b4c9886d53cb3757d5fefd53613e1f1a1b4da8d7847d SHA512 ffb7606b1706d5e9f46bdffbe20420e6fd4241f6a402740e02f6d8a0e87f29201a20ab92d89fd7ed77f3df31ada6f157837beac9defab7f35ebabf85d47399e8
DIST pre-commit-3.8.0.gh.tar.gz 270925 BLAKE2B febb7b6bb2e43aec096e454b064b01b0973cd9d04b2d792a4ce7cef9df4f9c9c2e3bf1200f584e163c829c12ca17f57761375b297ab5c3d97dce569d5c219bdd SHA512 b6970ac00c5033938462675c20ea5e13c0439dc4f70cd627f11b22b0f87fb0a3590e9b3e9c677bfb66e4b3420f40de66ca7ccbc969847ee5fa8994532a558cd1
diff --git a/dev-vcs/pre-commit/pre-commit-3.7.0.ebuild b/dev-vcs/pre-commit/pre-commit-3.7.0.ebuild
deleted file mode 100644
index 90ea7eb7e160..000000000000
--- a/dev-vcs/pre-commit/pre-commit-3.7.0.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{10..12} )
-DISTUTILS_SINGLE_IMPL=1
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_REQ_USE="sqlite"
-
-inherit distutils-r1
-
-DESCRIPTION="A framework for managing and maintaining multi-language Git pre-commit hooks"
-HOMEPAGE="https://pre-commit.com/"
-SRC_URI="https://github.com/${PN}/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 ~hppa ~ppc ~ppc64 x86"
-
-RDEPEND="dev-vcs/git
- $(python_gen_cond_dep '
- >=dev-python/cfgv-2.0.0[${PYTHON_USEDEP}]
- >=dev-python/identify-1.0.0[${PYTHON_USEDEP}]
- >=dev-python/nodeenv-0.11.1[${PYTHON_USEDEP}]
- >=dev-python/pyyaml-5.1[${PYTHON_USEDEP}]
- >=dev-python/virtualenv-20.10.0[${PYTHON_USEDEP}]
- ')"
-# coreutils requirement: see Bug #885559
-BDEPEND="test? (
- $(python_gen_cond_dep '
- dev-python/pytest-env[${PYTHON_USEDEP}]
- dev-python/re-assert[${PYTHON_USEDEP}]
- ')
- sys-apps/coreutils[-multicall]
-)"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-3.1.1-tests_git_file_transport.patch
-)
-
-DOCS=( CHANGELOG.md CONTRIBUTING.md README.md )
-
-EPYTEST_DESELECT=(
- # All of these require a boatload of dependencies (e.g. Conda, Go, R and more) in order to run
- # and while some of them do include "skip if not found" logic, most of them do not.
- tests/languages/
- tests/repository_test.py
- # These three consistently fail with
- # Calling "git rev-parse" fails with "fatal: not a git repository (or any of the parent directories): .git".
- # including with the sandbox disabled.
- tests/main_test.py::test_all_cmds
- tests/main_test.py::test_hook_stage_migration
- tests/main_test.py::test_try_repo
- # These two fail if pre-commit is already installed (Bug #894502)
- tests/commands/install_uninstall_test.py::test_environment_not_sourced
- tests/commands/install_uninstall_test.py::test_installed_from_venv
-)
-
-distutils_enable_tests pytest