summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNils Freydank <holgersson@posteo.de>2023-09-23 16:10:27 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2023-09-25 09:33:05 +0300
commit0900a1dda1a1f078b99d5a1800361764794751a4 (patch)
treefb58de770ac415d213cf4ec4a691de1e32a444bf /dev-vcs
parentapp-shells/starship: Drop 1.14.2 (diff)
downloadgentoo-0900a1dda1a1f078b99d5a1800361764794751a4.tar.gz
gentoo-0900a1dda1a1f078b99d5a1800361764794751a4.tar.bz2
gentoo-0900a1dda1a1f078b99d5a1800361764794751a4.zip
dev-vcs/git-lfs: Enable shell auto-completion
- Build and install the auto completion for bash, fish and zsh. - Switch from "go .. || die" to "ego ...". See upstream issue requesting pre-generated files for releases: https://github.com/git-lfs/git-lfs/issues/5520 Closes: https://bugs.gentoo.org/914542 Signed-off-by: Nils Freydank <holgersson@posteo.de> Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/git-lfs/git-lfs-3.4.0-r1.ebuild (renamed from dev-vcs/git-lfs/git-lfs-3.4.0.ebuild)17
1 files changed, 15 insertions, 2 deletions
diff --git a/dev-vcs/git-lfs/git-lfs-3.4.0.ebuild b/dev-vcs/git-lfs/git-lfs-3.4.0-r1.ebuild
index 10b83717c479..cbd1a55aa124 100644
--- a/dev-vcs/git-lfs/git-lfs-3.4.0.ebuild
+++ b/dev-vcs/git-lfs/git-lfs-3.4.0-r1.ebuild
@@ -6,7 +6,7 @@ EGO_PN=github.com/git-lfs/git-lfs
# Update the ID as it's included in each build.
COMMIT_ID="d06d6e9efd78ff4f958b072146ce167d87f60285"
-inherit go-module
+inherit go-module shell-completion
DESCRIPTION="Command line extension and specification for managing large files with git"
HOMEPAGE="
@@ -61,18 +61,31 @@ src_compile() {
-trimpath
-v -work -x
)
- go build "${mygobuildargs[@]}" -o git-lfs git-lfs.go || die
+ ego build "${mygobuildargs[@]}" -o git-lfs git-lfs.go
if use doc; then
for doc in docs/man/*adoc;
do asciidoctor -b manpage ${doc} || die "man building failed"
done
fi
+
+ # Generate auto-completion scripts.
+ # bug 914542
+ ./git-lfs completion bash > "${PN}.bash" || die
+ ./git-lfs completion fish > "${PN}.fish" || die
+ ./git-lfs completion zsh > "${PN}.zsh" || die
}
src_install() {
dobin git-lfs
einstalldocs
+
+ # Install auto-completion scripts generated earlier.
+ # bug 914542
+ newbashcomp "${PN}.bash" "${PN}"
+ dofishcomp "${PN}.fish"
+ newzshcomp "${PN}.zsh" "_${PN}"
+
use doc && doman docs/man/*.1
}