summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNils Freydank <holgersson@posteo.de>2023-07-29 14:20:56 +0200
committerSam James <sam@gentoo.org>2023-08-08 06:26:43 +0100
commit00cfa1f2bd735773fac6f9b0cba820c0205e364c (patch)
tree56d7e094fe5b74485d8c4b9ef0b1b087f09ea71a /dev-vcs
parentdev-vcs/git-lfs: Bump to 3.4.0 (diff)
downloadgentoo-00cfa1f2bd735773fac6f9b0cba820c0205e364c.tar.gz
gentoo-00cfa1f2bd735773fac6f9b0cba820c0205e364c.tar.bz2
gentoo-00cfa1f2bd735773fac6f9b0cba820c0205e364c.zip
dev-vcs/git-lfs: Update the live ebuild
Update the SRC_URI archive in this file, too to allow renaming into the next version. (And add the other stuff from 3.4.0 aswell.) Signed-off-by: Nils Freydank <holgersson@posteo.de> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/git-lfs/git-lfs-9999.ebuild12
1 files changed, 9 insertions, 3 deletions
diff --git a/dev-vcs/git-lfs/git-lfs-9999.ebuild b/dev-vcs/git-lfs/git-lfs-9999.ebuild
index 7b98fd42b0f3..10b83717c479 100644
--- a/dev-vcs/git-lfs/git-lfs-9999.ebuild
+++ b/dev-vcs/git-lfs/git-lfs-9999.ebuild
@@ -4,7 +4,7 @@
EAPI=8
EGO_PN=github.com/git-lfs/git-lfs
# Update the ID as it's included in each build.
-COMMIT_ID="77deabdf9a18f8a07ecfd3e0f4aa572ffbbab8d4"
+COMMIT_ID="d06d6e9efd78ff4f958b072146ce167d87f60285"
inherit go-module
@@ -18,9 +18,15 @@ if [[ "${PV}" = 9999* ]]; then
EGIT_REPO_URI="https://${EGO_PN}"
inherit git-r3
else
- SRC_URI="https://${EGO_PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+ SRC_URI="https://${EGO_PN}/releases/download/v${PV}/${PN}-v${PV}.tar.gz -> ${P}.tar.gz"
# Add the manually vendored tarball.
- # Compress the tarball with: xz -9kT0 --memlimit-decompress=256M
+ # 1) Create a tar archive optimized to reproduced by other users or devs.
+ # 2) Compress the archive using XZ limiting decompression memory for
+ # pretty constraint systems.
+ # Use something like:
+ # tar cf $P-deps.tar go-mod \
+ # --mtime="1970-01-01" --sort=name --owner=portage --group=portage
+ # xz -k -9eT0 --memlimit-decompress=256M $P-deps.tar
SRC_URI+=" https://files.holgersson.xyz/gentoo/distfiles/golang-pkg-deps/${P}-deps.tar.xz"
KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux"
fi