summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-vcs/hgsvn
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-vcs/hgsvn')
-rw-r--r--dev-vcs/hgsvn/Manifest1
-rw-r--r--dev-vcs/hgsvn/hgsvn-0.2.3-r1.ebuild38
-rw-r--r--dev-vcs/hgsvn/metadata.xml11
3 files changed, 50 insertions, 0 deletions
diff --git a/dev-vcs/hgsvn/Manifest b/dev-vcs/hgsvn/Manifest
new file mode 100644
index 000000000000..9744d753d4a4
--- /dev/null
+++ b/dev-vcs/hgsvn/Manifest
@@ -0,0 +1 @@
+DIST hgsvn-0.2.3.zip 199696 SHA256 bd066a058b34b8beb0b108e729f223e177532487fed0422d978061620422ed0e SHA512 d88d683730430b825411b4267c78e82e492f45d55c49c8a19ed159a95390e58507b07217c4e5082a223c3217042fdc1ae2c96648b1880bd441117ca173ca4c09 WHIRLPOOL aa0027405a1d8aa58cb41e563f5120e00b8ea38a8a944146a0df3e4b715f2a0276f6811285aa1d324f3407fd11d234b4a5dba37c563612c3f98007b69cd8eca0
diff --git a/dev-vcs/hgsvn/hgsvn-0.2.3-r1.ebuild b/dev-vcs/hgsvn/hgsvn-0.2.3-r1.ebuild
new file mode 100644
index 000000000000..4673b29205e6
--- /dev/null
+++ b/dev-vcs/hgsvn/hgsvn-0.2.3-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+DISTUTILS_SINGLE_IMPL=1
+
+inherit distutils-r1
+PYTHON_REQ_USE="xml"
+
+DESCRIPTION="A set of scripts to work locally on Subversion checkouts using Mercurial"
+HOMEPAGE="http://pypi.python.org/pypi/hgsvn"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-linux ~x86-macos"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}
+ dev-vcs/subversion[${PYTHON_USEDEP}]"
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+}
+
+python_prepare_all() {
+ sed -e "/use_setuptools/d" -i setup.py || die "sed failed"
+ distutils-r1_python_prepare_all
+}
+
+python_install() {
+ distutils-r1_python_install
+ rm -fr "${ED}$(python_get_sitedir)/hgsvn/unittests"
+}
diff --git a/dev-vcs/hgsvn/metadata.xml b/dev-vcs/hgsvn/metadata.xml
new file mode 100644
index 000000000000..e2a0f12dc5dd
--- /dev/null
+++ b/dev-vcs/hgsvn/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+ <longdescription>A set of scripts to work locally on Subversion checkouts using Mercurial</longdescription>
+ <upstream>
+ <remote-id type="pypi">hgsvn</remote-id>
+ </upstream>
+</pkgmetadata>