summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfred Wingate <parona@protonmail.com>2024-02-21 02:29:20 +0200
committerSam James <sam@gentoo.org>2024-03-21 02:53:26 +0000
commitc15823cae00f79c7d3758b0342c421457c32628b (patch)
tree70320340d21c17dac7b675d9a3f211966c3852d1 /dev-util
parentdev-util/ebuildtester: enable py3.12 (diff)
downloadgentoo-c15823cae00f79c7d3758b0342c421457c32628b.tar.gz
gentoo-c15823cae00f79c7d3758b0342c421457c32628b.tar.bz2
gentoo-c15823cae00f79c7d3758b0342c421457c32628b.zip
dev-util/ebuildtester: correct sphinx dependency
* Sphinx is only needed for building docs, previously the docs weren't even built so actually build it conditionally. * DEPEND -> BDEPEND. Signed-off-by: Alfred Wingate <parona@protonmail.com> Closes: https://github.com/gentoo/gentoo/pull/35453 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/ebuildtester/ebuildtester-42-r3.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-util/ebuildtester/ebuildtester-42-r3.ebuild b/dev-util/ebuildtester/ebuildtester-42-r3.ebuild
new file mode 100644
index 000000000000..f15cf5a0fb54
--- /dev/null
+++ b/dev-util/ebuildtester/ebuildtester-42-r3.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit bash-completion-r1 distutils-r1 pypi
+
+DESCRIPTION="A dockerized approach to test a Gentoo package within a clean stage3 container"
+HOMEPAGE="https://ebuildtester.readthedocs.io/"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ app-containers/docker
+ app-containers/docker-cli
+ sys-fs/fuse
+"
+
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+"
+
+distutils_enable_sphinx docs dev-python/sphinx-rtd-theme
+distutils_enable_tests unittest
+
+src_install() {
+ distutils-r1_src_install
+ newbashcomp "${PN}.bash-completion" "${PN}"
+}