summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFilip Kobierski <fkobi@pm.me>2024-08-24 21:51:20 +0200
committerJoonas Niilola <juippis@gentoo.org>2024-11-06 13:38:48 +0200
commitb595ffefd5fb225fc65fbc336e771771e94dc941 (patch)
tree9d165c724a6b8c6f476c58b0c9379f5d533ffb63 /dev-util
parentdev-util/redo: add python3.12 support (diff)
downloadgentoo-b595ffefd5fb225fc65fbc336e771771e94dc941.tar.gz
gentoo-b595ffefd5fb225fc65fbc336e771771e94dc941.tar.bz2
gentoo-b595ffefd5fb225fc65fbc336e771771e94dc941.zip
dev-util/repolite: add 0.6.2 with new python compat
Signed-off-by: Filip Kobierski <fkobi@pm.me> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/repolite/Manifest1
-rw-r--r--dev-util/repolite/repolite-0.6.2.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/dev-util/repolite/Manifest b/dev-util/repolite/Manifest
index 9fe70e4adb74..d6323351aef0 100644
--- a/dev-util/repolite/Manifest
+++ b/dev-util/repolite/Manifest
@@ -1 +1,2 @@
DIST repolite-0.4.0.tar.gz 29316 BLAKE2B 7843eee116de881e688d1ba7ef16113c0dd63d5c1a795d6c6c7b7c034e3dc5c82f5838049e33703cd8c16ea4a7d96c2ae365278be81df6267f2cb171b20dd059 SHA512 14990576f0cd5c77174318be023f0dc63b7dab957e2a896e2a021d5d24b8dccaefad7170ff75ef7e3308ed65ed72092bfc19dca2efdb14598b73722764d9a4dd
+DIST repolite-0.6.2.tar.gz 59311 BLAKE2B a5fbce62f272181249f4374b16837780733e5cfb033a2812330a6c029e5881846181f68dc1537ab148395092eb181650f7eb03a9e6760ed47207f33abf689d40 SHA512 b4ec870eb11d8edfe9c103e5b8f4b78eab46d4739055d01b02560036da30b01178c2351fe7aafb1b676105f5e6b8bdc456081917fd4e84219cea37ee2acaa5c3
diff --git a/dev-util/repolite/repolite-0.6.2.ebuild b/dev-util/repolite/repolite-0.6.2.ebuild
new file mode 100644
index 000000000000..427603038c28
--- /dev/null
+++ b/dev-util/repolite/repolite-0.6.2.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Manage a small set of git repository dependencies with YAML."
+HOMEPAGE="https://github.com/sarnold/repolite"
+
+if [[ ${PV} = 9999* ]]; then
+ EGIT_REPO_URI="https://github.com/sarnold/repolite.git"
+ EGIT_BRANCH="master"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/sarnold/repolite/releases/download/${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+fi
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+IUSE="doc"
+RESTRICT="test" # no tests :(
+
+RDEPEND="
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/munch[${PYTHON_USEDEP}]
+ dev-vcs/git
+"
+# needs versioningit if building from git repo source
+if [[ ${PV} = 9999* ]]; then
+ BDEPEND="$(python_gen_any_dep '>=dev-python/versioningit-2.0.1[${PYTHON_USEDEP}]')"
+fi
+
+DOCS=( README.rst )
+
+distutils_enable_sphinx \
+ docs/source \
+ dev-python/sphinx-rtd-theme \
+ dev-python/recommonmark \
+ dev-python/sphinxcontrib-apidoc
+
+pkg_postinst() {
+ optfeature "initialize repos with lfs files" dev-vcs/git-lfs
+}