summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2023-05-11 12:32:54 +0100
committerMarek Szuba <marecki@gentoo.org>2023-05-11 12:59:28 +0100
commit51b310b76aeebcc7afca3e2d27f0b4cba34bcc48 (patch)
treefb947e004c7f158510f737761ffd8420b0f0feb5 /dev-util
parentdev-util/yamllint: drop 1.28.0 (diff)
downloadgentoo-51b310b76aeebcc7afca3e2d27f0b4cba34bcc48.tar.gz
gentoo-51b310b76aeebcc7afca3e2d27f0b4cba34bcc48.tar.bz2
gentoo-51b310b76aeebcc7afca3e2d27f0b4cba34bcc48.zip
dev-util/yamllint: add 1.31.0
Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/yamllint/Manifest1
-rw-r--r--dev-util/yamllint/yamllint-1.31.0.ebuild22
2 files changed, 23 insertions, 0 deletions
diff --git a/dev-util/yamllint/Manifest b/dev-util/yamllint/Manifest
index f468295fef88..a9180e611e93 100644
--- a/dev-util/yamllint/Manifest
+++ b/dev-util/yamllint/Manifest
@@ -1,2 +1,3 @@
DIST yamllint-1.29.0.tar.gz 123149 BLAKE2B ffb19628eb4ae5bf41e8ad1eb1295ed4c6d2c7f08cc819884e1e52552ae37542d5822ce76ef531072a955435a99b512c0c75f32c70e60124c51bde9b76eaff53 SHA512 25c8b1db12c1955878a368433634277a75c2fbde14b041022f591ff7d71b975b509e24b6755c98fa086d3a3a5adf1560ef62f86f9f9e4798d6ca5a0fb50e9e52
DIST yamllint-1.30.0.tar.gz 124272 BLAKE2B 670115e61b4c744067d658474ef645a6f10351b898a544800c657bb2adf949167448d6cb6feeabe1dc3096124b862a0ff93d62cbb3428bef3dd5b42c33e9c750 SHA512 1db2c7133d7ce279a84d326684284e674f972cb820528201546cb3ab85309ab4baa4e1df7aca0529217a2a0b0d499158fd406be4263470ec9936326f844dc266
+DIST yamllint-1.31.0.tar.gz 128661 BLAKE2B f34da9302d9d3938f062931bc2aef2230b473798af0d2ad99dc89b4d814c49ce19c61363ff391e5c91d09497df9f83f6cfa1a0f34c8f74ef61341aa25ca320fb SHA512 2e23b60626eb7907f8d672cf3558178e670448e2413cc191dbea0052622353826a349380a7475724d3e88b18bc8373f99a2f72f70bb935a3b69b60811cfe62f0
diff --git a/dev-util/yamllint/yamllint-1.31.0.ebuild b/dev-util/yamllint/yamllint-1.31.0.ebuild
new file mode 100644
index 000000000000..49b3567c1eda
--- /dev/null
+++ b/dev-util/yamllint/yamllint-1.31.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A linter for YAML files"
+HOMEPAGE="https://pypi.org/project/yamllint/ https://github.com/adrienverge/yamllint/"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND=">=dev-python/pathspec-0.5.3[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest