summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-07-13 22:55:18 +0100
committerSam James <sam@gentoo.org>2021-07-13 22:55:18 +0100
commita7aa790649741a0035f60cabf69ce57fa13adec7 (patch)
treee087be762267ecbbae0ab04b534d04d52159d9e1 /dev-util/uncrustify
parentdev-vcs/gitolite-gentoo: call default in src_prepare (diff)
downloadgentoo-a7aa790649741a0035f60cabf69ce57fa13adec7.tar.gz
gentoo-a7aa790649741a0035f60cabf69ce57fa13adec7.tar.bz2
gentoo-a7aa790649741a0035f60cabf69ce57fa13adec7.zip
dev-util/uncrustify: fix Python dependency
Closes: https://bugs.gentoo.org/801886 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-util/uncrustify')
-rw-r--r--dev-util/uncrustify/uncrustify-0.71.0.ebuild6
-rw-r--r--dev-util/uncrustify/uncrustify-0.72.0.ebuild6
-rw-r--r--dev-util/uncrustify/uncrustify-9999.ebuild6
3 files changed, 15 insertions, 3 deletions
diff --git a/dev-util/uncrustify/uncrustify-0.71.0.ebuild b/dev-util/uncrustify/uncrustify-0.71.0.ebuild
index 2e266f8783d9..5bd13fa54668 100644
--- a/dev-util/uncrustify/uncrustify-0.71.0.ebuild
+++ b/dev-util/uncrustify/uncrustify-0.71.0.ebuild
@@ -26,4 +26,8 @@ SLOT="0"
IUSE="test"
RESTRICT="!test? ( test )"
-DEPEND="test? ( ${PYTHON_DEPS} )"
+BDEPEND="test? ( ${PYTHON_DEPS} )"
+
+pkg_setup() {
+ use test && python-any-r1_pkg_setup
+}
diff --git a/dev-util/uncrustify/uncrustify-0.72.0.ebuild b/dev-util/uncrustify/uncrustify-0.72.0.ebuild
index 573dbcd833df..9e76b92aa679 100644
--- a/dev-util/uncrustify/uncrustify-0.72.0.ebuild
+++ b/dev-util/uncrustify/uncrustify-0.72.0.ebuild
@@ -24,4 +24,8 @@ SLOT="0"
IUSE="test"
RESTRICT="!test? ( test )"
-DEPEND="test? ( ${PYTHON_DEPS} )"
+BDEPEND="test? ( ${PYTHON_DEPS} )"
+
+pkg_setup() {
+ use test && python-any-r1_pkg_setup
+}
diff --git a/dev-util/uncrustify/uncrustify-9999.ebuild b/dev-util/uncrustify/uncrustify-9999.ebuild
index 8f51f156ef9d..d078b64fab35 100644
--- a/dev-util/uncrustify/uncrustify-9999.ebuild
+++ b/dev-util/uncrustify/uncrustify-9999.ebuild
@@ -26,4 +26,8 @@ SLOT="0"
IUSE="test"
RESTRICT="!test? ( test )"
-DEPEND="test? ( ${PYTHON_DEPS} )"
+BDEPEND="test? ( ${PYTHON_DEPS} )"
+
+pkg_setup() {
+ use test && python-any-r1_pkg_setup
+}