summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorhololeap <hololeap@protonmail.com>2023-10-02 23:11:19 -0600
committerSam James <sam@gentoo.org>2023-10-23 04:10:31 +0100
commitaf52254302babba0a1df6136d57e629e81b57d5f (patch)
tree8ecec89f9c5e6646a6b981b2e2f21d5f12f0fc6b /dev-util/shellcheck
parentdev-haskell/zlib: add 0.6.3.0 (diff)
downloadgentoo-af52254302babba0a1df6136d57e629e81b57d5f.tar.gz
gentoo-af52254302babba0a1df6136d57e629e81b57d5f.tar.bz2
gentoo-af52254302babba0a1df6136d57e629e81b57d5f.zip
dev-util/shellcheck: Revision bump
Modifiy constraint on 'fgl' Signed-off-by: hololeap <hololeap@protonmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-util/shellcheck')
-rw-r--r--dev-util/shellcheck/metadata.xml4
-rw-r--r--dev-util/shellcheck/shellcheck-0.9.0-r2.ebuild51
-rw-r--r--dev-util/shellcheck/shellcheck-0.9.0.ebuild30
3 files changed, 55 insertions, 30 deletions
diff --git a/dev-util/shellcheck/metadata.xml b/dev-util/shellcheck/metadata.xml
index 937381521944..792eb9603797 100644
--- a/dev-util/shellcheck/metadata.xml
+++ b/dev-util/shellcheck/metadata.xml
@@ -5,4 +5,8 @@
<email>haskell@gentoo.org</email>
<name>Gentoo Haskell</name>
</maintainer>
+ <upstream>
+ <remote-id type="hackage">ShellCheck</remote-id>
+ <remote-id type="github">koalaman/shellcheck</remote-id>
+ </upstream>
</pkgmetadata>
diff --git a/dev-util/shellcheck/shellcheck-0.9.0-r2.ebuild b/dev-util/shellcheck/shellcheck-0.9.0-r2.ebuild
new file mode 100644
index 000000000000..c6c9cfada7db
--- /dev/null
+++ b/dev-util/shellcheck/shellcheck-0.9.0-r2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# ebuild generated by hackport 0.8.4.0.9999
+
+CABAL_HACKAGE_REVISION=1
+CABAL_PN="ShellCheck"
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Shell script analysis tool"
+HOMEPAGE="https://www.shellcheck.net/"
+
+LICENSE="GPL-3"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+
+# hololeap (2023-09-10)
+# 1 test fails
+# === prop_checkOverwrittenExitCode8 from src/ShellCheck/Analytics.hs:4927 ===
+# *** Failed! Exception: '(Array.!): undefined array element' (after 1 test):
+RESTRICT="test"
+
+CABAL_CHDEPS=(
+
+# hololeap (2023-09-02)
+# This is from the upstream git repo
+# See: <https://github.com/koalaman/shellcheck/pull/2749#issuecomment-1703896093>
+ 'fgl >= 5.7.0 && < 5.8.1.0'
+ 'fgl (>= 5.7.0 && < 5.8.1.0) || (>= 5.8.1.1 && < 5.9)'
+)
+
+RDEPEND="
+ >=dev-haskell/aeson-1.4.0:=[profile?] <dev-haskell/aeson-2.2:=[profile?]
+ >=dev-haskell/diff-0.4.0:=[profile?] <dev-haskell/diff-0.5:=[profile?]
+ >=dev-haskell/parsec-3.1.14:=[profile?] <dev-haskell/parsec-3.2:=[profile?]
+ >=dev-haskell/quickcheck-2.14.2:2=[profile?] <dev-haskell/quickcheck-2.15:2=[profile?]
+ >=dev-haskell/regex-tdfa-1.2.0:=[profile?] <dev-haskell/regex-tdfa-1.4:=[profile?]
+ >=dev-lang/ghc-8.10.6:=
+ || (
+ ( >=dev-haskell/fgl-5.7.0 <dev-haskell/fgl-5.8.1.0 )
+ ( >=dev-haskell/fgl-5.8.1.1 <dev-haskell/fgl-5.9 )
+ )
+ dev-haskell/fgl:=[profile?]
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-3.2.1.0
+"
diff --git a/dev-util/shellcheck/shellcheck-0.9.0.ebuild b/dev-util/shellcheck/shellcheck-0.9.0.ebuild
deleted file mode 100644
index 5346582375d4..000000000000
--- a/dev-util/shellcheck/shellcheck-0.9.0.ebuild
+++ /dev/null
@@ -1,30 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-# ebuild generated by hackport 0.8.0.0.9999
-
-CABAL_HACKAGE_REVISION=1
-CABAL_PN="ShellCheck"
-
-CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
-inherit haskell-cabal
-
-DESCRIPTION="Shell script analysis tool"
-HOMEPAGE="https://www.shellcheck.net/"
-
-LICENSE="GPL-3"
-SLOT="0/${PV}"
-KEYWORDS="amd64 ~arm64 ~ppc64 ~riscv ~x86"
-
-RDEPEND=">=dev-haskell/aeson-1.4.0:=[profile?] <dev-haskell/aeson-2.2:=[profile?]
- >=dev-haskell/diff-0.4.0:=[profile?] <dev-haskell/diff-0.5:=[profile?]
- >=dev-haskell/fgl-5.7.0:=[profile?] <dev-haskell/fgl-5.8.1.0:=[profile?]
- >=dev-haskell/quickcheck-2.14.2:2=[profile?] <dev-haskell/quickcheck-2.15:2=[profile?]
- >=dev-haskell/regex-tdfa-1.2.0:=[profile?] <dev-haskell/regex-tdfa-1.4:=[profile?]
- >=dev-lang/ghc-8.8.1:=
-"
-DEPEND="${RDEPEND}
- >=dev-haskell/cabal-3.0.0.0
-"