summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSv. Lockal <lockalsash@gmail.com>2024-03-24 19:17:45 +0000
committerSam James <sam@gentoo.org>2024-06-26 10:19:21 +0100
commit2d7749ed3a7049a788fceb0c1fab5cbaa1989aed (patch)
tree4f00b553b4a5258bd8b15298a5542f4d1b3446a8 /dev-util/rocminfo
parentsci-libs/hipSOLVER: add 6.1.1 (diff)
downloadgentoo-2d7749ed3a7049a788fceb0c1fab5cbaa1989aed.tar.gz
gentoo-2d7749ed3a7049a788fceb0c1fab5cbaa1989aed.tar.bz2
gentoo-2d7749ed3a7049a788fceb0c1fab5cbaa1989aed.zip
dev-util/rocminfo: drop 6.0.0-r1, enable python 3.13
Signed-off-by: Sv. Lockal <lockalsash@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-util/rocminfo')
-rw-r--r--dev-util/rocminfo/Manifest3
-rw-r--r--dev-util/rocminfo/files/rocminfo-6.0.0-python-3-12-support.patch34
-rw-r--r--dev-util/rocminfo/rocminfo-6.0.0-r1.ebuild49
-rw-r--r--dev-util/rocminfo/rocminfo-6.1.1.ebuild (renamed from dev-util/rocminfo/rocminfo-6.1.0.ebuild)2
4 files changed, 36 insertions, 52 deletions
diff --git a/dev-util/rocminfo/Manifest b/dev-util/rocminfo/Manifest
index 276b0c865c61..600de24040c9 100644
--- a/dev-util/rocminfo/Manifest
+++ b/dev-util/rocminfo/Manifest
@@ -1,3 +1,2 @@
DIST rocminfo-5.7.1.tar.gz 17302 BLAKE2B 395c695ed0b79c771c4240310c457aec893ffd889ddd551866753d2a0c8d4e98399672d74a7114a89faf8b1960dd54fbb0425ea00f7d15e5c740e33ce4046d0b SHA512 38726bc52bd045b6281cccd702706fd6ea5b57cdc421ad23106d5447a002f4b530e8d4e4430d2bb8eb30803af3bacdaf34646a965cea26f42d726bf7f6aafbab
-DIST rocminfo-6.0.0.tar.gz 17614 BLAKE2B f296d43103062c492c3a13a8f79a70ebe719126136abe38b020035f0e31819b9b25928aa538416ec9cc733a4e352e83fe8550d15c10f8071b7f889b361814fa6 SHA512 66de2e84b78f69a0c7d302e5432b08874374a45f7d577b158f23abbb40455c574868a7093e64c3a7d19e21dd13b48865a36bd626ef34b99ce52f3363bbb261a7
-DIST rocminfo-6.1.0.tar.gz 17734 BLAKE2B 3606c74b7b097a623175789e0ece4718da919bfdcc1b2852988d22ee67e036debbeba890e0667cb1ac2fb9ae3de05841a29fcf122a2feeed493bcdcbed021eea SHA512 417aad1bd65f056c43d264a5d0b62aa4c3b20ac4869a71efd5e6fa94a1cd4773112e75e1479efeae9342b8c222caba45213c75f1e8b8ece640bd47c934ace324
+DIST rocminfo-6.1.1.tar.gz 17740 BLAKE2B 6331054e1c8a59f2d4246c3fcb999afc28a8cabea9d5faf2b95d767f7153ab0930a633ee630cabc4472413a8a54fd9ef798516baa77e94aabda7687a36bf312f SHA512 d2982874ad09bfbe15418a88c2d3360f9bce262674d50f5858a08e52dd266e255f95116c85e069d7e8d28cb323164fb6999c5834163105f33e0c773aede4efdf
diff --git a/dev-util/rocminfo/files/rocminfo-6.0.0-python-3-12-support.patch b/dev-util/rocminfo/files/rocminfo-6.0.0-python-3-12-support.patch
new file mode 100644
index 000000000000..2b14e42e4705
--- /dev/null
+++ b/dev-util/rocminfo/files/rocminfo-6.0.0-python-3-12-support.patch
@@ -0,0 +1,34 @@
+Fix "SyntaxWarning: invalid escape sequence" SyntaxWarning in python 3.12+
+Bug: https://github.com/ROCm/rocminfo/issues/69
+--- a/rocm_agent_enumerator
++++ b/rocm_agent_enumerator
+@@ -92,7 +92,7 @@ def getGCNISA(line, match_from_beginning = False):
+ return result.group(0)
+ return None
+
+-@staticVars(search_name=re.compile("gfx[0-9a-fA-F]+(:[-+:\w]+)?"))
++@staticVars(search_name=re.compile(r"gfx[0-9a-fA-F]+(:[-+:\w]+)?"))
+ def getGCNArchName(line):
+ result = getGCNArchName.search_name.search(line)
+
+@@ -149,9 +149,9 @@ def readFromROCMINFO(search_arch_name = False):
+
+ # search AMDGCN gfx ISA
+ if search_arch_name is True:
+- line_search_term = re.compile("\A\s+Name:\s+(amdgcn-amd-amdhsa--gfx\d+)")
++ line_search_term = re.compile(r"\A\s+Name:\s+(amdgcn-amd-amdhsa--gfx\d+)")
+ else:
+- line_search_term = re.compile("\A\s+Name:\s+(gfx\d+)")
++ line_search_term = re.compile(r"\A\s+Name:\s+(gfx\d+)")
+ for line in rocminfo_output:
+ if line_search_term.match(line) is not None:
+ if search_arch_name is True:
+@@ -172,7 +172,7 @@ def readFromLSPCI():
+ except:
+ lspci_output = []
+
+- target_search_term = re.compile("1002:\w+")
++ target_search_term = re.compile(r"1002:\w+")
+ for line in lspci_output:
+ search_result = target_search_term.search(line)
+ if search_result is not None:
diff --git a/dev-util/rocminfo/rocminfo-6.0.0-r1.ebuild b/dev-util/rocminfo/rocminfo-6.0.0-r1.ebuild
deleted file mode 100644
index 4b5df7bd0033..000000000000
--- a/dev-util/rocminfo/rocminfo-6.0.0-r1.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{11..12} )
-inherit cmake python-r1
-
-if [[ ${PV} == *9999 ]] ; then
- EGIT_REPO_URI="https://github.com/RadeonOpenCompute/rocminfo/"
- inherit git-r3
-else
- SRC_URI="https://github.com/RadeonOpenCompute/rocminfo/archive/rocm-${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64"
- S="${WORKDIR}/rocminfo-rocm-${PV}"
-fi
-
-DESCRIPTION="ROCm Application for Reporting System Info"
-HOMEPAGE="https://github.com/RadeonOpenCompute/rocminfo"
-LICENSE="UoI-NCSA"
-SLOT="0/$(ver_cut 1-2)"
-
-RDEPEND=">=dev-libs/rocr-runtime-${PV}
- ${PYTHON_DEPS}"
-DEPEND="${RDEPEND}"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-PATCHES=(
- "${FILESDIR}/${PN}-6.0.0-detect-builtin-amdgpu.patch"
- "${FILESDIR}/${PN}-6.0.0_python-3.12.patch"
-)
-
-src_prepare() {
- sed -e "/CPACK_RESOURCE_FILE_LICENSE/d" -i CMakeLists.txt || die
- sed -e "/num_change_since_prev_pkg(/cset(NUM_COMMITS 0)" \
- -i cmake_modules/utils.cmake || die # Fix QA issue on "git not found"
- cmake_src_prepare
-}
-
-src_configure() {
- local mycmakeargs=( -DROCRTST_BLD_TYPE=Release )
- cmake_src_configure
-}
-
-src_install() {
- cmake_src_install
- rm "${ED}/usr/bin/rocm_agent_enumerator" || die
- python_foreach_impl python_doexe rocm_agent_enumerator "${BUILD_DIR}"/rocm_agent_enumerator
-}
diff --git a/dev-util/rocminfo/rocminfo-6.1.0.ebuild b/dev-util/rocminfo/rocminfo-6.1.1.ebuild
index 90ec124928f3..5f6dfcd53860 100644
--- a/dev-util/rocminfo/rocminfo-6.1.0.ebuild
+++ b/dev-util/rocminfo/rocminfo-6.1.1.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-PYTHON_COMPAT=( python3_{11..12} )
+PYTHON_COMPAT=( python3_{11..13} )
inherit cmake python-r1
if [[ ${PV} == *9999 ]] ; then