summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2022-12-20 09:25:23 +0000
committerPatrick Lauer <patrick@gentoo.org>2022-12-20 09:25:48 +0000
commit24d00ad348597c72a06a77dce699539289648ffd (patch)
tree07cb0993df908a289689d2718baba81c39867eea /dev-util/rocm_bandwidth_test
parentdev-util/hip: add 5.3.3 (diff)
downloadgentoo-24d00ad348597c72a06a77dce699539289648ffd.tar.gz
gentoo-24d00ad348597c72a06a77dce699539289648ffd.tar.bz2
gentoo-24d00ad348597c72a06a77dce699539289648ffd.zip
dev-util/rocm_bandwidth_test: add 5.3.3
Signed-off-by: Patrick Lauer <patrick@gentoo.org>
Diffstat (limited to 'dev-util/rocm_bandwidth_test')
-rw-r--r--dev-util/rocm_bandwidth_test/Manifest1
-rw-r--r--dev-util/rocm_bandwidth_test/rocm_bandwidth_test-5.3.3.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/dev-util/rocm_bandwidth_test/Manifest b/dev-util/rocm_bandwidth_test/Manifest
index e5e451b40341..ad31c1a27950 100644
--- a/dev-util/rocm_bandwidth_test/Manifest
+++ b/dev-util/rocm_bandwidth_test/Manifest
@@ -1 +1,2 @@
DIST rocm_bandwidth_test-5.0.2.tar.gz 38091 BLAKE2B bf9767d55a3400fa1bc95a638a9fd6debcd3b0cd8f5d698eb5d39568c5dc7321c5a63c6678b4bc91f7bd5ff9cee13da7800b3a7523a24a0ceae607be8b18b0b4 SHA512 b235838442dd12e0283b36168eed4853094f423b8b61e3f623be78133af9f89406fb83254972d5a622f90998450660165205deb95082cb49907f112f4de80942
+DIST rocm_bandwidth_test-5.3.3.tar.gz 38681 BLAKE2B 02a09ae869b507ad117e40e2daadd6e2acb2a365b12e5f601a4c8d6e55d3fb51de32feef9122bd532700b46843310ed83088842728a814f55695a3572e83d1d1 SHA512 155480284cdd1b0e42c62ab49f536ef12f2b9cbfcf0e8d076938cf0cf86872b536506a81e283b656ef1896d7d6e691e06145b2021593542755dd7460d08002c9
diff --git a/dev-util/rocm_bandwidth_test/rocm_bandwidth_test-5.3.3.ebuild b/dev-util/rocm_bandwidth_test/rocm_bandwidth_test-5.3.3.ebuild
new file mode 100644
index 000000000000..094ed9071adb
--- /dev/null
+++ b/dev-util/rocm_bandwidth_test/rocm_bandwidth_test-5.3.3.ebuild
@@ -0,0 +1,26 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Bandwidth test for ROCm"
+HOMEPAGE="https://github.com/RadeonOpenCompute/rocm_bandwidth_test"
+SRC_URI="https://github.com/RadeonOpenCompute/${PN}/archive/rocm-${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="NCSA-AMD"
+SLOT="0/$(ver_cut 1-2)"
+KEYWORDS="~amd64"
+
+DEPEND="dev-libs/rocr-runtime:="
+RDEPEND="${DEPEND}"
+BDEPEND=""
+
+S="${WORKDIR}/${PN}-rocm-${PV}"
+
+src_install() {
+ cmake_src_install
+
+ rm -rfv "${ED}"/usr/share/doc/rocm-bandwidth-test
+}