summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-08-04 10:14:16 +0100
committerSam James <sam@gentoo.org>2023-08-04 10:19:39 +0100
commitaf5c4a23e80083e4035e1f45cce365fb183bbc11 (patch)
treecb85cbd1391ca176beeb29eb464275926d6635d1 /dev-util/pkgconf
parentwww-client/vivaldi: Drop old 6.1.3035.111 (diff)
downloadgentoo-af5c4a23e80083e4035e1f45cce365fb183bbc11.tar.gz
gentoo-af5c4a23e80083e4035e1f45cce365fb183bbc11.tar.bz2
gentoo-af5c4a23e80083e4035e1f45cce365fb183bbc11.zip
dev-util/pkgconf: add 2.0.0 (and keyword it), drop 1.9.4, drop 1.9.5
1.9.x was a development branch, 2.0.0 is the production version of it. Changes from 1.9.5 are pretty minor in that nothing looks risky. Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-util/pkgconf')
-rw-r--r--dev-util/pkgconf/Manifest3
-rw-r--r--dev-util/pkgconf/pkgconf-1.9.5.ebuild70
-rw-r--r--dev-util/pkgconf/pkgconf-2.0.0.ebuild (renamed from dev-util/pkgconf/pkgconf-1.9.4.ebuild)3
-rw-r--r--dev-util/pkgconf/pkgconf-9999.ebuild3
4 files changed, 3 insertions, 76 deletions
diff --git a/dev-util/pkgconf/Manifest b/dev-util/pkgconf/Manifest
index e0985acad348..73821e1bd05f 100644
--- a/dev-util/pkgconf/Manifest
+++ b/dev-util/pkgconf/Manifest
@@ -1,3 +1,2 @@
DIST pkgconf-1.8.1.tar.xz 302372 BLAKE2B 591961f0b1fd185834fd8e2a672199cffc035139599817b1d56d571300d2aa800a719c9477aac4023dfade597ad3cc3b45360babe57498977568ee57077c7bbe SHA512 7a7d5204c1c9bfb6578bda56f299d1fa0300e69a133a65730b10ad77aefbf26fceb74ae77cecda326b3ed5db5736f27fcce94764b3a56d40f4bb99fecdc80bba
-DIST pkgconf-1.9.4.tar.xz 309164 BLAKE2B f0a99f9c7aaf571b14aa24b6dae441fb041d794294e560601232c03254e521a49a5724e41c5ada537f7933bb4831b63482896c8569a9502c8c5d841190e1d091 SHA512 079436244f3942161f91c961c96d382a85082079c9843fec5ddd7fb245ba7500a9f7a201b5ef2c70a7a079fe1aacf3a52b73de5402a6f061df87bcdcf0a90755
-DIST pkgconf-1.9.5.tar.xz 310068 BLAKE2B 196babfccbf34c10bf08eb52fe1a4366273e07fcc97fb42d117295bb1cb141811e6a0453597b4aab31dc2bfc06baf9b2507484c68cd6c7474c94e5676a743d0e SHA512 604853d8bb1c3ca14e696f83ac5b161e2592defb921d53e1c16cc949d4b9ecac2b12983c1fbbb3c89898323bda18c8749bff3946e049c8305a1a39a773265f09
+DIST pkgconf-2.0.0.tar.xz 310204 BLAKE2B c3c35724fddce349702e86046be5ddf359d8e1278e175ffbe46d6f202ef9cd14d41c76f3eb09de18ec2c67a45d7c45f0ba6e600d5873535aa63eb8361dd5df7e SHA512 6f40201a1e5d400358bb5218647d3160d42881c4a7d1bc3c8a75b306e47dc2ed1204268b2bdac0c14068e66cd3defe211570263274de7fedd0206b7dd343613d
diff --git a/dev-util/pkgconf/pkgconf-1.9.5.ebuild b/dev-util/pkgconf/pkgconf-1.9.5.ebuild
deleted file mode 100644
index 903ca97e2900..000000000000
--- a/dev-util/pkgconf/pkgconf-1.9.5.ebuild
+++ /dev/null
@@ -1,70 +0,0 @@
-# Copyright 2012-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit multilib multilib-minimal
-
-if [[ ${PV} == 9999 ]] ; then
- inherit autotools git-r3
- EGIT_REPO_URI="https://gitea.treehouse.systems/ariadne/pkgconf.git"
-else
- SRC_URI="https://distfiles.ariadne.space/${PN}/${P}.tar.xz"
- # Per release notes, 1.9.x is a testing/development release.
- #KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
-fi
-
-DESCRIPTION="pkg-config compatible replacement with no dependencies other than C99"
-HOMEPAGE="https://gitea.treehouse.systems/ariadne/pkgconf"
-
-LICENSE="ISC"
-SLOT="0/4"
-IUSE="test"
-
-RESTRICT="!test? ( test )"
-
-BDEPEND="
- test? (
- dev-libs/atf
- dev-util/kyua
- )
-"
-RDEPEND="!dev-util/pkgconfig"
-
-src_prepare() {
- default
-
- [[ ${PV} == 9999 ]] && eautoreconf
-
- MULTILIB_CHOST_TOOLS=(
- /usr/bin/pkgconf
- /usr/bin/pkg-config$(get_exeext)
- )
-}
-
-multilib_src_configure() {
- local myeconfargs=(
- --with-system-includedir="${EPREFIX}/usr/include"
- --with-system-libdir="${EPREFIX}/$(get_libdir):${EPREFIX}/usr/$(get_libdir)"
- )
-
- ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
-}
-
-multilib_src_test() {
- unset PKG_CONFIG_LIBDIR PKG_CONFIG_PATH
- default
-}
-
-multilib_src_install() {
- default
-
- dosym pkgconf$(get_exeext) /usr/bin/pkg-config$(get_exeext)
- dosym pkgconf.1 /usr/share/man/man1/pkg-config.1
-}
-
-multilib_src_install_all() {
- einstalldocs
-
- find "${ED}" -type f -name '*.la' -delete || die
-}
diff --git a/dev-util/pkgconf/pkgconf-1.9.4.ebuild b/dev-util/pkgconf/pkgconf-2.0.0.ebuild
index 903ca97e2900..742423bfd5ac 100644
--- a/dev-util/pkgconf/pkgconf-1.9.4.ebuild
+++ b/dev-util/pkgconf/pkgconf-2.0.0.ebuild
@@ -10,8 +10,7 @@ if [[ ${PV} == 9999 ]] ; then
EGIT_REPO_URI="https://gitea.treehouse.systems/ariadne/pkgconf.git"
else
SRC_URI="https://distfiles.ariadne.space/${PN}/${P}.tar.xz"
- # Per release notes, 1.9.x is a testing/development release.
- #KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
fi
DESCRIPTION="pkg-config compatible replacement with no dependencies other than C99"
diff --git a/dev-util/pkgconf/pkgconf-9999.ebuild b/dev-util/pkgconf/pkgconf-9999.ebuild
index 903ca97e2900..742423bfd5ac 100644
--- a/dev-util/pkgconf/pkgconf-9999.ebuild
+++ b/dev-util/pkgconf/pkgconf-9999.ebuild
@@ -10,8 +10,7 @@ if [[ ${PV} == 9999 ]] ; then
EGIT_REPO_URI="https://gitea.treehouse.systems/ariadne/pkgconf.git"
else
SRC_URI="https://distfiles.ariadne.space/${PN}/${P}.tar.xz"
- # Per release notes, 1.9.x is a testing/development release.
- #KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
fi
DESCRIPTION="pkg-config compatible replacement with no dependencies other than C99"