summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2021-12-01 04:48:34 -0500
committerIonen Wolkens <ionen@gentoo.org>2021-12-01 05:03:59 -0500
commitec624be3ead217db99e5496bd719fcf3f8a1115a (patch)
treefc2c13c6017f996406340b221abf24419e5a35fd /dev-util/maturin
parentapp-admin/exo: remove old (diff)
downloadgentoo-ec624be3ead217db99e5496bd719fcf3f8a1115a.tar.gz
gentoo-ec624be3ead217db99e5496bd719fcf3f8a1115a.tar.bz2
gentoo-ec624be3ead217db99e5496bd719fcf3f8a1115a.zip
dev-util/maturin: limit tests to 1 thread
Tentatively closing #825242 to see if it the issue resurfaces, can't reproduce anymore (so far) with 1 thread and tests aren't overly long (building tests will still uses normal thread count). Will revisit if upstream finds a solution. Closes: https://bugs.gentoo.org/825242 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'dev-util/maturin')
-rw-r--r--dev-util/maturin/maturin-0.11.5-r1.ebuild3
-rw-r--r--dev-util/maturin/maturin-0.12.3-r1.ebuild3
2 files changed, 4 insertions, 2 deletions
diff --git a/dev-util/maturin/maturin-0.11.5-r1.ebuild b/dev-util/maturin/maturin-0.11.5-r1.ebuild
index b2457d9b7798..fad51fc2c494 100644
--- a/dev-util/maturin/maturin-0.11.5-r1.ebuild
+++ b/dev-util/maturin/maturin-0.11.5-r1.ebuild
@@ -301,7 +301,8 @@ python_test() {
local -x PIP_CONFIG_FILE=${T}/pip.conf
local -x VIRTUALENV_SYSTEM_SITE_PACKAGES=1
- cargo_src_test -- --skip locked_doesnt_build_without_cargo_lock
+ cargo_src_test -- --skip locked_doesnt_build_without_cargo_lock \
+ --test-threads 1 #825242
}
python_install_all() {
diff --git a/dev-util/maturin/maturin-0.12.3-r1.ebuild b/dev-util/maturin/maturin-0.12.3-r1.ebuild
index bbced0e389c3..936b151e7a89 100644
--- a/dev-util/maturin/maturin-0.12.3-r1.ebuild
+++ b/dev-util/maturin/maturin-0.12.3-r1.ebuild
@@ -336,7 +336,8 @@ python_test() {
local -x PIP_CONFIG_FILE=${T}/pip.conf
local -x VIRTUALENV_SYSTEM_SITE_PACKAGES=1
- cargo_src_test -- --skip locked_doesnt_build_without_cargo_lock
+ cargo_src_test -- --skip locked_doesnt_build_without_cargo_lock \
+ --test-threads 1 #825242
}
python_install_all() {