summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2018-10-14 21:04:50 -0400
committerMike Gilbert <floppym@gentoo.org>2018-10-15 00:59:02 -0400
commit31b1852c8b72dbca9c03f9017c473b0f9add6dc0 (patch)
treebe92592e38d4f3ad41a7e7a882ff700b0027dff9 /dev-util/gn/gn-0.1479.ebuild
parentdev-util/perf: move in-package library to its dedicated directory (diff)
downloadgentoo-31b1852c8b72dbca9c03f9017c473b0f9add6dc0.tar.gz
gentoo-31b1852c8b72dbca9c03f9017c473b0f9add6dc0.tar.bz2
gentoo-31b1852c8b72dbca9c03f9017c473b0f9add6dc0.zip
dev-util/gn: bump to 0.1479
Package-Manager: Portage-2.3.50_p14, Repoman-2.3.11_p21 Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'dev-util/gn/gn-0.1479.ebuild')
-rw-r--r--dev-util/gn/gn-0.1479.ebuild63
1 files changed, 63 insertions, 0 deletions
diff --git a/dev-util/gn/gn-0.1479.ebuild b/dev-util/gn/gn-0.1479.ebuild
new file mode 100644
index 000000000000..fc369d2c0db0
--- /dev/null
+++ b/dev-util/gn/gn-0.1479.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 )
+
+inherit ninja-utils python-any-r1 toolchain-funcs
+
+DESCRIPTION="GN is a meta-build system that generates build files for Ninja"
+HOMEPAGE="https://gn.googlesource.com/"
+SRC_URI="https://dev.gentoo.org/~floppym/dist/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="vim-syntax"
+
+BDEPEND="
+ ${PYTHON_DEPS}
+ dev-util/ninja
+"
+
+PATCHES=(
+ "${FILESDIR}"/gn-gen-r2.patch
+)
+
+pkg_setup() {
+ :
+}
+
+src_configure() {
+ python_setup
+ tc-export AR CC CXX
+ unset CFLAGS
+ set -- ${EPYTHON} build/gen.py --no-sysroot --no-last-commit-position
+ echo "$@"
+ "$@" || die
+ cat >out/last_commit_position.h <<-EOF || die
+ #ifndef OUT_LAST_COMMIT_POSITION_H_
+ #define OUT_LAST_COMMIT_POSITION_H_
+ #define LAST_COMMIT_POSITION "${PV}"
+ #endif // OUT_LAST_COMMIT_POSITION_H_
+ EOF
+}
+
+src_compile() {
+ eninja -C out gn
+}
+
+src_test() {
+ eninja -C out gn_unittests
+ out/gn_unittests || die
+}
+
+src_install() {
+ dobin out/gn
+ einstalldocs
+
+ if use vim-syntax; then
+ insinto /usr/share/vim/vimfiles
+ doins -r tools/gn/misc/vim/{autoload,ftdetect,ftplugin,syntax}
+ fi
+}