summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2022-10-26 11:25:31 -0500
committerWilliam Hubbs <williamh@gentoo.org>2022-10-26 11:25:31 -0500
commite36c0208267a710bc6a05eb639aeb1fbc0b1316b (patch)
treebe94c656fe2b54400a4589a49b1c1370f597fbf6 /dev-util/gitlab-runner
parentsys-devel/gcc: keyword 13.0.0_pre20221023 for ~loong (diff)
downloadgentoo-e36c0208267a710bc6a05eb639aeb1fbc0b1316b.tar.gz
gentoo-e36c0208267a710bc6a05eb639aeb1fbc0b1316b.tar.bz2
gentoo-e36c0208267a710bc6a05eb639aeb1fbc0b1316b.zip
dev-util/gitlab-runner: add 15.4.1, 15.5.0
Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'dev-util/gitlab-runner')
-rw-r--r--dev-util/gitlab-runner/Manifest4
-rw-r--r--dev-util/gitlab-runner/gitlab-runner-15.4.1.ebuild67
-rw-r--r--dev-util/gitlab-runner/gitlab-runner-15.5.0.ebuild67
3 files changed, 138 insertions, 0 deletions
diff --git a/dev-util/gitlab-runner/Manifest b/dev-util/gitlab-runner/Manifest
index 6490b184585e..77ea9f165e13 100644
--- a/dev-util/gitlab-runner/Manifest
+++ b/dev-util/gitlab-runner/Manifest
@@ -6,3 +6,7 @@ DIST gitlab-runner-15.3.1-deps.tar.xz 141247556 BLAKE2B 8ea8e519efabfe54ff2a7047
DIST gitlab-runner-15.3.1.tar.gz 1306831 BLAKE2B 032115edb7b0ae23d4f4083e542aa645e4f76fea04a63c5d3018080314081c82b2250d292b26b507101b627314d9142b0109f33fa8289a583010a5d692a6c1cd SHA512 62e543983e184c2e57189042f8281696e0428841890aef8779fce125041dbbd0626807491e5ae589e367f6b725fb93e663d94da3a051e2a9ec681b959c4bd85f
DIST gitlab-runner-15.4.0-deps.tar.xz 141260140 BLAKE2B 876b71eb424bd5d65624718a666f7ff376b7d548056932e5f190974aa54bb7df5453b6fd6cb7a683a528035a8ddc0cec4a4a0f5481c491a6daac2e47edcba061 SHA512 1e940a8ac199b37d305d046f8f93d474e58881f76ee1e569d905cdc02f219dd5730ea7a4efc7ba297d5492996777daf2ec783788da9de6c5873528e0ed0d7c91
DIST gitlab-runner-15.4.0.tar.gz 1309792 BLAKE2B 54b4c94a79c86097116aa1bd4fe9e70da648ec379de606f36a3abbd15b7e9a2e3fc2174d9c8190bfc4925fd9c2ff1658440760ce9360db1a24319c50f506973f SHA512 85d4efb63a6bad62b3ca0a5fae365a7bf33d14e94e9b0ee24b71a87983bef7c92f83ecce78918024aee1bc8375e1910b731238b5f3f5b77e798d34f08283dd63
+DIST gitlab-runner-15.4.1-deps.tar.xz 138998168 BLAKE2B cee390b7955ee98eccffca6e878492f8c2de39d0ed4f4366ee9f0cc3fd016c625153dbe3b79d2cc6cf1e3a301f6ba8c2ad6a40b29d71408494a36788f07ba601 SHA512 c143883330b7a03ed4b77d49bded4423a44ef53ef8597294c99f067401c1ebe92ae69f8c8820181634b76e070d76304212ae1bcd957a7cbbee2167cca4dcfd64
+DIST gitlab-runner-15.4.1.tar.gz 1310885 BLAKE2B 9ba470444f7ba2db8be6044548dc9d7ee1ef8f50e63b0bc1ec2ba65ab9b5d035c5bc3a3bb50c4bf0d5acfa1329fe06fe9769f847aaa73c61ff116123f637e3f9 SHA512 1334c1d3fc830f49a0977cd43045105d013658361d55c807a99a2b36bd2b9dc4f3410185f13264a50a7cc13ab97d2191ec4a4daf45c10b24b42375dd6a2f6d13
+DIST gitlab-runner-15.5.0-deps.tar.xz 151900052 BLAKE2B cebea3c3a78030063e6fe551734bb22b80bd3200779195a5790ed3dfbe9519d81ce95dab912f62d84838026a8c7f2c7e9b89e16d7add598d1484bb5f5f182334 SHA512 a65c123dd6e53d663ed411ad0a95be0b0d9f7fafd36d73f893d3b55bf845df8b6048fca6ebda7210d87a43ab8868d7c41ba36d5f663d91050239d448b2719357
+DIST gitlab-runner-15.5.0.tar.gz 1327027 BLAKE2B edbf9db814ee3790decec9e14342fa6bff12433c3d20a45905dca294c655e09600af8adcf6da96635c8b65e7c7656aac61deec135dd153463e34b1bc198a5c10 SHA512 5452dce98144d9994221937c8ef8428fe6f23a8421fbf42479b9bf02244263cf42c1007349313076f3a003c2528c3d3b2e170a36523180889f2da61b2a52bd36
diff --git a/dev-util/gitlab-runner/gitlab-runner-15.4.1.ebuild b/dev-util/gitlab-runner/gitlab-runner-15.4.1.ebuild
new file mode 100644
index 000000000000..454e48ab945c
--- /dev/null
+++ b/dev-util/gitlab-runner/gitlab-runner-15.4.1.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit go-module systemd tmpfiles
+
+# make sure this gets updated for every bump
+GIT_COMMIT=526d939d
+
+DESCRIPTION="The official GitLab Runner, written in Go"
+HOMEPAGE="https://gitlab.com/gitlab-org/gitlab-runner"
+SRC_URI="https://gitlab.com/gitlab-org/gitlab-runner/-/archive/v${PV}/${PN}-v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~williamh/dist/${P}-deps.tar.xz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64"
+
+COMMON_DEPEND="acct-group/gitlab-runner
+ acct-user/gitlab-runner"
+DEPEND="${COMMON_DEPEND}"
+RDEPEND="${COMMON_DEPEND}"
+BDEPEND="dev-go/gox"
+
+DOCS=( docs CHANGELOG.md README.md config.toml.example )
+
+PATCHES=(
+ # https://gitlab.com/gitlab-org/gitlab-runner/-/merge_requests/3498
+ "${FILESDIR}"/build-for-arm64.patch
+ )
+
+S="${WORKDIR}/${PN}-v${PV}"
+
+src_compile() {
+ emake \
+ BUILT="$(date -u '+%Y-%m-%dT%H:%M:%S%:z')" \
+ GOX="${EPREFIX}/usr/bin/gox" \
+ REVISION=${GIT_COMMIT} \
+ VERSION=${PV} \
+ runner-bin-host
+}
+
+src_test() {
+ CI=0 ego test
+}
+
+src_install() {
+ dobin out/binaries/gitlab-runner
+ einstalldocs
+
+ newconfd "${FILESDIR}/${PN}.confd" "${PN}"
+ newinitd "${FILESDIR}/${PN}.initd" "${PN}"
+ systemd_dounit "${FILESDIR}/${PN}.service"
+ newtmpfiles "${FILESDIR}"/${PN}.tmpfile ${PN}.conf
+ keepdir /{etc,var/log}/${PN}
+ fperms 0700 /{etc,var/log}/gitlab-runner
+ fowners gitlab-runner:gitlab-runner /{etc,var/log}/${PN}
+}
+
+pkg_postinst() {
+ tmpfiles_process gitlab-runner.conf
+ [[ -f ${EROOT}/etc/gitlab-runner/config.toml ]] && return
+ elog
+ elog "To use the runner, you need to register it with this command:"
+ elog "# gitlab-runner register"
+ elog "This will also create the configuration file in /etc/gitlab-runner/config.toml"
+}
diff --git a/dev-util/gitlab-runner/gitlab-runner-15.5.0.ebuild b/dev-util/gitlab-runner/gitlab-runner-15.5.0.ebuild
new file mode 100644
index 000000000000..1a581387db33
--- /dev/null
+++ b/dev-util/gitlab-runner/gitlab-runner-15.5.0.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit go-module systemd tmpfiles
+
+# make sure this gets updated for every bump
+GIT_COMMIT=0d4137b8
+
+DESCRIPTION="The official GitLab Runner, written in Go"
+HOMEPAGE="https://gitlab.com/gitlab-org/gitlab-runner"
+SRC_URI="https://gitlab.com/gitlab-org/gitlab-runner/-/archive/v${PV}/${PN}-v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~williamh/dist/${P}-deps.tar.xz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64"
+
+COMMON_DEPEND="acct-group/gitlab-runner
+ acct-user/gitlab-runner"
+DEPEND="${COMMON_DEPEND}"
+RDEPEND="${COMMON_DEPEND}"
+BDEPEND="dev-go/gox"
+
+DOCS=( docs CHANGELOG.md README.md config.toml.example )
+
+PATCHES=(
+ # https://gitlab.com/gitlab-org/gitlab-runner/-/merge_requests/3498
+ "${FILESDIR}"/build-for-arm64.patch
+ )
+
+S="${WORKDIR}/${PN}-v${PV}"
+
+src_compile() {
+ emake \
+ BUILT="$(date -u '+%Y-%m-%dT%H:%M:%S%:z')" \
+ GOX="${EPREFIX}/usr/bin/gox" \
+ REVISION=${GIT_COMMIT} \
+ VERSION=${PV} \
+ runner-bin-host
+}
+
+src_test() {
+ CI=0 ego test
+}
+
+src_install() {
+ dobin out/binaries/gitlab-runner
+ einstalldocs
+
+ newconfd "${FILESDIR}/${PN}.confd" "${PN}"
+ newinitd "${FILESDIR}/${PN}.initd" "${PN}"
+ systemd_dounit "${FILESDIR}/${PN}.service"
+ newtmpfiles "${FILESDIR}"/${PN}.tmpfile ${PN}.conf
+ keepdir /{etc,var/log}/${PN}
+ fperms 0700 /{etc,var/log}/gitlab-runner
+ fowners gitlab-runner:gitlab-runner /{etc,var/log}/${PN}
+}
+
+pkg_postinst() {
+ tmpfiles_process gitlab-runner.conf
+ [[ -f ${EROOT}/etc/gitlab-runner/config.toml ]] && return
+ elog
+ elog "To use the runner, you need to register it with this command:"
+ elog "# gitlab-runner register"
+ elog "This will also create the configuration file in /etc/gitlab-runner/config.toml"
+}