summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2022-08-20 20:22:49 -0500
committerWilliam Hubbs <williamh@gentoo.org>2022-08-20 20:24:44 -0500
commit938a2af8e5a1b26c93249982cd5282f09807d286 (patch)
tree7455c98a2147f77d9f56fb97a7db45b0cc64cd6a /dev-util/gitlab-runner
parentwww-client/chromium: Stabilize 104.0.5112.101 amd64, #865839 (diff)
downloadgentoo-938a2af8e5a1b26c93249982cd5282f09807d286.tar.gz
gentoo-938a2af8e5a1b26c93249982cd5282f09807d286.tar.bz2
gentoo-938a2af8e5a1b26c93249982cd5282f09807d286.zip
dev-util/gitlab-runner: add 15.3.0
Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'dev-util/gitlab-runner')
-rw-r--r--dev-util/gitlab-runner/Manifest2
-rw-r--r--dev-util/gitlab-runner/gitlab-runner-15.3.0.ebuild67
2 files changed, 69 insertions, 0 deletions
diff --git a/dev-util/gitlab-runner/Manifest b/dev-util/gitlab-runner/Manifest
index f51ed402f516..dfc70e2581c7 100644
--- a/dev-util/gitlab-runner/Manifest
+++ b/dev-util/gitlab-runner/Manifest
@@ -10,3 +10,5 @@ DIST gitlab-runner-15.2.0-deps.tar.xz 141451528 BLAKE2B a77b8ca5c1570fc80f2d9f2b
DIST gitlab-runner-15.2.0.tar.gz 1291980 BLAKE2B 06194f6dfba94a1d071b3f29f3065475b8a9c08669ee0ec43917340a54dcdf79843f43b3f7fbe2e57560184c58166d7c107ed465742cfff05163faaca7ef491f SHA512 74f6a8941909c189bbde534d1cf5e1b8a60f595fa6046ca98dd4fb3a9f7406f988dfb9b2c2a6c777813fb24e4f5c23975f74163f7d5584b553acc4ca28ec8331
DIST gitlab-runner-15.2.1-deps.tar.xz 141242072 BLAKE2B 598850f3614772cad485a994ed156074c5f3aeb9b2bbf085fc9f77ded820d1facc6fafdc8b8fa9d763156cc15a454821113bfd47f2d943f2fb28723bc10a8cb7 SHA512 ac3f2b0272f9a6135c953b55e36623117c5e09c70ce88c2989fca4689eba699d12bffe6d5331876f942cfc69ae704b13f73f01ca9a681d02c113e2638420aad5
DIST gitlab-runner-15.2.1.tar.gz 1291638 BLAKE2B 7f2c7100ab5a7e670f8d50ea9dccd5f96b23b4e7ba60f928d732edc3a5f50b10afcfe9ffb052c4242ee401a21a0ddfad14e398a6a133ac093f3bbab84b620b0e SHA512 ed165fd95094dd00450bd2ffbbe876235849fdd98ff0ffc6ce635a103f426d4380573ef8c71f5a40d115fa6fe7ec9416b1c7b780f1563e8b3d4c4a09c02519f7
+DIST gitlab-runner-15.3.0-deps.tar.xz 141251000 BLAKE2B e72c597a10e78f234f7879ff77ecbd787f8a056116f70ed683b82af47bbc701157e23b1e72e9707598796b30e2a747813049984091058c97098436806b18ed66 SHA512 1956885e185854db3f4d6a40aaebd6c6010879d2baf6f910e5fae3f1ed2ba71c4896761a30a8b29c625af2770cb57e5a0a84dc85441096e9d66ed644cab76765
+DIST gitlab-runner-15.3.0.tar.gz 1306073 BLAKE2B cc7f1902e7cfc7577e936b411ae7f582c25757ed5d59cc5d61bb8f9c027ce292c7aac46788a44be78686f1705d5722373a9f5f2b295fd1eab2666e749fc50e06 SHA512 8eabe9a4fd04e46d4bf306dc202664e29f5cb12cba5d73820888957d694711702e026f79a84e1d5f5237cb3d1e7efed8e035129814dcc6354e708ee98e98cbe9
diff --git a/dev-util/gitlab-runner/gitlab-runner-15.3.0.ebuild b/dev-util/gitlab-runner/gitlab-runner-15.3.0.ebuild
new file mode 100644
index 000000000000..c58f8910bca6
--- /dev/null
+++ b/dev-util/gitlab-runner/gitlab-runner-15.3.0.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit go-module systemd tmpfiles
+
+# make sure this gets updated for every bump
+GIT_COMMIT=bbcb5aba7
+
+DESCRIPTION="The official GitLab Runner, written in Go"
+HOMEPAGE="https://gitlab.com/gitlab-org/gitlab-runner"
+SRC_URI="https://gitlab.com/gitlab-org/gitlab-runner/-/archive/v${PV}/${PN}-v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~williamh/dist/${P}-deps.tar.xz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+COMMON_DEPEND="acct-group/gitlab-runner
+ acct-user/gitlab-runner"
+DEPEND="${COMMON_DEPEND}"
+RDEPEND="${COMMON_DEPEND}"
+BDEPEND="dev-go/gox"
+
+DOCS=( docs CHANGELOG.md README.md config.toml.example )
+
+PATCHES=(
+ # https://gitlab.com/gitlab-org/gitlab-runner/-/merge_requests/3498
+ "${FILESDIR}"/build-for-arm64.patch
+ )
+
+S="${WORKDIR}/${PN}-v${PV}"
+
+src_compile() {
+ emake \
+ BUILT="$(date -u '+%Y-%m-%dT%H:%M:%S%:z')" \
+ GOX="${EPREFIX}/usr/bin/gox" \
+ REVISION=${GIT_COMMIT} \
+ VERSION=${PV} \
+ runner-bin-host
+}
+
+src_test() {
+ CI=0 ego test
+}
+
+src_install() {
+ dobin out/binaries/gitlab-runner
+ einstalldocs
+
+ newconfd "${FILESDIR}/${PN}.confd" "${PN}"
+ newinitd "${FILESDIR}/${PN}.initd" "${PN}"
+ systemd_dounit "${FILESDIR}/${PN}.service"
+ newtmpfiles "${FILESDIR}"/${PN}.tmpfile ${PN}.conf
+ keepdir /{etc,var/log}/${PN}
+ fowners gitlab-runner:gitlab-runner /{etc,var/log}/${PN}
+ fperms 0700 /{etc,var/log}/gitlab-runner
+}
+
+pkg_postinst() {
+ tmpfiles_process gitlab-runner.conf
+ [[ -f ${EROOT}/etc/gitlab-runner/config.toml ]] && return
+ elog
+ elog "To use the runner, you need to register it with this command:"
+ elog "# gitlab-runner register"
+ elog "This will also create the configuration file in /etc/gitlab-runner/config.toml"
+}