summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2023-01-23 12:13:18 -0600
committerWilliam Hubbs <williamh@gentoo.org>2023-01-23 12:13:49 -0600
commit31a948e5bee2fc392b67393ffee50dd87a7e73ad (patch)
tree16a868de767a574279be3a90139702f7ba4bdd2d /dev-util/gitlab-runner
parentdev-util/gitlab-runner: add 15.8.0 (diff)
downloadgentoo-31a948e5bee2fc392b67393ffee50dd87a7e73ad.tar.gz
gentoo-31a948e5bee2fc392b67393ffee50dd87a7e73ad.tar.bz2
gentoo-31a948e5bee2fc392b67393ffee50dd87a7e73ad.zip
dev-util/gitlab-runner: drop 15.5.1
Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'dev-util/gitlab-runner')
-rw-r--r--dev-util/gitlab-runner/Manifest2
-rw-r--r--dev-util/gitlab-runner/gitlab-runner-15.5.1.ebuild67
2 files changed, 0 insertions, 69 deletions
diff --git a/dev-util/gitlab-runner/Manifest b/dev-util/gitlab-runner/Manifest
index 55f463d8bf6a..838c818ab29d 100644
--- a/dev-util/gitlab-runner/Manifest
+++ b/dev-util/gitlab-runner/Manifest
@@ -1,5 +1,3 @@
-DIST gitlab-runner-15.5.1-deps.tar.xz 151906516 BLAKE2B 50dced95fd72259d31d0dd6513ddc6aa1001c5ca83a1a7b33028a9bc163c553e2bcd80dff32443813bb85f8d215b8ae73c8f75f0cfedeb6062cd6824f0415f04 SHA512 a74673d48de86e337b936b60a35820621f35e6a70087ebf59a8641c6f3f1d5e1ba7d0e3156815d8204c3dbcd349f5e903be4501f566e419f5ca46382cebbf15f
-DIST gitlab-runner-15.5.1.tar.gz 1327734 BLAKE2B 236d967a5ed18461d64429e078d3e40843e74aca96c23d572d070c13abf7ba3a3c7b4ba6046285d2aed261bdd2d9f5207f23a6b2c7c5cdc95c8cda5e0165f4c3 SHA512 c1ad7144bcea76b9ba20068bccc2b7a96240536cb0bdedcb0566674d05869c38f9052868314c3a58bddb1c6af304030fe0a2d055431d73eaff80ecb2226ea3e4
DIST gitlab-runner-15.6.2-deps.tar.xz 160098068 BLAKE2B b312f78c79a2ed47a6d5244307fee02fb9842b69873cb3babc14fd43b4f93a4e75cdbc9a3c13caa3e30f382ff5886b1c5a4957e0a07500c1a64e42e4b4ac3b33 SHA512 29f454cd15c24b74432e5759fbdd2d9ff7c42b0c516684c742752320701ffbfb87fb9381323d1bb0dca34f76150f48b9ac22362d2b0d287458898b381ff8d18f
DIST gitlab-runner-15.6.2.tar.bz2 1237158 BLAKE2B 2466e2688626e70cbb46386d9f963c95b1ac3fa6d5dbeeca02917524530588ad69e73cfe54adb1c70de1aa4eaa0599d8f9558fdc72432c87de2d6382ad56f060 SHA512 b9fce864b52ecc49441c4714beb9b6584cd30c1d55d3fea3e188b3154bd33931601111c4c869f354a75f97aeb803c68f8f1a3faa6c0b4d62ba85853f28ccdd25
DIST gitlab-runner-15.7.2-deps.tar.xz 160595944 BLAKE2B e0e942a2bf41b0f9092ff3c8670a0cc2a9dbcd961e89efb802f46c05f4d69c68db3c611ce16cafba4240419077b6021747d2b5f0c625c0a6975282a27c54482d SHA512 97bd14b384f49ec4b9c0e2a38597b86da45897d6a1bb61c0f2abf9e80f0f22aa07d17668599b7be340f3ffca8d340df51d50793d1b971ec1c6a0b798b97c1fec
diff --git a/dev-util/gitlab-runner/gitlab-runner-15.5.1.ebuild b/dev-util/gitlab-runner/gitlab-runner-15.5.1.ebuild
deleted file mode 100644
index ee38e0d1c049..000000000000
--- a/dev-util/gitlab-runner/gitlab-runner-15.5.1.ebuild
+++ /dev/null
@@ -1,67 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-inherit go-module systemd tmpfiles
-
-# make sure this gets updated for every bump
-GIT_COMMIT=7178588d
-
-DESCRIPTION="The official GitLab Runner, written in Go"
-HOMEPAGE="https://gitlab.com/gitlab-org/gitlab-runner"
-SRC_URI="https://gitlab.com/gitlab-org/gitlab-runner/-/archive/v${PV}/${PN}-v${PV}.tar.gz -> ${P}.tar.gz"
-SRC_URI+=" https://dev.gentoo.org/~williamh/dist/${P}-deps.tar.xz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 ~ppc64 ~riscv"
-
-COMMON_DEPEND="acct-group/gitlab-runner
- acct-user/gitlab-runner"
-DEPEND="${COMMON_DEPEND}"
-RDEPEND="${COMMON_DEPEND}"
-BDEPEND="dev-go/gox"
-
-DOCS=( docs CHANGELOG.md README.md config.toml.example )
-
-PATCHES=(
- # https://gitlab.com/gitlab-org/gitlab-runner/-/merge_requests/3498
- "${FILESDIR}"/build-for-arm64.patch
- )
-
-S="${WORKDIR}/${PN}-v${PV}"
-
-src_compile() {
- emake \
- BUILT="$(date -u '+%Y-%m-%dT%H:%M:%S%:z')" \
- GOX="${EPREFIX}/usr/bin/gox" \
- REVISION=${GIT_COMMIT} \
- VERSION=${PV} \
- runner-bin-host
-}
-
-src_test() {
- CI=0 ego test
-}
-
-src_install() {
- dobin out/binaries/gitlab-runner
- einstalldocs
-
- newconfd "${FILESDIR}/${PN}.confd" "${PN}"
- newinitd "${FILESDIR}/${PN}.initd" "${PN}"
- systemd_dounit "${FILESDIR}/${PN}.service"
- newtmpfiles "${FILESDIR}"/${PN}.tmpfile ${PN}.conf
- keepdir /{etc,var/log}/${PN}
- fperms 0700 /{etc,var/log}/gitlab-runner
- fowners gitlab-runner:gitlab-runner /{etc,var/log}/${PN}
-}
-
-pkg_postinst() {
- tmpfiles_process gitlab-runner.conf
- [[ -f ${EROOT}/etc/gitlab-runner/config.toml ]] && return
- elog
- elog "To use the runner, you need to register it with this command:"
- elog "# gitlab-runner register"
- elog "This will also create the configuration file in /etc/gitlab-runner/config.toml"
-}