summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2022-07-25 17:51:13 -0500
committerWilliam Hubbs <williamh@gentoo.org>2022-07-25 17:52:46 -0500
commit2ffb7038f358a23ec942e2299acbe92bcf3a9dc8 (patch)
treef40044ef23732b2a61581af80abc3e21a3e58e05 /dev-util/gitlab-runner
parentdev-util/gitlab-runner: add 15.1.1 (diff)
downloadgentoo-2ffb7038f358a23ec942e2299acbe92bcf3a9dc8.tar.gz
gentoo-2ffb7038f358a23ec942e2299acbe92bcf3a9dc8.tar.bz2
gentoo-2ffb7038f358a23ec942e2299acbe92bcf3a9dc8.zip
dev-util/gitlab-runner: add 15.2.0
Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'dev-util/gitlab-runner')
-rw-r--r--dev-util/gitlab-runner/Manifest2
-rw-r--r--dev-util/gitlab-runner/gitlab-runner-15.2.0.ebuild67
2 files changed, 69 insertions, 0 deletions
diff --git a/dev-util/gitlab-runner/Manifest b/dev-util/gitlab-runner/Manifest
index 146be42f1d05..c9b6186e9b31 100644
--- a/dev-util/gitlab-runner/Manifest
+++ b/dev-util/gitlab-runner/Manifest
@@ -6,3 +6,5 @@ DIST gitlab-runner-15.1.0-deps.tar.xz 140961872 BLAKE2B 711d2d7b75ab287216963a38
DIST gitlab-runner-15.1.0.tar.gz 1287049 BLAKE2B 76b1c5b535e328941741e55e460de158bcf54d8fa76bc70eba1eed63e7e892f126cdec992cf34ad4c0227f0ee5ba33ec06cea8ba4efd47bf36a540869f71b706 SHA512 7892b4ccfa5973f20deda365e337b8f70e159a9387b6823eada4b39a0cabcd078af08c9bc45e629aa432f49c72f71df6b04fc1cecb72bc2e9c9cd018fc04299b
DIST gitlab-runner-15.1.1-deps.tar.xz 140961196 BLAKE2B b3818572b2b5c01c78290572219c9788b0c61091eb4fd28978c08b5c9e11c14cf7b988b036598e93f543f9cd02bb22d1e2aa60ff905891948216943db5e28907 SHA512 fedc9bc87deed3a8cbaac8aa641d7a7175b535dca74d0bddc1b59b796a952a794bcfb456055ec19fc561cab060be9c5a09df322cf52daef7cb8152acb89e26b9
DIST gitlab-runner-15.1.1.tar.gz 1287440 BLAKE2B 0648132a2de277865d3899e460d0f444a26d3d827ee6efdf90abd195b243f31e138f57ca968c702089245e92763ab3cbb7e997fb8dc409a373689ed4e75016bc SHA512 538fc769e0aed90ffe4df9e2afe81b3c89f0c3d9ad9d48e52f12cde5df3b36326f054c1ab88c3d532cf573cdcd7a6e1733d3041cff133a665db5c91c4b8ddd0c
+DIST gitlab-runner-15.2.0-deps.tar.xz 141451528 BLAKE2B a77b8ca5c1570fc80f2d9f2bf3ebd9291997cd7f017eb1eaefb68d7bdba219d9fd14fb86c313a8c4fdc8169d81488244905d971a9b7c8393000f85253fd69ae2 SHA512 0aca328527b8b769015ea8177e22c8e232dd840b6427bf6e7ae7e0acccdc3cc6630ad10c2bc3fc42729107509fd37eaa5441846aa5f1ce934d68786335b960a4
+DIST gitlab-runner-15.2.0.tar.gz 1291980 BLAKE2B 06194f6dfba94a1d071b3f29f3065475b8a9c08669ee0ec43917340a54dcdf79843f43b3f7fbe2e57560184c58166d7c107ed465742cfff05163faaca7ef491f SHA512 74f6a8941909c189bbde534d1cf5e1b8a60f595fa6046ca98dd4fb3a9f7406f988dfb9b2c2a6c777813fb24e4f5c23975f74163f7d5584b553acc4ca28ec8331
diff --git a/dev-util/gitlab-runner/gitlab-runner-15.2.0.ebuild b/dev-util/gitlab-runner/gitlab-runner-15.2.0.ebuild
new file mode 100644
index 000000000000..c10a0b580009
--- /dev/null
+++ b/dev-util/gitlab-runner/gitlab-runner-15.2.0.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit go-module systemd tmpfiles
+
+# make sure this gets updated for every bump
+GIT_COMMIT=7f093137
+
+DESCRIPTION="The official GitLab Runner, written in Go"
+HOMEPAGE="https://gitlab.com/gitlab-org/gitlab-runner"
+SRC_URI="https://gitlab.com/gitlab-org/gitlab-runner/-/archive/v${PV}/${PN}-v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~williamh/dist/${P}-deps.tar.xz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+COMMON_DEPEND="acct-group/gitlab-runner
+ acct-user/gitlab-runner"
+DEPEND="${COMMON_DEPEND}"
+RDEPEND="${COMMON_DEPEND}"
+BDEPEND="dev-go/gox"
+
+DOCS=( docs CHANGELOG.md README.md config.toml.example )
+
+PATCHES=(
+ # https://gitlab.com/gitlab-org/gitlab-runner/-/merge_requests/3498
+ "${FILESDIR}"/build-for-arm64.patch
+ )
+
+S="${WORKDIR}/${PN}-v${PV}"
+
+src_compile() {
+ emake \
+ BUILT="$(date -u '+%Y-%m-%dT%H:%M:%S%:z')" \
+ GOX="${EPREFIX}/usr/bin/gox" \
+ REVISION=${GIT_COMMIT} \
+ VERSION=${PV} \
+ runner-bin-host
+}
+
+src_test() {
+ CI=0 ego test
+}
+
+src_install() {
+ dobin out/binaries/gitlab-runner
+ einstalldocs
+
+ newconfd "${FILESDIR}/${PN}.confd" "${PN}"
+ newinitd "${FILESDIR}/${PN}.initd" "${PN}"
+ systemd_dounit "${FILESDIR}/${PN}.service"
+ newtmpfiles "${FILESDIR}"/${PN}.tmpfile ${PN}.conf
+ keepdir /{etc,var/log}/${PN}
+ fowners gitlab-runner:gitlab-runner /{etc,var/log}/${PN}
+ fperms 0700 /{etc,var/log}/gitlab-runner
+}
+
+pkg_postinst() {
+ tmpfiles_process gitlab-runner.conf
+ [[ -f ${EROOT}/etc/gitlab-runner/config.toml ]] && return
+ elog
+ elog "To use the runner, you need to register it with this command:"
+ elog "# gitlab-runner register"
+ elog "This will also create the configuration file in /etc/gitlab-runner/config.toml"
+}