summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2023-10-26 15:42:59 -0500
committerWilliam Hubbs <williamh@gentoo.org>2023-10-26 15:44:11 -0500
commit1f507d8981f575c50c67f88b077bad9fa7415394 (patch)
treee94877d4eb5f01499cf0ac31c69db0491dcd4abe /dev-util/gitlab-runner
parentdev-util/gitlab-runner: drop 16.4.1 (diff)
downloadgentoo-1f507d8981f575c50c67f88b077bad9fa7415394.tar.gz
gentoo-1f507d8981f575c50c67f88b077bad9fa7415394.tar.bz2
gentoo-1f507d8981f575c50c67f88b077bad9fa7415394.zip
dev-util/gitlab-runner: drop 16.2.0
Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'dev-util/gitlab-runner')
-rw-r--r--dev-util/gitlab-runner/Manifest2
-rw-r--r--dev-util/gitlab-runner/gitlab-runner-16.2.0.ebuild62
2 files changed, 0 insertions, 64 deletions
diff --git a/dev-util/gitlab-runner/Manifest b/dev-util/gitlab-runner/Manifest
index 87543edd7a06..5d54bb9106f5 100644
--- a/dev-util/gitlab-runner/Manifest
+++ b/dev-util/gitlab-runner/Manifest
@@ -1,5 +1,3 @@
-DIST gitlab-runner-16.2.0-deps.tar.xz 200381264 BLAKE2B 61a9d094c251f299e98718883359433545294c8d862872bcf1b4558d721455bd83d867b198af4ec9a217b7e67be3084539955613640ff1829ae6c39a4bc82926 SHA512 9ffbee5f3b179d5a85f3d322b109b538c6c78874b80c5f593fbfe8ccb993fa0b2028665354f10a0774c7a130c12170bc53cc3315f34ec3b6941febc726e113df
-DIST gitlab-runner-16.2.0.tar.bz2 1361100 BLAKE2B 19df94ba47188ad696f79df56595f34a2fa7c82971549172a8acc65dd04228aed077d675f85e35e8731ae4b1e72003333ebe667772dce66e6bb17a0ad84a522b SHA512 75097c09b065c8486a5d23219dcb8e36c2baac254e0b09811dd725cf493d959d9b2d3a2c9c130d208a50c1355e19faa749a6d5bb58e1681f782279eca277605e
DIST gitlab-runner-16.3.3-deps.tar.xz 200547520 BLAKE2B 432ed7485f66ccd809e6bfbb7e6578fe10d6ef65843549d4fdccd85da2680b2f2b33b5dee829d926a237577996ba77fbd61b9d62e7db439fea47b8577b5c4dbd SHA512 a67a522c7109550e354dd892dc3bfedf73604128fe6d4a865d9dad1bc97dca2f8ae10eb8c85c225ddf9e6ebd285d266fdd26e73588ce72cbf372e2ed53c8cf07
DIST gitlab-runner-16.3.3.tar.bz2 1367409 BLAKE2B f74556c945fef53d490be2159b62e0ac663e6f71b3cf45bf6002f7c12ec250bff6ed20a3787f2d154dfe01b4dc082caf4650cdfc24002da9742518bf1238717a SHA512 184c616efff930922a33e1c0debd46cc720b355820279f370fe4827e9534c9c1956bb4e2d77489ab773b6a1da985fe2bbf7192c99ba8c39a47997fd3184557da
DIST gitlab-runner-16.4.2-deps.tar.xz 218831500 BLAKE2B e639c446aafd9095e07a6dd64b50e99035b42a9b16caec081ff9fc449df81b044afd57819bc320fcf050ff2b25be8d70aa56def7fdae29676f946b145a9b25a1 SHA512 28480ca7bf6b0c8abf655181530464baabc706513d5dd5bb0c58a6b2bc70ce4190eee3d568873e44fc256e523b27ef28f38af0ff16aa1f8f5b1828c44895d722
diff --git a/dev-util/gitlab-runner/gitlab-runner-16.2.0.ebuild b/dev-util/gitlab-runner/gitlab-runner-16.2.0.ebuild
deleted file mode 100644
index 4a6bef12c466..000000000000
--- a/dev-util/gitlab-runner/gitlab-runner-16.2.0.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-inherit go-module systemd tmpfiles
-
-# make sure this gets updated for every bump
-GIT_COMMIT=782e15da
-
-DESCRIPTION="The official GitLab Runner, written in Go"
-HOMEPAGE="https://gitlab.com/gitlab-org/gitlab-runner"
-SRC_URI="https://gitlab.com/gitlab-org/gitlab-runner/-/archive/v${PV}/${PN}-v${PV}.tar.bz2 -> ${P}.tar.bz2"
-SRC_URI+=" https://dev.gentoo.org/~williamh/dist/${P}-deps.tar.xz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 ~ppc64 ~riscv"
-
-COMMON_DEPEND="acct-group/gitlab-runner
- acct-user/gitlab-runner"
-DEPEND="${COMMON_DEPEND}"
-RDEPEND="${COMMON_DEPEND}"
-BDEPEND="dev-go/gox"
-
-DOCS=( docs CHANGELOG.md README.md config.toml.example )
-
-S="${WORKDIR}/${PN}-v${PV}"
-
-src_compile() {
- emake \
- BUILT="$(date -u '+%Y-%m-%dT%H:%M:%S%:z')" \
- GOX="${EPREFIX}/usr/bin/gox" \
- REVISION=${GIT_COMMIT} \
- VERSION=${PV} \
- runner-bin-host
-}
-
-src_test() {
- CI=0 ego test
-}
-
-src_install() {
- dobin out/binaries/gitlab-runner
- einstalldocs
-
- newconfd "${FILESDIR}/${PN}.confd" "${PN}"
- newinitd "${FILESDIR}/${PN}.initd" "${PN}"
- systemd_dounit "${FILESDIR}/${PN}.service"
- newtmpfiles "${FILESDIR}"/${PN}.tmpfile ${PN}.conf
- keepdir /{etc,var/log}/${PN}
- fperms 0700 /{etc,var/log}/gitlab-runner
- fowners gitlab-runner:gitlab-runner /{etc,var/log}/${PN}
-}
-
-pkg_postinst() {
- tmpfiles_process gitlab-runner.conf
- [[ -f ${EROOT}/etc/gitlab-runner/config.toml ]] && return
- elog
- elog "To use the runner, you need to register it with this command:"
- elog "# gitlab-runner register"
- elog "This will also create the configuration file in /etc/gitlab-runner/config.toml"
-}