summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2024-03-12 09:51:47 -0500
committerWilliam Hubbs <williamh@gentoo.org>2024-03-12 09:52:14 -0500
commit17c56aba712423120998cd5201995c1f887ce4a9 (patch)
tree8abab331bf7dacac1bbaaa626f29f5b9faffa934 /dev-util/gitlab-runner
parentxfce-base/xfce4-panel: Stabilize 4.18.6 arm64, #926563 (diff)
downloadgentoo-17c56aba712423120998cd5201995c1f887ce4a9.tar.gz
gentoo-17c56aba712423120998cd5201995c1f887ce4a9.tar.bz2
gentoo-17c56aba712423120998cd5201995c1f887ce4a9.zip
dev-util/gitlab-runner: add 16.9.1
Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'dev-util/gitlab-runner')
-rw-r--r--dev-util/gitlab-runner/Manifest2
-rw-r--r--dev-util/gitlab-runner/gitlab-runner-16.9.1.ebuild62
2 files changed, 64 insertions, 0 deletions
diff --git a/dev-util/gitlab-runner/Manifest b/dev-util/gitlab-runner/Manifest
index bbd8f186331e..96cba09ba9a6 100644
--- a/dev-util/gitlab-runner/Manifest
+++ b/dev-util/gitlab-runner/Manifest
@@ -10,3 +10,5 @@ DIST gitlab-runner-16.8.1-deps.tar.xz 236213628 BLAKE2B b270aa8f285c1c568c303832
DIST gitlab-runner-16.8.1.tar.bz2 1352201 BLAKE2B 931bb25d5aabae58af4c1808b5540ebe5bef49ee0fb663036e1faede8322bf3e8760419841aa7937db16d3145d2b9143f2da1b7783df5408697383763f709810 SHA512 054fcd54760e20e9ddb781876bc5bf8b491100495232ef5d54a0f4ce232b5eda603b6bec4b59143ccd17991416472746c0d5e563e7550f72c22ca28a3cc08535
DIST gitlab-runner-16.9.0-deps.tar.xz 236216888 BLAKE2B 206c9caf281b0527494cebc98f85e01060367a295632328b405f184bbe15b1381be69c6f2076d70f7e1a9461ec98a836a71fe0f380bafbae68857bd09d62a1bd SHA512 46edb66d2a1c42187ac89ecd7f7b2b8db366ac75a5ebeda9a716f970dd21e8df526ef70f7f24652ed69a103b97b4b0ac8e98e816cb606abec275449d54ca66c1
DIST gitlab-runner-16.9.0.tar.bz2 1361920 BLAKE2B 8dafc277531d441f6f55477221b8ef1b5c8a207697c438a1e647bcb034d557e66de270afb18ae01c829f25e0dd8b2bacd5aceb830b461cb65698f03ad51cca87 SHA512 442682b14e8166147bf13e07320b6440d078be19ee6da9b313aa12b1373eef07bd831cadb47aea6f637a1db8cd361177f05732bcf9e122b8a44bcf5263abff27
+DIST gitlab-runner-16.9.1-deps.tar.xz 87359096 BLAKE2B 788cac7b2c5ee4fe5d21fcdf75c3c854e97c21b418ec18d8543d275ce38e7072f5699aa8387f36239f5e27dbdea2a45754cb7a31fd707e0c69defd9b717c18d5 SHA512 1ad9d63648582dd1e0ce63470f9eec48382e2a2c528cb33394d7f825b4ca791a8e93fd124abb63fd8918f677b3b95b0eb622c694eaecadb00f372f8b028182a6
+DIST gitlab-runner-16.9.1.tar.bz2 1362513 BLAKE2B d129e5a98da11adae36b77dbc767849827961c21173a833bb7122046a4f69d31706cc11e8b799fd045dbc8b876bf4442b698999f8e8e694aea13e6f69c02cc4a SHA512 4fe41595025aad9141205e2e5cf4b3d7a3a859bb1dceca9a5b2f572f2d39272de6c89f6fbd1d2ce8e90657bde8d8e6a0dd004c446844d93bf6e572a45f21043e
diff --git a/dev-util/gitlab-runner/gitlab-runner-16.9.1.ebuild b/dev-util/gitlab-runner/gitlab-runner-16.9.1.ebuild
new file mode 100644
index 000000000000..6c86af23b3e8
--- /dev/null
+++ b/dev-util/gitlab-runner/gitlab-runner-16.9.1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit go-module systemd tmpfiles
+
+# make sure this gets updated for every bump
+GIT_COMMIT=782c6ecb
+
+DESCRIPTION="The official GitLab Runner, written in Go"
+HOMEPAGE="https://gitlab.com/gitlab-org/gitlab-runner"
+SRC_URI="https://gitlab.com/gitlab-org/gitlab-runner/-/archive/v${PV}/${PN}-v${PV}.tar.bz2 -> ${P}.tar.bz2"
+SRC_URI+=" https://dev.gentoo.org/~williamh/dist/${P}-deps.tar.xz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ~ppc64 ~riscv"
+
+COMMON_DEPEND="acct-group/gitlab-runner
+ acct-user/gitlab-runner"
+DEPEND="${COMMON_DEPEND}"
+RDEPEND="${COMMON_DEPEND}"
+BDEPEND="dev-go/gox"
+
+DOCS=( docs CHANGELOG.md README.md config.toml.example )
+
+S="${WORKDIR}/${PN}-v${PV}"
+
+src_compile() {
+ emake \
+ BUILT="$(date -u '+%Y-%m-%dT%H:%M:%S%:z')" \
+ GOX="${EPREFIX}/usr/bin/gox" \
+ REVISION=${GIT_COMMIT} \
+ VERSION=${PV} \
+ runner-bin-host
+}
+
+src_test() {
+ CI=0 ego test
+}
+
+src_install() {
+ dobin out/binaries/gitlab-runner
+ einstalldocs
+
+ newconfd "${FILESDIR}/${PN}.confd" "${PN}"
+ newinitd "${FILESDIR}/${PN}.initd" "${PN}"
+ systemd_dounit "${FILESDIR}/${PN}.service"
+ newtmpfiles "${FILESDIR}"/${PN}.tmpfile ${PN}.conf
+ keepdir /{etc,var/log}/${PN}
+ fperms 0700 /{etc,var/log}/gitlab-runner
+ fowners gitlab-runner:gitlab-runner /{etc,var/log}/${PN}
+}
+
+pkg_postinst() {
+ tmpfiles_process gitlab-runner.conf
+ [[ -f ${EROOT}/etc/gitlab-runner/config.toml ]] && return
+ elog
+ elog "To use the runner, you need to register it with this command:"
+ elog "# gitlab-runner register"
+ elog "This will also create the configuration file in /etc/gitlab-runner/config.toml"
+}