summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-util/fuzz
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-util/fuzz')
-rw-r--r--dev-util/fuzz/Manifest2
-rw-r--r--dev-util/fuzz/fuzz-0.6.ebuild32
-rw-r--r--dev-util/fuzz/metadata.xml10
3 files changed, 44 insertions, 0 deletions
diff --git a/dev-util/fuzz/Manifest b/dev-util/fuzz/Manifest
new file mode 100644
index 000000000000..aa5271a05185
--- /dev/null
+++ b/dev-util/fuzz/Manifest
@@ -0,0 +1,2 @@
+DIST fuzz-0.6.tar.gz 54431 SHA256 70fcd0d5b83f211f0a6fd9a95e1772c3e3aaaf83d533ae224a57812c00c0ce1b SHA512 87a9b103bb37c91937e2bd4667a33f3792c464f8464fe1f35b022d9c01a13255c7228ab80ce0bfac4ccfdab9a25238a5e1add00e9380cbeb24f95b686d18151b WHIRLPOOL f24f3162bee0e81751f7b64d71880a3e38d76a503b7f4f1d488ad96d89b745758f659cfd0f76c3a6f0c75a41f3500e7badd06557aafe8ce736e7a3a9bd27fd6f
+DIST fuzz_0.6-7.3.diff.gz 3004 SHA256 6f657d720c306bf29669a9cd9bf1523deb1710fde6284c9d865863b533c2bb11 SHA512 aef080a908269d44536071bb6d4a91560d7f357fb2145fc0d0369ea5997fa6a5c1b13b3fc673c370a61add5c76f40df3501f5103f2ac35ddce9662c9345e20af WHIRLPOOL 46ab73f38c4389cd4a82aaa7201a9a2252eee2777fd170ba6f48cbebf738b5178f4bc68df52e7b81b46fc5900969ccef8635946c7aafe3aeb6df7120719498b4
diff --git a/dev-util/fuzz/fuzz-0.6.ebuild b/dev-util/fuzz/fuzz-0.6.ebuild
new file mode 100644
index 000000000000..715a471bc43a
--- /dev/null
+++ b/dev-util/fuzz/fuzz-0.6.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Stress-tests programs by giving them random input"
+HOMEPAGE="http://fuzz.sourceforge.net/"
+DEB_P="${PN}_${PV}"
+DEB_PR="7.3"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz
+ mirror://debian/pool/main/${PN:0:1}/${PN}/${DEB_P}-${DEB_PR}.diff.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+DEPEND=">=sys-libs/readline-4.3"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ unpack ${P}.tar.gz
+ cd "${S}"
+ epatch "${DISTDIR}"/${DEB_P}-${DEB_PR}.diff.gz
+ tc-export CC
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc NEWS README ChangeLog AUTHORS
+}
diff --git a/dev-util/fuzz/metadata.xml b/dev-util/fuzz/metadata.xml
new file mode 100644
index 000000000000..ecbc43d4a42a
--- /dev/null
+++ b/dev-util/fuzz/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>robbat2@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">fuzz</remote-id>
+ </upstream>
+</pkgmetadata>