summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2021-02-17 15:20:59 +0700
committerAndrey Grozin <grozin@gentoo.org>2021-02-17 15:20:59 +0700
commit2737fc0172db0f101f5722d340deb71af9244482 (patch)
treedcb67e721736c29df7a5c73694ab13f8a2b1f7f8 /dev-util/diffuse
parentsys-fs/reiserfs-defrag: bump EAPI to 7 (diff)
downloadgentoo-2737fc0172db0f101f5722d340deb71af9244482.tar.gz
gentoo-2737fc0172db0f101f5722d340deb71af9244482.tar.bz2
gentoo-2737fc0172db0f101f5722d340deb71af9244482.zip
dev-util/diffuse: bump to 0.6.0
Suggested-by: Hans F. Nordhaug <hansfn@gmail.com> Closes: https://bugs.gentoo.org/770925 Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Andrey Grozin <grozin@gentoo.org>
Diffstat (limited to 'dev-util/diffuse')
-rw-r--r--dev-util/diffuse/Manifest1
-rw-r--r--dev-util/diffuse/diffuse-0.6.0.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/dev-util/diffuse/Manifest b/dev-util/diffuse/Manifest
index 1ed6f939a329..cfb672847399 100644
--- a/dev-util/diffuse/Manifest
+++ b/dev-util/diffuse/Manifest
@@ -1 +1,2 @@
DIST diffuse-0.5.0_alpha7.tar.xz 531124 BLAKE2B e97b8dd1b24253c4049dd4dc0f185049f030163945d822c3dbf6763f14eff270ed6bea82ae55b6cecaaa0f90976aab286db53c3f69d54f708e403832f8b2b1c1 SHA512 280d2c3c698affbf91b0e25ba658133999ea9b0199d8c165e2cef05210386f0fb3ff8611710903c1a3cb13aed01a648d04b3b8b13227f96803b74adbebf62adf
+DIST diffuse-0.6.0.tar.gz 621120 BLAKE2B c39cbe55edb6e1734d4db1343a0b0029ab146fe92ef4edc58cd6ea82bc6780e3f789d6765d2bddecd941fa458781c59ddde71a010f1b90d4ca238e6d6b233dc2 SHA512 fe9842738560dbefe9c546c8bba3f9f1cefcf4c327ad644430c512ec6bb1b4877986ca2b816af75226975eefa9b0f70120a4ed574e2ed90058b0a92380e8995a
diff --git a/dev-util/diffuse/diffuse-0.6.0.ebuild b/dev-util/diffuse/diffuse-0.6.0.ebuild
new file mode 100644
index 000000000000..fd3abb9089ba
--- /dev/null
+++ b/dev-util/diffuse/diffuse-0.6.0.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7..9} )
+PLOCALES="cs de es it ja ko pl pt ru sv th zh_CN zh_TW"
+inherit meson python-single-r1 l10n xdg-utils
+
+DESCRIPTION="A graphical tool to compare and merge text files"
+HOMEPAGE="http://diffuse.sourceforge.net/ https://github.com/MightyCreak/diffuse/"
+SRC_URI="https://github.com/MightyCreak/diffuse/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}"
+RDEPEND="${DEPEND}
+ $(python_gen_cond_dep '
+ dev-python/pygobject:3[${PYTHON_MULTI_USEDEP},cairo]
+ ')
+ x11-libs/gtk+:3[introspection]"
+# file collision, bug #279018
+DEPEND="${DEPEND}
+ !sci-chemistry/tinker"
+
+src_prepare() {
+ default
+ l10n_find_plocales_changes translations '' '.po'
+
+ rm_locale() {
+ rm -f translations/${1}.po
+ rm -rf src/usr/share/man/${1}
+ rm -rf src/usr/share/gnome/help/${PN}/$1
+ rm -f src/usr/share/omf/${PN}/${PN}-$1.omf
+ sed -e "/^${1}/d" -i translations/LINGUAS
+ }
+
+ l10n_for_each_disabled_locale_do rm_locale
+}
+
+src_install() {
+ meson_src_install
+ dodoc AUTHORS CHANGELOG.md README.md
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}