summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2016-04-02 23:48:10 +0200
committerDavid Seifert <soap@gentoo.org>2016-04-02 23:49:01 +0200
commitac593a5e7f2472d3651bdfb6551497449fd9853f (patch)
treeaebfc76ba5c046fe483b76c3ba723d3f5bff518d /dev-util/diffball
parentnet-irc/kvirc: Version bump (5.0_pre20160401144043). (diff)
downloadgentoo-ac593a5e7f2472d3651bdfb6551497449fd9853f.tar.gz
gentoo-ac593a5e7f2472d3651bdfb6551497449fd9853f.tar.bz2
gentoo-ac593a5e7f2472d3651bdfb6551497449fd9853f.zip
dev-util/diffball: add -std=gnu89 to CFLAGS to restore pre-GCC5 semantics
Gentoo-Bug: 548316 * EAPI=6 Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-util/diffball')
-rw-r--r--dev-util/diffball/diffball-1.0.1.ebuild18
1 files changed, 11 insertions, 7 deletions
diff --git a/dev-util/diffball/diffball-1.0.1.ebuild b/dev-util/diffball/diffball-1.0.1.ebuild
index ba9d483721f4..52393215d0aa 100644
--- a/dev-util/diffball/diffball-1.0.1.ebuild
+++ b/dev-util/diffball/diffball-1.0.1.ebuild
@@ -1,7 +1,11 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
+EAPI=6
+
+inherit flag-o-matic
+
DESCRIPTION="Delta compression suite for using/generating binary patches"
HOMEPAGE="https://diffball.googlecode.com/"
SRC_URI="https://diffball.googlecode.com/files/${P}.tar.bz2"
@@ -20,12 +24,12 @@ DEPEND="${RDEPEND}
# Invalid RESTRICT for source package. Investigate.
RESTRICT="strip"
-src_compile() {
- econf $(use_enable debug asserts)
- emake || die "emake failed"
+src_prepare() {
+ # fix bug 548316 by restoring pre-GCC5 inline semantics
+ append-cflags -std=gnu89
+ default
}
-src_install() {
- emake DESTDIR="${D}" install || die
- dodoc AUTHORS ChangeLog README TODO
+src_configure() {
+ econf $(use_enable debug asserts)
}